Hi all,

I have tried to run the service zwave.update_config many times without luck in The reason for me to run it is that I have the new Heatit Z-Trm2 thermostat. This has a new config\template file:

For some reason I am not able to update the zwfg file. When including the thermostat it is automatically using the old configuration. I have tried to edit the zwfg file manually by deleting everything about the node and then restart It is still using the old config file.

I have run the service zwave.update several times. Waiting everything from 5 minutes to a day before trying to add the thermostat.

What can I do?

Interesting. I didn’t know this existed.

Attempt to update OZW configuration files from git to support newer devices. After you run this, wait a few minutes then stop Home Assistant. You can now back up your zwcfg_*.xml file, then delete the relevant entries from your zwcfg_*.xml (between and including <Node id="?"> and </Node> ), and finally start Home Assistant.

What I have done in the past is to stop Home Assistant, backup the xml file, and then manually make the changes for that node to match the new config file from GitHub.

Well, if you manually need to enter everyting then the zwave.update_config does not work properly. Should I make an issue on github for it?

Honestly, I have never tried it before, but then it has been almost a year since I added something that needed newer templates. But it is worth opening if you don’t find someone that has experience on the forum with a fix. I simply offered up a simple work around if (like me) you want to get it working sooner.

I was attempting this today also, ended up doing this instead: