Zwave2mqtt- cannot connect to local mqtt broker

Can’t figure out why zwave2mqtt isn’t able to connect to the local mqtt broker. I’ve tried using HASS admin credentials, setting up local users, anonymous (after setting the ACLs in MQTT Broker) but it still gets connection refused messages. I don’t even see the connection attempt in the MQTT Broker log, only the zwave log. Am I missing a setting somewhere? I referred to the simple Z2M setup on here to get this far.

2020-06-03T01:23:31.108Z z2m:Mqtt MQTT client closed
2020-06-03T01:24:31.118Z z2m:Mqtt MQTT client reconnecting
2020-06-03T01:24:31.120Z z2m:Mqtt connect ECONNREFUSED
2020-06-03T01:24:31.120Z z2m:Mqtt MQTT client closed
[20:16:49] INFO: Setup mosquitto configuration
[20:16:49] WARNING: SSL not enabled - No valid certs found!
[20:16:49] INFO: No local user available
[20:16:50] INFO: Initialize Add-on services
[20:16:50] INFO: Initialize Home Assistant discovery
[20:16:50] INFO: Start Mosquitto daemon
1591147010: Loading config file /share/mosquitto/acl.conf
1591147010: mosquitto version 1.6.3 starting
1591147010: Config loaded from /etc/mosquitto.conf.
1591147010: Loading plugin: /usr/share/mosquitto/
1591147010: |-- *** auth-plug: startup
1591147010:  ├── Username/password checking enabled.
1591147010:  ├── TLS-PSK checking enabled.
1591147010:  └── Extended authentication not enabled.
1591147010: Opening ipv4 listen socket on port 1883.
1591147010: Opening ipv6 listen socket on port 1883.
1591147010: Opening websockets listen socket on port 1884.
1591147010: Warning: Mosquitto should not be run as root/administrator.
1591147011: New connection from on port 1883.
[INFO] found homeassistant on local database
1591147011: New client connected from as auto-8892E102-B365-8E5C-7EAE-617048A4D037 (p2, c1, k60, u'homeassistant').

states that pot 1883 on localhost is refusing your connection. IS your broker really listening on your HA host or only within its own Docker host?

How do I tell? I’m really new to HA and still figuring out how things work.