Zwave2mqtt problem


I have proxmox and installed Hassos with this script:

I have setup mosquitto and can send receive commands from node-red when i send test commands

I have problem to get the Zwave2mqtt 0.7 to work.
Im running it in proxmox and i can see my zwave dvices in the control panel.

Can someone help me with the setup. I dont understand whats wrong. I belive it is in the control panel for Zwave2mqtt

Kind regards

I don’t use HassIO/HassOS, but I do use Mosquitto that I installed myself and I do use Zwave2MQTT; So I may not understand completely the setup you have.
My first thought is centered around the authentication.

For the ZWave2MQTT you have the ‘Auth’ enabled, but have you entered a username and password?
I would think for the MQTT Broker you also would need a username and password configured too but doesn’t appear to be there.

Anyway as a first test, turn off all authentication, both Zwave2MQTT and the Broker, just to see if Zwave2MQTT is talking to the broker.

I have entered password and user that is auto generated in mosquitto. (A very long random password)

I have also tried to disable password in Zwave2 mqtt without success.

I dont see any units in HomeAssistant.

Do I need to add the units that are found in Zwave2mqtt manualy into config files for Homeassistant?

Hmmm…I’m surprised ZWave2MQTT will not let you turn off authentication…
I’m sorry that I don’t know enough about the HassOS implementation of the mosquitto Broker to help. Just reading the wiki, it seems by default the mosquitto broker add-on (I assume you’re using the mosquitto add-on) picks up the username/password of existing HA users, and one of these users (and password) you would select to enter for ZWave2mqtt’s mqtt broker authentication settings. I couldn’t find anything about an auto-generated password, so I may be off base somehow.

As for needing to add units manually for HA, most users have success using the auto-discovery feature of zwave2mqtt, so no should not need to manually configure zwave units into HA if you do auto-discovery.

Can you share your setup in MQTT and Zwave2mqtt

As for my ZWave2mqtt, My MQTT settings are like yours except I have configured a username and password (which appears under the “Store”/“Auth” buttons), and these settings match that username and password I have setup at mosquitto to allow clients to access it.

As for my mosquitto settings, I don’t use the Add-on, and so the configuration schema can’t be compared. I would suggest you look at the wiki I referred to earlier, and search the Forum for “mosquitto broker add on” (such as this one).