ZWaveJSMQTT: Fibaro RGBW doesn't show color control wheel


I managed to migrate to ZWaveJSMQTT (running in separate docker container) - everything seems to work except being able to change the color of the Fibaro RGBW Controllers. It’s recognised as a normal light (switch on/off and changing the brightness). The color wheel is not available.

brightness: 255
friendly_name: RGBW Controller: Current value
supported_features: 33

In the ZWaveJSMQTT Control Panel I checked various settings:

  • [6-112-0-6] Associations command class choice => Normal (RGBW) Color Control Set
  • [6-112-0-42] Command class reporting Outputs status change => input and controller actions

Anyone an idea?

Same problem with Fibaro RGBW and the new zWave Js integration. Except I get 5 dimmers. 1 controlls ‘the main’ the other 4 control RGBW. I can set the dimmer on each to adjust the intensity of each color, the combination making the final color I’m after. I use ‘the main’ controller switch as off and on.

On the legacy zwave, the same thing occured, except ‘the main’ controller had the color wheel and automatically adjusted the other 4.

Yes, I’m seeing the same. The colour wheel was present with the OpenZwave (beta) integration, but has now gone with Z-Wave JS. It seems as though the same 5 dimmers are available as before, and like Doug, I can use them to control the LEDs, but for some reason with the Z-Wave JS integration, the colour wheel has gone.

One other thing, the LEDs 1:Power entity is no longer showing the current power consumption, but seems to be linked to something else.

I have the same behaviour as both of you - also getting 5 dimmers of which one acts as the main switch. Appears to be a bug or feature that hasn’t been build in yet? I found this topic which is not exactly the same but similar - . I checked whether the recommended lines are in the *.values.jsonl, which it is.


Do any of you know where I to submit this as a bug/feature request?

I found the issue being reported here - doesn’t seem to be a perm. fix yet.

1 Like

Something else odd; I looked at the list of entities for the RGBW controller that I had when running OpenZwave (beta), and instead of 5 dimmers, there were actually 6 Light controls:

Node 14:

  • LEDs 1 Woonkamer: Instance 1: Level

  • LEDs 1 Woonkamer: Instance 2: Level

  • LEDs 1 Woonkamer: Instance 3: Level

  • LEDs 1 Woonkamer: Instance 4: Level

  • LEDs 1 Woonkamer: Instance 5: Level

  • LEDs 1 Woonkamer: Instance 6: Level

  • LEDs 1 Woonkamer: Electric - kWh

  • LEDs 1 Woonkamer: Electric - W

  • LEDs 1 Woonkamer: Power

I see that this issue has now been raised for the core ZWave JS as well:

1 Like

I can confirm that on the following versions, the color wheel is working for the FGRGBW-442.

zwavejs2mqtt: 4.2.1
zwave-js: 7.4.0
homeassistant: 2021.5.4


Hmm, I’m still not seeing the color wheel for my FGRGBW-442 here… The color wheel entity is still showing as unavailable:

I am running later versions than you are, but I don’t think that there has been a regression here, since at one time I would have been running the same versions as yourself, and I have never seen the color wheel since I moved from OpenZwave (beta) to ZWaveJS…

zwavejs2mqtt: 4.3.0
zwavejs driver: 7.5.0
zwavejs server: 1.5.0
Home Assistant Core: 2021.5.5

No, it is not working just by upgrading. I’m on the latest everything. zwavejs2mgtt, zwave-js under the hood, HA.
No color wheel still. What steps did you take to get it working?

Nothing specific, just using the latest dockers for HA and ZWJS2MQTT. I enabled the five switches and when I switch on the main switch, I also start the white led with an automation (don’t know if that is still needed, it was required before the wheel started working.

The configuration in ZWJS2MQTT is the following:

Your config screen in the zwavejsmgtt admin looks entirely different than mine. I re-interviewed, but didn’t help. I actually have a color picker in the admin tool.

Strange…version info of the device says this:

Are you sure you have the 442?

I am not sure, I don’t know to what 442 is referring.
What I will say is it worked on the now deprecated native zwave solution.

441 is the Fibaro RGBW Controller, 442 is the successor, the Fibaro RGBW Controller 2. I have the 442, which is shown in both applications. Don’t see that in Geoff’s screenshot, which does show the same FW version you have. So I think you have the 441.

Makes sense.

All of a sudden my 442 started working. I already had a colorwheel, it just did not do anything when selection colors… I does now… not sure why, only updated regular things as they came out…

But now a new question, how do I get the pre-programmed sequences activated ?
I see them and can activate from Z-Wave JS Controlpanel, but not (yet) in HomeAssistant itself.

I would like to use them via NodeRed to activate for example when the doorbell rings…
but the available items in developer options to do seem to do much with regards to the sequences:

Still not working on 441, firmware 25.25