Zwavejsmqtt set parameters not working

I cannot set zwave parameters on zwavejsmqtt in most recent version using the “zwave_js.set_config_parameter” service. Also cannot set it using the “Custom Configuration” dialog in zwavejsmqtt settings.

Using the Configuration menu for the device (screen shot above), I can get the value using the green “GET” box, which then creates a setting with the little “Arrow” for that parameter. Using that “Arrow” dialog, I can then set the device. Here is the log output when that works:

2022-09-06 08:41:12.539 INFO ZWAVE: Calling api writeValue with args: [
{ nodeId: 19, commandClass: 112, property: 32 },
[length]: 3
2022-09-06 08:41:12.545 INFO ZWAVE: Writing 1345 to 19-112-0-32

However, using the “Custom Configuration” dialog with the blue “SET” dialog, I get an error:

50-0-value-66049 13.415 => 13.568
2022-09-06 08:21:39.262 INFO ZWAVE: Calling api sendCommand with args: [
{ nodeId: 19, commandClass: 112 },
[ 32, 1345, 1, [length]: 3 ],
[length]: 3
2022-09-06 08:21:39.269 INFO ZWAVE: options is not a ConfigurationCCAPISetOptions (ZW0322) sendCommand undefined

I get a similar error when I try to use the “zwave_js.set_config_parameter” service.

Any ideas why?

Try re-interviewing the device. What is it?

Did you figure this out? I am having the same issue, sorta. I am going through Node red and using mosquitto to set parameters, but I get same error now

From my MQTT explorer:

Your screenshot is clipped so it’s impossible to troubleshoot your problem. Copy and paste the response and post it as text instead. Especially your command payload.

Even with the image being clipped, I can see that you are setting the args incorrectly. The set function takes a single object, not a list of parameters. That was a change to the driver, sometime over a month ago. When using the CC API sometimes you have to look at the source code (and understand TypeScript) to figure out what the parameters are.

"args": [
  { "commandClass": 112, "nodeId": 67 },
  [ { parameter: 16, value: XXXXX, valueSize: Y } ]

You’ll have to fill in the value and valueSize since I can’t see what those are supposed to be.

Sweetness! Thank you!!

NVM, figured it out.