0.100: Better Plex, Bye JSON, HERE Travel time.

Used snapshots feature from Hassio. I automate it to make those backups weekly.

Same for me. Was so bad that the app was crashing on the background while trying to update my position and giving constant crash alerts.

Then the sensor is broken, it doesn’t understand software version numbering.

Mine too, I’ve opened an issue on GitHub https://github.com/home-assistant/home-assistant/issues/27527

1 Like

For everyone having HomeKit issues, do consider restarting your router in addition to the other usual fixes (like removing/re-adding the bridge to HomeKit, deleting the HomeKit.state file, etc)

After upgrading to iOS 13 I tried everything to get HomeKit working again and it ended up being a simple router restart that fixed it.

I not sure what it is, but I think the issue is bigger than that.
I’m running iOS 13 since June (Beta), now running final version and never before had issues with Home Assistant or Home Assistant Companion App.

App was crashing on my phone while I was on the streets.

Since my whole setup relies so much on Homekit I had to rush and fix it and I wasn’t able to figure out the issue.

I did try re-adding HA to HomeKit multiple times, and also deleting all HomeKit files in Hassio before doing it.

Only detail I can give is that bridge would add to Homekit, and as you started assigning accessories to rooms it would crash Home.app. Then bridge would be there with 0 accessories.

Have you tried adding the bridge in safe mode?

Also - “I think the problem is bigger than that” - have you actually tried it? I couldn’t figure out WHY it worked, but it did

I get the exact same error and had to downgrade HA as well.

The error I get is:

Error loading custom_components.sonoff. Make sure all dependencies are installed
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/loader.py", line 346, in _load_file
    module = importlib.import_module(path)
  File "/usr/local/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/config/custom_components/sonoff/__init__.py", line 10, in <module>
    from homeassistant.util.async_ import run_coroutine_threadsafe
ImportError: cannot import name 'run_coroutine_threadsafe' from 'homeassistant.util.async_' (/usr/src/homeassistant/homeassistant/util/async_.py)

Read further up, you need to update the sonoff custom component

Same here. I had to revert because the app keeps crashing. Sadly…

I always run the Configuration checker before updating. I got the following warning (but I ignored it…)

Component error: mobile_app - No module named 'hass_nabucasa'

Maybe there the issue is related to this error?

As I understand it, the iOS app crash is because the library it uses to check the Home Assistant version can’t handle version numbers greater than 99.

That warning you are seeing looks like this issue. You may be able to get rid of it by adding cloud: or default_config: (the default config options include cloud) to your configuration.yaml.

Had only older snapshosts/backups…
I downgraded it through SSH and command:
hassio homeassistant update --version 0.99.3

I am also getting this:

2019-10-12 08:28:48 ERROR (MainThread) [homeassistant.config] Unable to import smartthings: No module named 'hass_nabucasa'
2019-10-12 08:28:48 ERROR (MainThread) [homeassistant.setup] Setup failed for smartthings: Invalid config.

Did you ever find a fix yet?

But… Isn’t 0.10 the same as 0.100 or was my math teacher wrong?

Sure, if this was decimal, but last I checked 0.99.3 isn’t a valid decimal :wink:

This is Semantic Versioning, where the . separates the components of the version number: Major, Minor, Patch level


Thanks for the link. But since I have a Nabucasa subscription, cloud: was already enabled in my configuration. However, I’ve tried if the problem could be solved by deleting it, restarting, add it again and restart again. But this makes no difference…

So, that means i.m.h.o. that we need to wait for an update of the app…

Yes, the hass_nabucasa python module was missing.
In my setup, I’m using Python virtual environment, so all I had to do was to activate the environment and simply run $ pip install hass_nabucasa. And reboot.

Reference: https://github.com/home-assistant/home-assistant/issues/27421

1 Like

Good point

I had to revert back to 0.99.3.

100.1 somehow broke my hassio. It was running for 10min and then always stopped. Nothing in the logs. 99.3 is stable again, even though i had to delete and resinstall some addons after the snapshot.

If it helps this is the way I do it:

  ## checks the installed version of Home Assistant
  - platform: version

  ## checks for the latest available version of Home Assistant
  - platform: scrape
    resource: https://www.home-assistant.io
    name: HA Online Version
    select: ".current-version h1"
    value_template: '{{ value.split(":")[1] }}'

  - alias: HASS Update Available Display
      platform: time_pattern
      hours: '/1'
      minutes: 00
      seconds: 00
      service_template: >-
        {% if (states.sensor.ha_online_version.state != states.sensor.current_version.state) %}
        {% else %}
        {% endif %}
      entity_id: input_boolean.bool_3

then I just use a conditional card to display the status of the input boolean in the frontend when it’s on.