0.112: Making things faster; Logbook & History

I know you gave a helpful reply but seriously, HA itself is a solution to 1st World Problems and I didn’t think the original request was unreasonable. If it could be done. Which it can’t. That fact was accepted without drama…



Can you explain me, the best way to do? I am not really an expert…

To view the error log go to http://homeassistant.local:8123/config/logs

To add some system monitor sensors read this:

At a minimum you should monitor the disk use, memory use and processor use.

same problem, any solution?

Thank you, got it working

I’m getting way too slow speedtest results…

Completely smooth update from 0.111.4 to 0.112.4 - loving the speed! My thanks to all who contributed.

That’s probably because it tests multiple times a minute, slowing everything down/using a lot of resources. Try to re-apply the settings (must be done after every restart).

Yeah have done too, after reboot changed the update frequency and server, but still waaaay to slow

Tp-Link integration for a hs110 monitored PowerPoint seems to have dropped off the daily energy attribute? Worked previously in 0.112.3 or maybe 0.112.2

The attribute was called ‘today_energy_kwh’.

Be great if this could be added back in as it was really useful to see the daily energy use.

NOTE : Found out that this is still working but the switch needs internet access after a power outage, I assume to set the current time which is used to set the daily capture. My switch daily energy started working again after temporarily connecting to the internet again (and then disabling).

All I can say is WOW. I wish HA had ran this fast this past year and half I’ve been using it. Instant response for everything. Yea, it is always a bit snappier after a full reboot of the supervisor and core but this is on another level. Still I’ll report back in a week on how stable and responsive it still is. Generally that was how long it would run before it became unstable. And I’d either have to do a clean reboot or a hard and dirty reboot with a lot of hoping.

Thanks fpr this, these Monitors can i now see in the Logs?

Add the sensors to some history graph cards and keep an eye on them.

So… upgrade not going well.
Home Assistant Core 0.112.4
You are currently running version 0.111.4

– Error: Unknown Error, see logs

Turns out HA doesn’t check if there is room to download and perform the update on the disk before trying to update…

1 Like

This are the logs entries:

2020-07-11 22:40:54 ERROR (MainThread) [homeassistant.setup] Setup failed for bmw_connected_drive: unknown error
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/setup.py", line 145, in _async_setup_component
    component = integration.get_component()
  File "/usr/local/lib/python3.7/site-packages/homeassistant/loader.py", line 313, in get_component
    cache[self.domain] = importlib.import_module(self.pkg_path)
  File "/usr/local/Cellar/python/3.7.7/Frameworks/Python.framework/Versions/3.7/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/bmw_connected_drive/__init__.py", line 4, in <module>
    from bimmer_connected.account import ConnectedDriveAccount
  File "/Users/Pinuccio/.homeassistant/deps/lib/python/site-packages/bimmer_connected/__init__.py", line 5, in <module>
    __version__ = pkg_resources.get_distribution("bimmer_connected").version
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 482, in get_distribution
    dist = get_provider(dist)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 358, in get_provider
    return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 901, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 787, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'bimmer_connected' distribution was not found and is required by the application```

Again even the check config button will get stuck not returning an OK code...

I found an elegant solution, In HACS there is an front-end add-in called Custom-Sidebar.
Install it and create (as it requests) a file called sidebar-order.yaml in the config/www directory.

As an example this is my content for that file, odds are that you need a subtely different url for your mqtt.

  - item: overview
  - item: file editor
  - item: developer 
    href: /developer-tools/state
  - new_item: true
    icon: mdi:lan-pending
    item: MQTT
    href: /config/mqtt?config_entry=88d8fc6108a64d61a78bf7236a21b7c9
  - item: sqlite
  - new_item: true
    item: Server Controls
    icon: mdi:server
    href: /config/server_control 

  - item: map
    hide: true
  - item: calendar
    hide: true
  - item: logbook
    bottom: true
  - item: history
    bottom: true
  - item: hacs
    bottom: true
  - item: supervisor
    bottom: true
  - item: configuration
    bottom: true
  - item: node-red
    bottom: true

Hello, installed the latest update 0.112.4, deleted MariaDB, and rebooted Home Assistant. I see errors, how can I fix them?

Did you fix your recorder url to not use mariadb anymore ?

Same problem here: Since 0.112 my Home Assistant stops collecting sensor values every night at about 4 o’clock (sometimes 3:30, sometimes 4:10, …). Until now I couldn’t find anything in the logs that could help me. I have no idea what goes wrong there.

Oh sh*t) Yes, I forgot, thank you this solved the problem