0.112: Making things faster; Logbook & History

Thanks! It worked for me as well :smile: :smile:

These are the commands I executed to alter the table @finity

MariaDB [(none)]> use hass;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed

MariaDB [hass]> describe schema_changes;
| Field          | Type     | Null | Key | Default | Extra |
| change_id      | int(11)  | NO   | PRI | NULL    |       |
| schema_version | int(11)  | YES  |     | NULL    |       |
| changed        | datetime | YES  |     | NULL    |       |
3 rows in set (0.001 sec)

MariaDB [hass]> ALTER TABLE schema_changes MODIFY COLUMN change_id INT auto_increment;
Query OK, 2 rows affected (0.079 sec)              
Records: 2  Duplicates: 0  Warnings: 0

MariaDB [hass]> describe schema_changes;
| Field          | Type     | Null | Key | Default | Extra          |
| change_id      | int(11)  | NO   | PRI | NULL    | auto_increment |
| schema_version | int(11)  | YES  |     | NULL    |                |
| changed        | datetime | YES  |     | NULL    |                |
3 rows in set (0.004 sec)
1 Like

Thanks for that info.

I didn’t need to do anything when I updated but hopefully it will help others if needed.

Has 0.112.5 been withdrawn ?

appeared this morning, I saw it around 7:00. I know it takes 2 hours to build, but now it is 14:42, and still no sign on docker hub ?

1 Like

I am having the same problem. Have you solved it? I Cannot update from 0.110 to 0.112.4 because this is happenning.
Running it in a NUC with Ubuntu Server and Docker

Looks like it failed to build :anguished: https://dev.azure.com/home-assistant/Core/_build/results?buildId=50770&view=results

1 Like

Looks like there are tons of ‘libcec’ errors on the build log…
I also tryed to docker pull the update, and got the same version I already had, lol. :roll_eyes:

1 Like

Not seeing the 112.5 update using supervisor? Did it get pulled?

See 2 replies up.

It is being pulled. We have changes standing by for 0.113, which aren’t compatible with the builds for 0.112.5. We have decided the risk for fixing this now is to high for a patch release.

As a result 0.112.5 will only be available for people using the Home Assistant Core installation method.


I’m currently on 0.112.5 (Home Assistant Core in a venv). Will this cause me any issues if I update to the 0.113 Beta when it’s available?

No, it won’t cause any issues. Patch releases contain cherry picked things from the next release (0.113 in this case). Essentially, every patch release you are upgrading closer to the next release already.

Yes. I’m having the exact same issue. My MQTT broker appears to be receiving and sending msgs okay, but HA is ignoring…

Thanks for the info.

1 Like

Yes indeed lots of libcec errors on the 112.5 build… explains why my update sensor hasn’t ticked off since reading the release notes for .5 yesterday. Oh well no love lost on my end… looks like the asuswrt patch hasn’t made it through yet anyways.

Hi all, I started 1.5 years ago with hassio. Last week I successfully updated to 112.4. Beside my broken blink integration I must say, that I never had such a smooth and stable HA version like this one. Nearly no issues in the logbook within 3 days. I thought first, that there must be something broken :slight_smile: But no, simply running without any issues.
Guys, great job!! Congrats!.
From my point of view, we’re close to the first official release. That’s how it should work. Looking forward to the 113 improvements in automations and script. That makes fun :slight_smile:
Thanks to all contributors and helpers and the great community.

And by the way, the last two upgrades saved money.
Before, I had the feeling, that I have to upgrade from RaspB3+ to Rasp4 due to performance issues.
During 111 and 112 the performance increased so rapidly, that I’m far away from updating the hardware :wink:
Sorry amazon :slight_smile:


Is anyone else having an issue with the play_stream camera service? When I try and use the service to play to a chromecast device all I get is the chromecast emblem and no stream. The same automation worked fine in previous builds.

Quick question about combining entities in a condtions

Do they have to be the same type? For example could I include a light and a switch and in input boolean

  - condition: state
      - binary_sensor.withings_in_bed_me
      - light.bedside_lamp
      - switch.wall_plug
    state: 'off'

I could not find any examples of such.

As far as I know, as long as all entities have exactly the same state type, it should work.
Simply test it out :wink:

1 Like

You can mix them, no problem :slight_smile:

1 Like

Apparently since the July 14th update, my Smartthings Z-wave switches are being pressed on every 5-minutes. I’ve got no automation, script, routine associated with these switches and the only thing that has changed was an update to Release 0.112.5. If I disable the devices in HA, the lights operate normally, re-enabled? Every 5-minutes.