0.115: B-Day release! Media browser, tags, automations & WTH

hello, after the update I don’t have any automation that works, I tried to eliminate them all but I still get the same error…

Logger: homeassistant.config
Source: config.py:413
First occurred: 9:34:19 AM (1 occurrences)
Last logged: 9:34:19 AM

Invalid config for [automation]: must be a value between 0 and 59 for dictionary value @ data['minutes']. Got None. (See ?, line ?).
1 Like

This means, you have an automation that sets something else, e.g., /60 which isn’t valid and never worked. The checks have been improved to catch those occurrences.

3 Likes

I had in previous Version 0.114 “media_player_kodi” with magic paket. Now after update i have new intergration "media_player_coreelec and how i can set Magic packet again?
Previous code:

   turn_on_action:
     - service: wake_on_lan.send_magic_packet
       data:
          mac: *********
          broadcast_address: 255.255.255.255

New verstion is nice, but sometimes i need power on Odroid with Kodi

1 Like

It appears that 0.115 may have broken dropdown options in the UI Editor of custom cards. This is one example (https://github.com/custom-cards/bar-card). The dropdowns now just appear as a list and are not functional.

So I thought leaving HA to settle down for some time after the upgrade may help, but it’s still the same, high system resource usage, which is what I think is causing the frontend to take longer than normal to load, as you can see below, the upgrade was done just before 2pm.

image

image

please help me memorize where this same issue was discussed, but another solution was suggested, by simply adding the entity_id into the template as a ‘fake’ x entity…? I can’t find it but my memory tells me it was in the WTH thread somehow… not sure though.

It was a much more elegant solution than the one offered in the documentation tbh… btw, never realized this was suggested as far back as jan 2018

edit

duh, its in the link you already posted…sorry for that:

 {% set x = states('sensor.date') %} 

and no need for convoluted strptime sensors which might not even be used, and need to be added especially for this purpose.

would be nice if the short solution by Petro be added to the official docs…

of course this is another proof for the need of global variables (the would also trigger the template) because sensors like this would need it in all templates:

      utc_offset:
        friendly_name: Utc offset
        entity_id: sensor.time
        value_template: >
          {{now().utcoffset().total_seconds()/3600}}
        icon_template: >
          mdi:numeric-{{states('sensor.utc_offset')|int|abs}}

or, would the self referencing here be enough to work…?

other example:

      entities_domains_counter:
#        entity_id:
#          - sensor.date
#          - sensor.count_persistent_notifications
        friendly_name: Entities per domain
        value_template: >
          {{states|count}}
        attribute_templates:
          headline: >
            {{states|count}} entities in {{states|groupby('domain')|count}} domains
          alert: >
            {{states.alert|count}}
          automation: >
            {{states.automation|count}}
          binary_sensor: >
            {{states.binary_sensor|count}}
          camera: >
            {{states.camera|count}}
          climate: >
            {{states.climate|count}}
          counter: >
            {{states.counter|count}}
# continue to list all domains

they now all would need a set x? I feel being able to set the entity_id: was not that bad, and most certainly has its advantages over these cases. Setting the entity_id for the full template sensor, and by that limiting updating to only that entity_id was sheer power… Sorry to see that go.

took my chance to ping the merged PR on this… hope Bdraco wont minor suggests otherwise

Yes, it’s very impressive, mainly the speed even on a lowly RPi!

Does anyone know anything about the NightScout integration introduced in this release? There seems to be no ability to add your password?

First, what a release! And Happy Birthday :wink:

Getting a Broadlink (RM Pro+) issue. Was working prior to upgrading, on upgrade it wasn’t automatically picked up, when trying to manually add it (configuration>Integration>+) I get:

Failed to connect

Logs are showing.

2020-09-18 17:12:03 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found
2020-09-18 17:12:49 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found
2020-09-18 17:14:52 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at homeassistant.components.broadlink: Invalid hostname or IP address

Any suggestions, the Broadlink is still on the 192.168.1.60 address.

Great job you all! Amazing how many new feautures we can use now! But since I got no response on the forum I’ll raise my question here and hopefully someone will notice. Is it possible to take a close look at the Siemens Home Connect and Samsung SmartThings integration? They both only work for a very short time after a restart of Home Assistant but are pretty useless at this moment. And I am not the only one who has issues with the integration.

1 Like

Hi,

Have problem with automation.
Get this message in log: “Invalid config for [automation]: must be a value between 0 and 59 for dictionary value @ data[‘minutes’]. Got None.”
Don’t know where is the problem?!
Before this last update everything was ok.

It worked, thank you very much, it shows that the use of the cpu is lower

Hi @spider7611, please see the response from @frenck about 1 hour previous in the forum.

I actually saw this error in 0.114.3, it was caused when I edited an automation in the UI that had previously been created in yaml. Basically I think it was the syntax of “/60” was wrong so just play around with this in the UI automation editor until it saves OK.

I think this means that these automations never previously worked properly.

Quick question: (this could be existing behavior I hadn’t spotted before, but due to the sensors updating automatically is now visible to me):

  • Previously I had a sensor which was scheduled to refresh every 20mins using homeassistant.update_entity – these are now working on the fly

  • I have an automation which if the state of this sensor (which is a number) changed alerts me

  • This sensor has a number of attributes, if the state remains the same but the attributes change the automation is triggered (or are attributes considered part of the overall state??)

Is this expected behavior?

Awesome release by the way - lots to work through :slight_smile:

After I see that post too sorry.
But don’tknow where is the problem. Have one time pattern automation with this minute settings: /30 and this automation working good now and before.
All of my automation opened and saved again and not show any error but after HA restart again received this error in log…

Pretty cool release, guys.

Just wanted to verify am I only one having problem with yeelight integration.
After adding the yeelight integration and adding device IP to the host I get “Failed to connect” message.
Whole integration worked fine before update, so I assume local connection is set correctly.

My config:

    devices:
      192.168.1.213:     
        name: kids_table
        model: lamp
      192.168.1.191:
        name: toilet_main
        model: mono1
      192.168.1.215:
        name: hall_main_1
        model: mono1
      192.168.1.216:
        name: hall_main_2
        model: mono1
      192.168.1.157:
        name: bedroom_her
        model: bslamp1
      192.168.1.158:
        name: bedroom_his
        model: bslamp1

Logs:

2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.158: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.158: cannot connect
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.216: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.216: cannot connect
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.157: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.157: cannot connect

OK then but I am not sure what else to suggest.

There is the old programmers cut-and-paste method if you wanted to try it, it goes something like this …

  1. First copy your automations.yaml to as a back-up for safe keeping.
  2. Then edit the automations.yaml file to delete half of the automations in it, reload automations and see if the error persists.
  3. If the error is gone then it means it must be in the half of the automations that you deleted.
  4. Proceed like this chopping the file down until you narrow down where the error is and correct it.
  5. Finally restore the backup file and correct the error in the original.

Hope that helps!

I have the same problem

Seeing the same problem with yeelight integration

Ok. When will have time chechk this. Thank You.