0.115: B-Day release! Media browser, tags, automations & WTH

Great job you all! Amazing how many new feautures we can use now! But since I got no response on the forum I’ll raise my question here and hopefully someone will notice. Is it possible to take a close look at the Siemens Home Connect and Samsung SmartThings integration? They both only work for a very short time after a restart of Home Assistant but are pretty useless at this moment. And I am not the only one who has issues with the integration.

1 Like

Hi,

Have problem with automation.
Get this message in log: “Invalid config for [automation]: must be a value between 0 and 59 for dictionary value @ data[‘minutes’]. Got None.”
Don’t know where is the problem?!
Before this last update everything was ok.

It worked, thank you very much, it shows that the use of the cpu is lower

Hi @spider7611, please see the response from @frenck about 1 hour previous in the forum.

I actually saw this error in 0.114.3, it was caused when I edited an automation in the UI that had previously been created in yaml. Basically I think it was the syntax of “/60” was wrong so just play around with this in the UI automation editor until it saves OK.

I think this means that these automations never previously worked properly.

Quick question: (this could be existing behavior I hadn’t spotted before, but due to the sensors updating automatically is now visible to me):

  • Previously I had a sensor which was scheduled to refresh every 20mins using homeassistant.update_entity – these are now working on the fly

  • I have an automation which if the state of this sensor (which is a number) changed alerts me

  • This sensor has a number of attributes, if the state remains the same but the attributes change the automation is triggered (or are attributes considered part of the overall state??)

Is this expected behavior?

Awesome release by the way - lots to work through :slight_smile:

After I see that post too sorry.
But don’tknow where is the problem. Have one time pattern automation with this minute settings: /30 and this automation working good now and before.
All of my automation opened and saved again and not show any error but after HA restart again received this error in log…

Pretty cool release, guys.

Just wanted to verify am I only one having problem with yeelight integration.
After adding the yeelight integration and adding device IP to the host I get “Failed to connect” message.
Whole integration worked fine before update, so I assume local connection is set correctly.

My config:

    devices:
      192.168.1.213:     
        name: kids_table
        model: lamp
      192.168.1.191:
        name: toilet_main
        model: mono1
      192.168.1.215:
        name: hall_main_1
        model: mono1
      192.168.1.216:
        name: hall_main_2
        model: mono1
      192.168.1.157:
        name: bedroom_her
        model: bslamp1
      192.168.1.158:
        name: bedroom_his
        model: bslamp1

Logs:

2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.158: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.158: cannot connect
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.216: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.216: cannot connect
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.157: timeout
2020-09-18 11:23:03 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.157: cannot connect

OK then but I am not sure what else to suggest.

There is the old programmers cut-and-paste method if you wanted to try it, it goes something like this …

  1. First copy your automations.yaml to as a back-up for safe keeping.
  2. Then edit the automations.yaml file to delete half of the automations in it, reload automations and see if the error persists.
  3. If the error is gone then it means it must be in the half of the automations that you deleted.
  4. Proceed like this chopping the file down until you narrow down where the error is and correct it.
  5. Finally restore the backup file and correct the error in the original.

Hope that helps!

I have the same problem

Seeing the same problem with yeelight integration

Ok. When will have time chechk this. Thank You.

That is easier to answer if you show your automation. If the trigger does not have from: or to:, it will trigger on attribute changes.

works for me on android with edge browser, same with app

Perfect thanks @amelchio - that answers it!!

I guess because I was only updating the sensor every hour I didn’t see this ‘feature’.

I’m only bothered if the state which is a count changes - but in my attributes I had placed battery levels so as they’re running down its changing, right, time for a rethink. Thanks again :wink:

1 Like

first off Happy birthday!
what a great release.

my query is I noticed you added a reload button to an integration card. I posted yesterday saying I was having an issue with my lights on connecting to HA once they are back on

is it possible to fire the reload from an automation in yaml?

did you remove any existing broadlink sensor/remote configs, if they are still in use then it seems errors occur

have you removed the old configs

I have the same issue. I tried adding the bulbs using the Integrations UI, but it fails to find the bulb even when I put in the IP address.
My bulbs are in a separate VLAN, so I’m not sure if that’s why it can’t find them.
it was working fine in v0.114

This what I get in the log when trying to add from the new Integrations UI.

ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.10.41: timeout

Looks like it’s a bug.

I had removed the remote: but just noticed the switches still setup in the config. Removed them, restarted HA. Save issue, on trying to add through Integrations getting this in the logs:

[homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found

there are some problems with RM 3 mini and some more devices
please see below (at the end)
probably it will be fixed in 0.115.1 ? i think