0.115: B-Day release! Media browser, tags, automations & WTH

Seeing the same problem with yeelight integration

Ok. When will have time chechk this. Thank You.

That is easier to answer if you show your automation. If the trigger does not have from: or to:, it will trigger on attribute changes.

works for me on android with edge browser, same with app

Perfect thanks @amelchio - that answers it!!

I guess because I was only updating the sensor every hour I didn’t see this ‘feature’.

I’m only bothered if the state which is a count changes - but in my attributes I had placed battery levels so as they’re running down its changing, right, time for a rethink. Thanks again :wink:

1 Like

first off Happy birthday!
what a great release.

my query is I noticed you added a reload button to an integration card. I posted yesterday saying I was having an issue with my lights on connecting to HA once they are back on

is it possible to fire the reload from an automation in yaml?

did you remove any existing broadlink sensor/remote configs, if they are still in use then it seems errors occur

have you removed the old configs

I have the same issue. I tried adding the bulbs using the Integrations UI, but it fails to find the bulb even when I put in the IP address.
My bulbs are in a separate VLAN, so I’m not sure if that’s why it can’t find them.
it was working fine in v0.114

This what I get in the log when trying to add from the new Integrations UI.

ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.10.41: timeout

Looks like it’s a bug.

I had removed the remote: but just noticed the switches still setup in the config. Removed them, restarted HA. Save issue, on trying to add through Integrations getting this in the logs:

[homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found

there are some problems with RM 3 mini and some more devices
please see below (at the end)
probably it will be fixed in 0.115.1 ? i think

The emulated_hue is broken with the following error:

Component error: emulated_hue - cannot import name ‘real_ip’ from ‘homeassistant.components.http’ (/usr/src/homeassistant/homeassistant/components/http/init.py)

Any idea?

1 Like

Thanks for the hint @Kanishkaz. Yes it looks exactly my problem, hopefully will be solved on next release.

You probably have templates that listen to all states or are listening to their own changes or making loops.

I most definitely do, but wasn’t an issue previously, and I didn’t see any changes that relates, or did I miss that?

Check the templates section of the breaking changes.
We will now update the template on every change of states you used in your template. If you use all states in multiple template sensors that will end in a loop.

Will do, does this only apply to scripts / automations, or sensors as well?

Sensors too.

well that is not very desirable and rather underlines my thoughts about that here

previously, entity_id: was a great tool to define ‘global’ entities for the full sensor, And limiting the updating of the sensor to only that entity_id.
Hope we can get that back.

Is there a simple way to track these down?

I’m not sure I truly understand what needs to be changed here.