0.115: B-Day release! Media browser, tags, automations & WTH

Very impressive release! Thanks to all.

Hey guys and girls,
I did the update yesterday to latest version and i get this warning

The 'entity_id' option is deprecated, please remove it from your configuration

Does anyone know what i have to do? It says 4 occurencies but i searched my files for “entity_id” and i found 80+ occurencies so i am confused? Is it only me who finds annoying when I read warnings about something without mentioning where? I mean if they can find these “errors” how hard is to write where is the problem?

Remove the entity_id option from all of your Template entities (Template Sensors, Template Binary Sensors, etc) and adapt their templates to work without that option where needed. For example, if a template contains no entities, the documentation explains how to handle that situation.

2 Likes

We’re still working on this integration. Battery powered devices will be supported. At the moment Shelly Gas is working fine because it’s AC powered.

1 Like

I was asked to re-authenticate Spotify. When re-authenticating I only got the message Aborted. Removed the integration and tried to install it again - same error.
aborted

Solved by setting internal and external url in settings.

2 Likes

It seems 0.115 introduced a bug with the side menu. You cannot collapse it any more in IOS and it seems same problem in Android. That is a problem when you use things like file editor because you end up with only half the screen width to do the work

between 100 up 200 extra Mo of Ram eaten with the 0.115 vs 0.114 for me :frowning:

Excellent release so far. I haven’t had a chance to play around with some of the changes, but the update process was very smooth.

Great work :+1:

A massive list of updates, very exiting. I would like to see media player integration for J River Media Center, but what is needed to get such an integration running, is it a lot of work? Is there any info about what is needed somewhere? Does the work need to be done on the JRMC-side or the HA-side?

Very meaty update! The media library makes for a cool demo but without a search field, it’s usability is limited with normal media libraries.

EDIT: it’s a great feature, please ignore my tone. It was only meant as an UX feedback.

Honestly, for a new feature that has been developed in less than 5 weeks… I think it is a pretty impressive piece of art they’ve put up and support more than I would have ever dreamed compared to what is was aimed for at the start.

Everything needs to start somewhere, and is developed from there.

11 Likes

hello, after the update I don’t have any automation that works, I tried to eliminate them all but I still get the same error…

Logger: homeassistant.config
Source: config.py:413
First occurred: 9:34:19 AM (1 occurrences)
Last logged: 9:34:19 AM

Invalid config for [automation]: must be a value between 0 and 59 for dictionary value @ data['minutes']. Got None. (See ?, line ?).
1 Like

This means, you have an automation that sets something else, e.g., /60 which isn’t valid and never worked. The checks have been improved to catch those occurrences.

3 Likes

I had in previous Version 0.114 “media_player_kodi” with magic paket. Now after update i have new intergration "media_player_coreelec and how i can set Magic packet again?
Previous code:

   turn_on_action:
     - service: wake_on_lan.send_magic_packet
       data:
          mac: *********
          broadcast_address: 255.255.255.255

New verstion is nice, but sometimes i need power on Odroid with Kodi

1 Like

It appears that 0.115 may have broken dropdown options in the UI Editor of custom cards. This is one example (https://github.com/custom-cards/bar-card). The dropdowns now just appear as a list and are not functional.

So I thought leaving HA to settle down for some time after the upgrade may help, but it’s still the same, high system resource usage, which is what I think is causing the frontend to take longer than normal to load, as you can see below, the upgrade was done just before 2pm.

image

image

please help me memorize where this same issue was discussed, but another solution was suggested, by simply adding the entity_id into the template as a ‘fake’ x entity…? I can’t find it but my memory tells me it was in the WTH thread somehow… not sure though.

It was a much more elegant solution than the one offered in the documentation tbh… btw, never realized this was suggested as far back as jan 2018

edit

duh, its in the link you already posted…sorry for that:

 {% set x = states('sensor.date') %} 

and no need for convoluted strptime sensors which might not even be used, and need to be added especially for this purpose.

would be nice if the short solution by Petro be added to the official docs…

of course this is another proof for the need of global variables (the would also trigger the template) because sensors like this would need it in all templates:

      utc_offset:
        friendly_name: Utc offset
        entity_id: sensor.time
        value_template: >
          {{now().utcoffset().total_seconds()/3600}}
        icon_template: >
          mdi:numeric-{{states('sensor.utc_offset')|int|abs}}

or, would the self referencing here be enough to work…?

other example:

      entities_domains_counter:
#        entity_id:
#          - sensor.date
#          - sensor.count_persistent_notifications
        friendly_name: Entities per domain
        value_template: >
          {{states|count}}
        attribute_templates:
          headline: >
            {{states|count}} entities in {{states|groupby('domain')|count}} domains
          alert: >
            {{states.alert|count}}
          automation: >
            {{states.automation|count}}
          binary_sensor: >
            {{states.binary_sensor|count}}
          camera: >
            {{states.camera|count}}
          climate: >
            {{states.climate|count}}
          counter: >
            {{states.counter|count}}
# continue to list all domains

they now all would need a set x? I feel being able to set the entity_id: was not that bad, and most certainly has its advantages over these cases. Setting the entity_id for the full template sensor, and by that limiting updating to only that entity_id was sheer power… Sorry to see that go.

took my chance to ping the merged PR on this… hope Bdraco wont minor suggests otherwise

Yes, it’s very impressive, mainly the speed even on a lowly RPi!

Does anyone know anything about the NightScout integration introduced in this release? There seems to be no ability to add your password?

First, what a release! And Happy Birthday :wink:

Getting a Broadlink (RM Pro+) issue. Was working prior to upgrading, on upgrade it wasn’t automatically picked up, when trying to manually add it (configuration>Integration>+) I get:

Failed to connect

Logs are showing.

2020-09-18 17:12:03 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found
2020-09-18 17:12:49 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at 192.168.1.60: Device not found
2020-09-18 17:14:52 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to the device at homeassistant.components.broadlink: Invalid hostname or IP address

Any suggestions, the Broadlink is still on the 192.168.1.60 address.