0.76: Auth almost done, FleetGo, PJLink, RMV public transport


#45

Anyone having tracker issues with this version?
My ddwrt router trackers are not showing correct status now.


#46

Your problem is lack of temp space.

No, we didn’t tested this scenario.


#47

How did you forget about that? People using HA for more than 1 year have 8++ gb of db. I have 20+gb space left on the SD cart yet my DB is corrupted and lost 1 year of data…


#48

No one can think about all the possibilities that can happen.
It’s always wise to have a good backup bevor updating.


#49

There are lots of DB engines people are using, different DB has different way to do schema update. As an open source project, we would not be able to test all possible scenario, especially home-assistant is not a database focus application.

Welcome to join us as beta tester, if you have special setup and want to make sure it works in next release.


#50

I just told jaymelweston his problem is lack of temp space. I didn’t saw your error log, didn’t know what happens during your upgrade process.

You can always modify the schema by yourself, I posed in previous comment a link that people are doing manual DB migration, you can look at it.


#51

If your DB is only on an SD without backup it was anyway something due to happen… and you can always correct it manually…


#52

How long could the update take on a RPi


#53

probably 20-30 minutes in addition to DB migration


#54

After updating, the developer tools were not working.
After rebooting the Pi, everything is back to working order.


#55

I am running hassio (Resin OS) and I have had

Invalid Config.  The following components and platforms could not be set up:
recorder
history
logbook

Please check your config.

I understand the conversion of DB might have failed? I don’t think I need my history or anything, so happy to delete database and start again. What do I need to do? Stop Home Assistant - delete home-assistant_v2.db and then restart home assistant?

Thanks,

James


#56

Yep, that would solve it.


#57

I’m having issues with the Tuya component. All was working well in 0.75.3 and with 0.76.1 I am getting the following exception:
2018-08-20 13:28:24 ERROR (MainThread) [homeassistant.setup] Error during setup of component tuya
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config) # type: ignore
File “/usr/lib/python3.5/asyncio/futures.py”, line 380, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.5/asyncio/tasks.py”, line 304, in _wakeup
future.result()
File “/usr/lib/python3.5/asyncio/futures.py”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/thread.py”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/tuya.py”, line 65, in setup
tuya.init(username, password, country_code, platform)
File “/srv/homeassistant/lib/python3.5/site-packages/tuyapy/tuyaapi.py”, line 44, in init
self.get_access_token()
File “/srv/homeassistant/lib/python3.5/site-packages/tuyapy/tuyaapi.py”, line 68, in get_access_token
raise TuyaAPIException(message)
tuyapy.tuyaapi.TuyaAPIException: Get accesstoken failed. Username or password error!

I have verified that my credentials are valid (they didn’t change since I upgraded). I have also tried adding the new platform option to my tuya config set to both smart_life and tuya. All combinations result in the same exception.


#58

I’m experiencing one issue with the Auth: component. I activated auth_providers: once I installed v 0.76 on my Hass.io system. All works well, including add-ons, except that doing a Snapshot Download to my iMac fails. I’ve tried it with Safari, Firefox, and Chrome. No file is transferred, and this error is generated:
“Please change to use bearer token access /api/hassio/snapshots/20379af5/download”

Any ideas? Thanks in advance.


#59

Thanks, this worked.


#60

No web interface. I still have access to the file system via configurator on port 3218 after about 20 minutes.
I have a monitor attached.
any suggested command I should run


#61

My system is giving these errors for lot’s of things. Also appdaemon keeps getting ip-banned because of wrong password…


#62

Finally user system is coming :slight_smile:


#64

My system was getting these errors for several things also prior to v0.76, so I never left Auth activated. Now I’m leaving Auth activated since I only get the error when trying to download the Snapshot file.
Thanks for the reply.


#65

Is anyone having issues with Magic Seaweed since updating? I installed it last update, because…why not, and noticed today that it was not working any more. Log gets the following error

Update for sensor.virgia_beach_surf_report_forecast fails
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity.py", line 199, in async_update_ha_state
    yield from self.async_device_update()
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity.py", line 322, in async_device_update
    yield from self.hass.async_add_job(self.update)
  File "/usr/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/sensor/magicseaweed.py", line 148, in update
    self.data.update()
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/util/__init__.py", line 325, in wrapper
    result = method(*args, **kwargs)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/sensor/magicseaweed.py", line 195, in _update
    self.currently = forecasts.data[0]
IndexError: list index out of range