0.80: Lovelace updates, webhooks, TRÅDFRI switches

Can the new webhooks be used with Owntracks? I tried previously with the long-lived access tokens and couldn’t get that to work. This is the only thing keeping me on the legacy password.

1 Like

PR is already open https://github.com/home-assistant/home-assistant/pull/17034

1 Like

Perfect! Thanks!

Did you mean exclude_entities? - had to remove that for it to work for me.

Also, when setting it up in Google Assistant I kept getting a popup about “check for connection”, had to set the “Client Secret” on the Google Console to match the “project_id” inside the HASS Configuration for it to work - even then Google Assistant threw up the same error, but added HASS anyway…

I am seeing below error since upgrading frequently appearing while using the UI.

2018-10-12 22:10:47 ERROR (MainThread) [aiohttp.server] Unhandled exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_protocol.py", line 410, in start
    await resp.prepare(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 300, in prepare
    return await self._start(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 608, in _start
    return await super()._start(request)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py", line 367, in _start
    await writer.write_headers(status_line, headers)
  File "/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py", line 110, in write_headers
  File "/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py", line 67, in _write
    raise ConnectionResetError('Cannot write to closing transport')
ConnectionResetError: Cannot write to closing transport

Just wondering - did anybody try the new Google Assistant auth with the apache proxy?

I’m always getting “Account linking failed”.
It worked perfectly before though. And I’ve even setup a new “skill” in the “Actions on Google”.
I’m gonna try to debug it further.

That sounds not right, client secret can be any string, we didn’t verify it. We didn’t change exclude_entities config, could you make sure your yaml file format is correct?

If you can login your HA via your proxy, Google Assistant auth should work as well, they are using same OAuth flow.

Okay. Weird. Thanks for the info!

This is more of an example of a tree traversal than a webhook, but you could write an automation to close that new hole. Probably need some sort of cover device. :scream_cat:


1 Like

Heheh… Automation cannot function without electricity. :slight_smile:

'cause we don’t have robots yet that can do all the heavy lifting! That is, if robots have Home Assistant pre-installed. :slight_smile:

I finally figured it out.
It seems like that now you need a valid SSL certificate.
Previously a self issued certificate was enough. It might be worth to add this information to the docs.
Thanks for your help!

I really love the work that has been done for the webhooks. Just in case anyone is wondering how to use it:

Rugular data:

    platform: webhook
    webhook_id: test
    service: logbook.log
      name: testlog
      message: >
        {{ trigger.data.a }}

And call it from Python like this:

import requests
requests.post("", data={"a":1})

JSON encoded:

    platform: webhook
    webhook_id: test
    service: logbook.log
      name: testlog
      message: >
        {{ trigger.json.a }}

And call it from Python like this:

import requests
import json
requests.post("", data=json.dumps({"a":1}), headers={"Content-type":"application/json"})

Same errors occurring here.

Using the new Google Assistant auth, it says in the instructions that you need to “relink your test app” - does this also mean that I lose all of my google assistant settings and need to recreate all my device information in the google assistant app?

Yes you will need to reassign the devices to rooms again once you have re authenticated google assistant using the new setup unless you having been using the entity config value room, which would automatically assign the device.

after update to hassio 0.80.0 I lost posibility to create Automation.
On top of that, I cannot modify via editor those which currently exist, each time screen is empty


I have these (rooms) defined in the configuration file. When I unlink and relink, everything is then automatically in the right rooms.

For immediate relief, check your config directory and see if you still have an automations.yaml. If so, you can break up each of your automations in that file, and cut-n-paste each into a unique named .yaml file in the automations directory. Also, include this line in your configuration.yaml

automation old: !include_dir_merge_list automations

1 Like

That’s not what the Config Validator thinks

project_id: hass-000000
api_key: 000000000000000000000000000000000000
expose_by_default: false
  - script
  - script.pushbullet
  - script.radio538
  - script.stop_bedroom_music_devices
    expose: true
    name: Bedside Lamp Bar
     - headboard light
    room: Kev's Bedroom
    expose: true
    room: Kev's Bedroom

Additionally it’s no longer mentioned in the documentation https://www.home-assistant.io/components/google_assistant/