0.82: TensorFlow, Lovelace UI edit, Z-Wave Barrier Class


#21

For a long time those of us who wanted to use zwave garage door integrations had to manually install another fork of open wave or the dev fork and do extra work every upgrade to keep it working. This means we can put that practice to rest.


#22

That’s what I thought, but when I attempted to use the new embedded Z-wave in 82, none of my garage door openers were detected, and all of my other zwave entities were pretty messed up. I’m guessing it’s because I’ve been using a dev branch of open-zwave rather than just patching the master branch, so this is likely not going to impact anyone who has been using a patched master. I did want to warn anyone else out there though, if you’ve been using --flavor=ozwdev in your build, I recommend continuing to do so.

I’ve got it all nicely automated to build a docker container for me, so it’s really no more work to just keep doing it my way.


#23

Further testing… I’ve come to conclusion its the size of the ui lovelace yaml file that’s significant.


#24

Talking about the UI editor for Lovelace cards, how about drag&drop item reorder (inside or between the cards)? Sort of visual customization in-place.


#25

I just tried to upgrade as well, my zwave entities were fine but no cover showed up for the garage door opener, so I rolled back my install for now. My install only uses zwave for 2 switches, a thermostat, and the garage door opener, so I may try to wipe everything any start over if it’s supposed to work.


#26

I just got my garage door working. From the z wave control panel page try doing a heal node with that node selected. Then do a refresh node after a few minutes. This worked for me after not getting a cover device initially.

Alternatively, remove the node, reboot, then do a secure add again after z wave is ready. You may still have to do the heal/refresh node steps. Suggesting this in case you existing node has some remnant xml code. This method would clear that out.


#27

Upgraded, no issues so far. Thanks for the hard work.


#28

Where is the Edit UI menu?


#29

Top of the lovelace page, there is a menu.


#31

My asuswrt component using telnet stopped working after the upgrade. Downgraded to 0.81.6 and it’s working again.

RPi 2, Raspbian Stretch, VirtualEnv, Asus RT-AC66U


#32

Lots of stuff changed in the MQTT cover component but the docs where not updated to reflect the changes:
* Change of behaviour. Allow user to configure either a position topic or a state topic but not both.

Especially if you use set_position_topic, now you have to change the configuration of your component: state_topic should become position_topic.

It was failing for me with this error:
Set position topic must be set together with get position topic


#33

Just upgraded and now I have this error:
ERROR (MainThread) [homeassistant.setup] Setup failed for alert: Component failed to initialize.

I checked for breaking changes but I dont see anything about the Alert component. Unless I missed it.


#34

@hulkhaugen re asuswrt: I had the same issue — it looks like the default port logic has been changed. I added an explicit port: 23 to my component configuration, and that fixed it.


#35

What???


#37

Write in sentences please.


#38

my ui-lovelace.yaml was not changed when I updated to 0.82.0
When I click on edit, I get on every card:

Card Configuration


                     Cancel    Save

So what is wrong? How to automaticaly get ID’s?


#39

Thank you a lot for your work. You are just great.
And OZW updates are awesome.


#40

Anyone else noticing their Nest sensors are no longer available since upgrading?
Nest_Sensors


#41

I had luck doing this but would love an automatic way of getting ID’s

  - name: Chicken
    id: Chicken
    title: Chicken
    cards:
      - type: entities
        id: Chicken Controls
        title: Chicken Controls
        show_header_toggle: false
        entities:
          - cover.chicken_door
          - automation.chicken__afterdark_turn_off_light
          - switch.esp3

#42

All my IDs were created automatically after one of the previous updates.