0.82: TensorFlow, Lovelace UI edit, Z-Wave Barrier Class


#43

Mine too…


#44

If you roll back to 0.81.0 the Id’s get generated automatically.


#45

0.81.0 was never installed on my system, but something higher and lower. So I can’t do a roll back to this Version. Maybe it is planned to re-add the automatic ID creation in a later release again?


#46

With a quick copy paste (changing the ids) it will take you a minute


#47

I just rolled back to 0.81.0 restarted and then went to latest with a restart and was done rather quickly.


#48

Thanks for this!! I have it working again.


#49

Just updated from 0.80.3 to 0.82.0. I have no problems with Z-Wave, but my Lovelace UI is a bit weird.

For starters, this blog claims a lot has changed in Lovelace, but the releasenotes at https://www.home-assistant.io/lovelace/changelog/ mention nothing? It still thinks 0.81.0 is the most recent version.

My problem is that since the upgrade all card titles are suddenly in a very small, not header-like font. Why?


#50

This custom card can add the ID’s for you.


#51

I see there’s an approved pull request for improved Koogeek support, any chance we can see those changes in the next version? :slight_smile:


#52

Is anyone else having an issue with asuswrt SSH not updating the status of the devices? I am not seeing any error messages in the logs.


#53

Yes, asuswrt device tracker is broken in 0.82.


#54

Yes, I have the same problem since 0.82.0, not updating!


#55

I’ve just update to 82 from 81 and got “onkyo: Error on device update!”

onkyo: Error on device update!
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 251, in _async_add_entity
    await entity.async_device_update(warning=False)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity.py", line 349, in async_device_update
    await self.hass.async_add_executor_job(self.update)
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/media_player/onkyo.py", line 223, in update
    self._attributes["video_out"] = ','.join(hdmi_out_raw[1])
TypeError: 'bool' object is not subscriptable

this is my conf:

media_player:
  - platform: onkyo
    host: !secret onkyo_host
    name: Onkyo
    sources:
      pc: 'PC'
      game: 'ChromeCast'

I tried to comment sourses, but nothing.
What’s goin on and what can i do?
Now back to 0.81 and onkyo work normal.


#56

known issue, fix is in progress it seems: https://github.com/home-assistant/home-assistant/issues/18353

always a good idea to check github for issues.


#57

Thanks, to check github for issues it’s really good idea.


#58

After this update 0.82.1 I have lots of problems with embedded MQTT. After a while all my arduinos are disconnected and they can’t connect anymore. They don’t stop work all together but one after the other…
They start working only after I reset them.
I don’t think the problem is in my arduinos’ software because they worked until today like a charm!
Any suggestion?


#59

Yes, logs. We do not have crystal balls.


#60

looking at home-assistant.log I don’t find anything useful:
enabling MQTT debugging and looking at the log file I see only received and sent topic
tail -f /home/homeassistant/.homeassistant/home-assistant.log | grep mqtt

any other log file to look at?


#61

Only what is generated by the arduino code, which I am guessing will be a PITA to retrieve.

Does the built in MQTT server continue to run?

Have you tried mosquitto (which I must say, I have always had better luck with!)


#62

Agree with @nickrout, the embedded mqtt broker is very limited and I also had problem. Since I moved to mosquitto I didn’t have any issue (in a docker container)