0.85: ESPHome, Plum Lightpad, OpenSenseMap


Slugify changed, which can impact entity ID creation if the entities had names with either a - or characters outside of A-Z and the integration has no unique IDs. We now better handle the characters and substitute it with an alternative instead of removing that character.

Read this breaking change warning? 👆 Good. Let’s get started. This is the first release of 2019 and it covers a whopping 4 weeks, as we skipped the last release of the year to focus on friends and family. This is going to be a great year and we’re planning a lot of cool stuff. If you haven’t seen it yet, check the State of the Union to see what we have planned.

We’ve been so good at taking a break, that we pushed Lovelace as the default UI to 86 to make sure it’s super polished. We expect just bug fixes between 85 and 86, so feel free to check it out!

We’re also busy churning through the backlog of open PRs for Home Assistant (170 as of now), if you did a contribution over the past 4 weeks, we’ll get to it soon.

During the break we’ve launched the Home Assistant Data Science Portal. It explains all the data that Home Assistant stores and how you can get a data science environment going to explore it yourself.

This release also features native support for ESPHome, a system for managing ESP8266 and ESP32 microchips with a YAML config inspired by Home Assistant. The native API replaces MQTT for ESPHome firmwares and is designed specifically for Home Assistant and absolute efficiency. 🏎 It also comes with a Hass.io add-on to make configuration even easier.

New Platforms

If you need help…

…don’t hesitate to use our very active forums or join us for a little chat. The release notes have comments enabled but it’s preferred if you use the former communication channels. Thanks.

Reporting Issues

Experiencing issues introduced by this release? Please report them in our issue tracker. Make sure to fill in all fields of the issue template.

Breaking Changes

  • Targetting all entities in a domain by not sending an entity_id to a service is now deprecated. Instead, send entity_id: all if you want to target all. The old method will work for a couple of releases more, but will print a warning. Please migrate. (@balloob - #19006) (breaking change)
  • The default interval of the weather component was aligned with the sensor component and is now 30 seconds instead of 15 seconds. (@fabaff - #19186) (weather docs) (breaking change)
  • In order to fix the below bug, default entity_ids will change (for example, sensor.17track_packages_delivered will change to sensor.seventeentrack_packages_delivered). (@bachya - #19213) (sensor.seventeentrack docs) (breaking change)
  • Change STATE_AUTO to STATE_HEAT and STATE_AWAY to STATE_ECO to conform to climate DOMAIN standards. Change made to fix Alexa/Google Assistant support for this component. (@marchingphoenix - #19242) (climate.eq3btsmart docs) (breaking change)
  • Add config flow for Daikin. Removes configuration option: monitored_conditions. Also removes configuration settings for sensor.daikin. (@fredrike - #19182) (daikin docs) (climate.daikin docs) (sensor.daikin docs) (breaking change)
  • Add traccar motion, speed and battery_level attributes. Attributes will only exist if there is data to show for that attribute.

(@ludeeus - #19090) (device_tracker docs) (breaking change)

Beta Fixes

All changes

This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2019/01/09/release-85/

Daikin Component - no climate entities created - task exception
Updated HA to version 0.86.4 and now entities are missing
YET another take on an alarm system
Daikin Component - no climate entities created - task exception

I love the fact that there is an Ambient component now - just in time.
Bye bye WUnderground!


I don’t have a button to update in Hass.io and tried updating via SSH and just got back ‘OK’?

Currently on 0.84.6.


Docker image hasn’t been updated yet. I manually pulled 85.0b0 in Docker, but I’m sure they’ll update the :latest tag shortly.


Ahh thanks. Usually I don’t try for a couple of days but I was really excited for this one after the holiday break.


I’m confused. I already have my ESPhome devices connected using Integrations as I have this in the ESPhome configuration yaml file for the devices:

  discovery: true
  discovery_prefix: homeassistant

Do I have to reprogram all my ESP devices OTA to remove this and add them again and delete the existing integrations or can I continue to use mqtt (which has been working exceptionally well)?


I had the same but I could do this:
hassio ha update --version=0.85.0


Even better! Thanks.


Please read https://esphomelib.com/esphomeyaml/changelog/v1.10.0.html .


Docker file still not updated :frowning:


Thanks raoul. The migration guide answered all my questions.


My telldus units all stoped working after 85.0


Did you notice " f you are upgrading from 0.58 or older, you need to remove all Telldus configuration from your configuration.yaml file before continuing." on https://www.home-assistant.io/components/tellduslive/ ?


Did you see anything in the logs related to telldus live?


Ii was on 84.6 and moved to 85.0


Nothing. Its like it ignored to import them all in all. Dono if it imports them with numbers and that the system then ignores them cause of the brake changes? Nothing in the loggs so far about why it happens.


Strange, have a look at Configuration -> Integrations and see if you can see something there.


Sorry for that: in my head 0.58 read like 0.85


What is slugify and does this breaking change mean that any existing entity that I have that includes an numeric in the entity_id needs to be changed?


Upgraded from 0.84.6 and appears to have removed all ZHA light entities.
The ZHA device nodes exist but not the light entities
There’s an error ‘Error while setting up platform zha’ for ‘components/light/zha.py (ERROR)’, see screenshot

I did a zha.remove on my fan, restarted and re-added it-- it came back with just the fan and switch entities, light never returned at all. So far only the fan is responding, the switch doesn’t control the light. Previously I could use the switch or light entity of this device to turn light on or off.

On one restart all of my six ETI downlights came back but disappeared on subsequent restarts.
edit: removed fan again to see if I could get light entity back on another permit but noticed the ETI downlights came back. That adds up with earlier when the downlights were back, so that’s not great…