Home Assistant Community

YET another take on an alarm system

#1432

No of course not. I just don’t have any experience with arlo. As discussed in the arlo topic you linked, try to remove it and install it again from ground up.

Else try IFTTT: Arlo - not showing anything at all - not even a Control Panel?

I can’t be of any more help, as i don’t have the hardware. We also should keep this topic free of off topic requests.

References:



0 Likes

#1433

Thanks man! Appreciated!

1 Like

#1434

By updating to 0.85.1, I am getting this error:

Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: “all”

It sounds like a bwalarm thing, since the handling of entities has changed:

Slugify changed, which can impact entity ID creation if the entities had names with either a - or characters outside of A-Z and the integration has no unique IDs. We now better handle the characters and substitute it with an alternative instead of removing that character.

@gazoscalvertos Mind taking a look?

0 Likes

#1435

How exactly did you get it?
I updated to 0.85.1, but didn’t see any errors and alarm worked as expected…

0 Likes

#1436

i’m on 85.1 and even tried with a dev build and dont get any issues

what is the full error message,
Are you using the latest build of the alarm component

0 Likes

#1437

That is changed in 0.85, see the release notes below.

0 Likes

#1438

Hi al, i am also interesed in a new alarm panel , i am now using the MQTT platform and NOT the manual_mqtt platform, because all my logic is my external alam system, i am just sending/receiving mqtt for status and arm/disarm commands, therefore i cant use the manual_mqtt platform
but the mqtt platform now, is verry basic and limited,… so can i use this project instead?

now the onlt thing i can setup is like this below, thats all

alarm_control_panel:
#  - platform: manual_mqtt
  - platform: mqtt
    name: Risco Alarm
    state_topic: "riscopanel/armstatus"
    command_topic: "riscopanel/armstatus/SET"
    payload_disarm: "disarmed" 
    payload_arm_home: "partially"
    payload_arm_away: "armed"
0 Likes

#1439

I see the exact same error. It triggers when I try to arm my alarm. Unfortunately something else also happened after the update. I no longer see the keypad which I also stated in another thread.

0 Likes

#1440

My alarm panel shows the temp info in Celsius, but all my other displays are in Fahrenheit. How do I fix this? I have units set both in configuration.yaml, and under the darksky sensor.

Thank you!

0 Likes

#1441

@AhmadK I am getting it when arming or disarming the alarm.

@aidbish This is the full error

@gerard33 I know… I was on 0.84.6 when it was working fine last time.

@Yoinkz Yes, me too. I have a panel on my lovelace which I am using to arm or disarm the alarm, and I also cant see my keypad. However if I use the default custom panel of this alarm, it works fine, but I still get the same error.

I have this alarm panel and was working fine until 0.84.6 version.
After updating to 0.85.1 it stopped working.
Yesterday I formatted my raspberry and started all over again with new installation of raspbian and HA in virtual environment but still no go…

Two days now, I am trying to figure out what is going on, and I hadnt enabled persistence mode. I just enabled it, and I am now getting this error in addition to the previous one.

3

I have to note that the alarm is working fine. Arming, disarming, triggering and the automations. I am just getting this error and now my panel in lovelace, is useless. I cant disarm the using the default panel unless I open the custom one.

0 Likes

Alarm-panel not showing keypad or Accept input
#1442

Well, all I can say is I updated from 0.83.2 to 0.85.1 and saw some breaking bugs (for example, one cannot have __ in input_boolean, input_datetime, input_number or sensor names) and and plenty of sql-related exceptions in the log. Almost immediately roles it back and waiting patiently for a proper update :wink:

0 Likes

#1443

Did you use the ‘WIPE AND RESTORE’ or the ‘RESTORE SELECTED’?
First time I’m doing this :slight_smile:

0 Likes

#1444

there were breaking changes in .85 regarding entity id’s. have you checked that out in the release notes

post the contents of your alarm config/automations for alarm. this maybe able to help whats going on

0 Likes

#1445

I’m getting the same error about entity_id: “all” however I can’t see anywhere in alarm.yaml or automations.yaml that has a missing entity_id so I’m wondering if it’s in the code code of this alarm system? (ie: bwalarm.py)

0 Likes

#1446

I’m having the same issue. It was working yesterday, then I updated today and no bueno. You’d think that a “warning” wouldn’t limit functionality, but so much for that concept. Hoping for a resolution soon!

0 Likes

#1447

It looks like it’s coming from an http call between the alarm panel and the component. But it’s a little out of my league to figure out (but I am looking into it). Hopefully, @gazoscalvertos can jump in with a quick fix:

2019-01-20 21:55:42 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.1903579856] Received {'type': 'call_service', 'domain': 'alarm_control_panel', 'service': 'alarm_arm_home', 'service_data': {'code': ''}, 'id': 23}
2019-01-20 21:55:42 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=alarm_control_panel, service=alarm_arm_home, service_data=code=>
2019-01-20 21:55:42 WARNING (MainThread) [homeassistant.helpers.service] Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: "all"
2019-01-20 21:55:42 DEBUG (SyncWorker_9) [custom_components.alarm_control_panel.bwalarm] [ALARM] Alarm changing from disarmed to pending
2019-01-20 21:55:42 DEBUG (SyncWorker_9) [custom_components.alarm_control_panel.bwalarm] [ALARM] Pending user leaving house
0 Likes

#1448

I believe it happens when alarm control panel reacts to Away/Home button - it sends an event to the alarm to change state. Needs to be changed in alarm’s code.
However, it’s just became deprecated, and I assume that it does not affect functionality at the moment as it’s only a warning.

0 Likes

#1449

The problem that I’m seeing is that none of my notifications in automation.yaml are being sent. I created a test trigger that works fine, and the only visible indication that something is different is the warning that I’m getting about entity_id; so I am presuming that’s stopping the notifications.

This code works from the switch on the Overview page:

####################
# TEST
####################
- id: test
  alias: 'test'
  trigger:
    platform: sun
    event: sunset
  action:
    - service: notify.ios_tommys_iphone
      data: 
        title: "Alarm Away Mode Armed"
        message: "This stuff isn't working and it's driving me crazy"
    - service: tts.google_say
      entity_id: media_player.living_room
      data:
        message: "This stuff isn't working and it's driving me crazy"s

But this does not, even from manually setting the mode from the Overview page:

####################

Armed - home

####################

  • id: alarm_armed_home
    alias: ‘[Alarm] Home Mode Armed’
    trigger:
    • platform: state
      entity_id: alarm_control_panel.house
      to: ‘armed_home’
      action:
    • service: notify.ios_tommys_iphone
      data:
      title: “Alarm Away Mode Armed”
      message: “The house alarm has been switched on in home mode.”
    • service: tts.google_say
      entity_id: media_player.living_room
      data:
      message: “The house alarm has been switched on in home mode.”
0 Likes

#1450

Well, you didn’t mention it’s not working anymore (mine worked until I rolled Hass.io back).
If that’s the case, it needs to be addressed if the author is still available.

0 Likes

#1451

I’m pretty new to all this, but I just tested again and here’s what I’m finding. Using the code above (with Test and Armed-Home modes), if I 'switch on" test from the Automations section in my Overview page, nothing seems to happen. But if I go into the Logbook page, select the test entity, then choose Trigger from the popup, I’m getting the notifications. But for the alarm, whether I use the Alarm panel, or the Automations section in Overview, or under Logbook - I never get the notifications.

Perhaps I’m an isolated case, and it’s some other issue. But regardless, I’m hoping that someone can help figure out what’s going on !

0 Likes