0.86: New Lovelace UI and Zigbee Management Panel!


#244

it’s a bug they fixed, you need to update your selector (or: better specify which item to select). See issue https://github.com/home-assistant/home-assistant/issues/20393 as well.

Whats is the config you use?


#245

Scraper did not break, it’s just more strict in how you select the elements. Previous selectors worked due to a bug, you (unfortunately) need to update your config. See the issue at https://github.com/home-assistant/home-assistant/issues/20393 as well.

If you post your config, we might be able to help you out.


#246

Thanks @gregg098 I have gone through those instructions a couple of times and also did a reinstall of GPS Logger on my phone with a data and cache clear. Still no joy :sob:
When I get a chance I’ll do a separate post and see if anyone can help.


#247

This is my config:

- platform: scrape
  resource: http://***
  name: Wind
  select: "tr:nth-of-type(4) td:nth-of-type(2)"

And the HTML I try to parse is like this (sorry, not allowed to share the URL):

2019%2021_18_55

Normally I would say, pretty simple …


#248

Yeah, that looks similar to my setup. Only difference, I’ve got single quotes ( ’ ) around the select statement, you have double quotes ( " ) but I’m not sure if that would make a difference.

You sure that the resource URL is correct? It does not redirect to another page (ie https or so)?


#249

I’m sure you have tried all this, but this is where I kept screwing up, mainly because I didn’t read it all the way.

I kept trying to add the latitude, longitude, device ID, etc after the URL, like I used to. I finally realized that only the webhook URL goes in the URL section. Then I removed the long lived token data from the headers and made sure everything else was set per the instructions. Then it just worked.

One way to troubleshoot is to switch to Log View in GPS Logger and scroll to the bottom. It will show you every requests to log and the response.


#250

No longer works through a reverse proxy and connecting direct the page comes up but all my entities are gone. Automations are still working just the UI is broke. Anyone else had this issue? Trying to avoid having to back out to 83.3.


#251

Proxy issue was cert related and resolved. I think the blank page is due to my old UI not being ported over to Love Lace. I will work on rebuilding the UI in the new interface and see if I can get it to work.


#252

Thanks.

In the end i might end Up getting Xiaomi gateway as been waiting for a long time on deconz adding proper support for the cube and vibration sensor so i can actually get tilt/rotational values.


#253

I got issues since 0.86.0 with webcams in lovelace gets broken images if I switch to a tab with webcams, lock my phone and start it up again after a few minutes. I get a grey broken image until i reload the UI. Anyone else?


#254

Yes, I just wanted to report this too.
I have a ffmpeg and netatmo presence camera.
In my browser after some time I need reload the whole page to get the camera working.
In the app I have to push the reload button, which reloads the whole UI. Afterwards the picture of the cameras are shown again.


#255

I’ve had these camera issues as well, but even before 0.86…also using ffmpeg, so this might be the actual common factor.


#256

I have to agree with robg here that radiotherm is broken, haven’t had a chance to dig into why yet but there were some changes to the version of underlying library used.
ERROR (SyncWorker_37) [homeassistant.components.climate.radiotherm] thermostat-xx-xx-xx(192.168.1.xxx) was busy (invalid value returned)


#257

Well it is not really that complicated if you think about it a little. ZHA management is currently the only solution that does native Zigbee integration. All the others solutions you are thinking of do not actually add Zigbee support to Home Assistant but instead add support for specific gateways/bridges/hubs (middleware-brokers) and Home Assistant does not need to know what protocol your devices use, to it it could your devices could in theory just as well been Z-Wave if the Philips Hue Hub support those, Home Assistant just need to talk to the Philips Hue Hub.

Using zigbee2mqtt does not make Home Assistant support Zigbee. That is a third-party gateway solution that converts Zigbee to MQTT. So while zigbee2mqtt might solve Ziogbee for you it is no technically a Zigbee solution for Home Assistant, instead it is just a gateway that talks MQTT with Home Assistant, but Home Assistant is not aware that zigbee2mqtt talks Zigbee to your devices on its end.

No reason to get irritated. Sure, the native ZHA component has been available for about a year but it has not been user-friendly to use before this new Zigbee management panel was added in 0.86 and before it did not support as many types of Zigbee dongles as it does now. I also guess that you are not alone not knowing about ZHA simply for the reason that there was no Zigbee management panel before. For now, no solution is perfect in any case, they all have different flaws or limitations. Documentation could always be improved regardless.


#258

Add me to the list of people that GPSlogger is not working for. I actually don’t use the GPSlogger app, but HTTP POST via Tasker. Worked just fine before. I modified everything to accommodate the breaking change, and I just can’t get it to work. Webhook is in the URL, correct data is in the HTTP Body, content type is correct, just doesn’t update my device tracker in Hass. I even tried with the actual GPSlogger app to see if that was the problem, but no, same result.


#259

Asuswrt not working for me on 0.86.4 via SSH (not tested with telnet or private key) Router: RT-AC66U B1. Server: Raspberry Pi with Docker.
Same error as 0.86, 0.86.2 and 0.86.3: X25519 is not supported by this version of OpenSSL.


#260

Is there anyway to add panel: true within the Lovelace UI? Doesn’t seem very obvious and I don’t really want to have to revert back to editing the yaml after all the hard work that’s been done to make a UI.


#261

I am also getting the same asuswrt error with 0.86.4


#262

same here, asuswrt still not working with the latest hass update - 0.86.4
ssh only - telnet was removed from the firmware couple releases ago


#263

Love the way you say this but don’t actually say how to do it. Couldn’t find anything in the doco about it either.