0.86: New Lovelace UI and Zigbee Management Panel!


#122

Previously as my auto discovered MQTT devices were found they just popped up in the states UI. Now I have to manually refresh the UI to see any new devices.

update: now erratic behaviour sometimes this still works, sometimes not


#123

So i changed my notify to lower case however in the error log it still shows up as and error but it is also still upper case. Is there something you have to do to clear it out. My automation are now all lower case but still getting the error.


#124

I completely agree with you that upgrading can be a source of frustration. In addition, it is difficult to have a test system that completely duplicates the production system. Nevertheless, having something ‘close enough’ is often better than nothing at all. Backups are essential, in the event the production system produces errors that weren’t found while running the test system.

Anyone who just upgrades blindly is, frankly, accepting the risk of rendering their ‘one-and-only’ system unusable … and spending an unplanned weekend debugging it. For better or worse, this is Home Assistant’s nature. Fast-paced evolution … with ‘breaking changes’.


#125

The software development world I came from was; If the authors took the effort to publish an update, there must be a reason for it, therefore it would behoove you to apply the update.


#126

For Home Assistant, that usually applies to minor updates, meaning the “Y” in “0.XX.Y”. For example, 0.86.1 is out and contains corrections for 0.86.0.

That’s not to say 0.86.0 didn’t fix things in 0.85.Y but, as a rule of thumb, important new functionality appears in major updates.

FWIW, I’m still using 0.80.0. In fact, I don’t think there was an 0.80.1 (but i may be wrong). It runs fine and, for my purposes, has all the features I need. When there’s something new released that I want, I’ll make the giant leap forward but not before experimenting with it on parallel system first.


#127

My number one rule of using HA… Never update on V0.xx.0!! You are just simply asking for trouble.

Usually lately I have been waiting to update till either right before or right after the next major version is released. As a case in point I just updated to V0.85.1 yesterday.

And I’m still getting some strange issues in lovelace that I think are related to some custom card shenanigans that updated dependencies that were specifically related to v0.86 since i wasn’t having any problems until i updated some cards via the custom-updater. Hopefully that all calms down by v0.86.7. :wink: I mean the release was out for around one day and it needed a fix already.

Pre-release testing…do it…at least a bit more


#128

Hi,

patform time change to time_pattern, ok but i’ve error on this:

alias: Test
  trigger:
    platform: state
    entity_id: device_tracker.ap_quarto
    from: 'home'
    to: 'not_home'
    for:
      minutes: 5

How resolve this? With 0.85.1 works fine


#130

Card-tools as an example, latest version REQUIRES 0.86

Well they fixed a couple of very minor things. I have been running 0.86.0 since b0 and there was a nasty ID change in b2 but it was painless going to 86.0 and 86.1 … 86.0 is fine really…


#131

No idea if this will work but give it a shot and let us know the results:

for: '00:05:00'

#132

Just upgraded from 85.1 to 86.1 - a HUGE Success! The only issue is Asuswrt doesn’t work.

Thanks to all the Devs for their hard work! We are very grateful.


#133

Upgraded to 0.86.1.
Neato component is now listing an invalid configuration. (Neato D7 Vacuum).
It worked fine in 0.85.1.
Anybody else having this issue?


#134

try only :slight_smile:

  to: 'not_home'
  for:
   minutes: 5

you don’t need

 from: 'home'

i have it working without error.


#135

My AppleTV integration still works, did you happen to move to an IOS beta on your AppleTV, that has broken my AppleTV integration in the past.


#136

update: restarted the HA, and now it is recognizing the vacuum.


#137

Yep worked for me too. Thank you!


#138

Have you restarted your Home Assistant?


#139

I figured it out. It was user error.


#140

I have the same issue as you but my time_pattern changes are correct. I’m going to roll back to 85 for now.


#141

that’s one approach I guess… but eventually you are going to have to fix it so why not now?


#142

So, after some tinkering, I added back the missing wemo and found that all automation jobs were disabled (enabled them fix it)

The new GUI editing tool is cool and make it easy to play with lovelace