0.86: New Lovelace UI and Zigbee Management Panel!


#143

Got an error while upgrading with pip 19.0.1, pip 18.1 works fine (python 3.7.2). pycparser seems to do something wrong.

Collecting pycparser (from cffi>=1.1->bcrypt==3.1.5->homeassistant)
  Downloading https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl (111kB)
    100% |████████████████████████████████| 112kB 1.6MB/s 
Exception:
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 176, in main
    status = self.run(options, args)
  File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 346, in run
    session=session, autobuilding=True
  File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/wheel.py", line 886, in build
    assert have_directory_for_build
AssertionError

#144

have a workaround for AsusWRT use telnet protocol works on 0.86


#145

Just updated to 0.86.2 from 85.1, no issues. Great work devs and congratulations on the lovelace milestone.


#146

Same here. Tried upgrading to 0.86.2 and it broke badly. The UI looked likes this before (using a lot of groups basically on a per-room basis)

grafik

But it changed to

grafik

so all of the grouping are gone.

And also some automations broke (not a time / time_pattern issue):

2019-01-25 09:52:22 ERROR (MainThread) [homeassistant.config] Invalid config for [automation]: Service notify.TelegramXXYYZZ does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got Noee /.../configuration.yaml, line 324). Please check the docs at https://home-assistant.io/components/automation/

Went back to 0.85.1 and everything works as expected.


#147

use lowercase in you service
like notify.telegram…


#148

This used to work in previous versions (even when using upper/lowercase). Any chance that this is an undocumented breaking change then?


#149

Can’t understand about ZigBee management panel, is it out yet? how to access it? will it work with zigbee2mqtt / raspberry pi + cc2531 stick?


#150

hi all,

my update worked nicely for me.
now i am just wondering about best practise to reference custom components without using YAML mode. or is it required to use YAML mode if you have content like this

resources:
  - url: /local/simple-thermostat/simple-thermostat.js?v=1
    type: module

when I run in YAML mode everything works and the custom card is rendered. as soon as i switch to default lovelace, it says the card is not know - obviously because the resources are not loaded.

any hints?

regards,
markus


#151

Use raw editor to add custom components


#152

Hi! Something’s going wrong… can not update from yesterday.
Could not contact Home Assistant Update to check for updates

What is going wrong? Are there issues with my connection?


#153

i think i tried that and the resources were still not picked up. is that the official way to do it? i guess i did it wrong :slight_smile:


#154

Yes it’s the ‘official way’

There was a bug in 0.85.0 (?) that wiped it out I believe but for now that’s the official way to do it.


#155

confirmed! thanks!


#156

Yepp, my scraper broke down to. I even did a clean install of my server (becaus of other issuse) and scraper still dead…


#157

The new slugify means entity ids now follow strick rules. its so much easier to just fix your issues by reading the updated documentation your error links to than going back to an old version expecting it to continue working in the future.


#158

Thanks for the reply. I probably do have Apple betas on, I should have turned that off. I’ll do some more investigation on my end.


#159

1000000x this. Just suck it up and fix it now.


#160
> Blockquote
https://<myha>.duckdns.org/frontend_latest/app-3b4bb4ed.js:365:157 Uncaught TypeError: Illegal constructor
> Blockquote

I don’t know if there’s anyone have the same issue as mine. After upgrading to 0.86.0/1 , I always get a blank overview page while browsing externally and cause a “Illegal constructor” error message in syslog.
I use duckdns+ NGynx and https while I am not home. The strange thing is that it only happens on Google Chrome and IE, but M$ Edge would some how get in and redirected to https://.duckdns.org/lovelace/default_view.
How can I get back to a working overview page?
Thanks.


#161

Can the community now please get a dedicated “Zigbee” sub-forum (equivalent to the “Z-Wave” subforum)?

Would be good to be able to have all threads about configuration of the ZHA component in one subforum.

I think that would show everyone in the community that Zigbee is finanly a first-class citizen in Home Assistant!

Your questions is answered here Suggestion: "Zigbee" sub-forum (equivalent to the "Z-Wave" subforum) here?

Zigbee panel only works with ZHA component, not with bridges/gateways like zigbee2mqtt or deCONZ. See:

ZHA component relies on the Zigpy library and unfortunatly it does not yet have support for CC253x dongles:

Zigpy supports different dongles but developers needs to first write a low-level library for each protocol used.


#162

Could you elaborate on that please? I’ve read the link that is mentioned in the error message, but have no clue how to fix it …