0.87: SmartThings, Areas and Entity Registry UI.


#1

Today we’re releasing Home Assistant 0.87, our third release of the year. Besides a bunch of bugs squashing and performance improvements, we got some cool new features too.

Let’s start with the big one: we now support SmartThings. Via a custom app that can be installed inside SmartThings, you can now push the state of each device, as soon as it changes, to Home Assistant. No more fiddling with MQTT bridges or other solutions. Big shoutout to @andrewsayre for making this possible. Have a look at the SmartThings docs to get started.

New in this release is a new area feature thanks to @Kane610. Areas will allow users to organize their devices by their physical area, like kitchen or living room. This will unlock a whole new range of possible new features (of which none are implemented yet). With this release, users will just be able to manage areas in the configuration panel and place devices in areas via the integration page. In the future, we’re planning to add area based user permissions and a Lovelace area card. If you can’t wait to start leveraging areas today, [@thomasloven] has created a custom Lovelace card that can leverage areas.

This release also includes a UI to manage the entity registry. The entity registry contains all entities with unique IDs that Home Assistant has ever seen. It will allow users to quickly rename entities, change entity IDs or have Home Assistant forget entities that are no longer active.

We didn’t forget about the frontend in this release. In the last release we introduced Lovelace, so for this release we focused on bug squashing, performance improvements and usability. The YAML editor is now rendered using a full editor including line numbers thanks to @bramkragten. There is also a new system health component that will help users diagnose problems from the “info” developer tool. See changelog for the frontend.

In this release we have also upgraded the Material Design Icons to 3.3.92, which renames some icons. Make sure to check their changelog.

If you prefer a podcast over release notes, check out the Hass Podcast in which Phil and Rohan discuss each new Home Assistant release and keep a tap on what’s happening in the home automation space.

New Platforms

New Features

If you need help…

…don’t hesitate to use our very active forums or join us for a little chat. The release notes have comments enabled but it’s preferred if you use the former communication channels. Thanks.

Reporting Issues

Experiencing issues introduced by this release? Please report them in our issue tracker. Make sure to fill in all fields of the issue template.

Breaking Changes

  • SolarEdge sensors: This PR changes the entity names of this sensor and the monitoring condition keys in the configuration: sensor.solaredge_current_power -> sensor.solaredge_current_power, sensor.solaredge_last_day_data -> sensor.solaredge_energy_today, sensor.solaredge_last_month_data -> sensor.solaredge_energy_this_month, sensor.solaredge_last_year_data -> sensor.solaredge_energy_this_year, sensor.solaredge_life_time_data -> sensor.solaredge_lifetime_energy, (@LouisMT - #20109) (sensor.solaredge docs) (breaking change)
  • Geolocation is no longer creating a default group. (@exxamalte - #20338) (geo_location docs) (breaking change)
  • The Dovado sensor platform has been broken up into a Dovado component with sensor and notify platforms. The configuration variables have been changed. Please refer to the documentation for the correct configuration. (@rohankapoorcom - #20339) (dovado docs) (sensor.dovado docs) (breaking change)
  • Brottsplatskartan: The incident type count is reset every day. Before this change, it didn’t reset until you restarted Home assistant. (@chrillux - #20117) (sensor.brottsplatskartan docs) (breaking change)
  • Ambient PWS has new configuration and entity IDs will change. Configure it now via the integrations page. (@bachya - #20332) (ambient_station docs) (sensor.ambient_station docs) (breaking change)
  • New Transmission component. With the introduction of the Transmission component, the configuration for Transmission sensor and switch has been moved to the component configuration. Configuration must be changed accordingly. (@MatteGary - #19230) (transmission docs) (sensor.transmission docs) (breaking change) (new-platform)
  • The alarm control panel will now flag mistyped configs from configuration.yaml correctly as invalid, instead of just ignoring them. (@emontnemery - #20224) (alarm_control_panel docs) (breaking change)
  • MQTT platforms will now flag mistyped configs from configuration.yaml correctly as invalid, instead of just ignoring them. (@emontnemery - #20562) (mqtt docs) (breaking change)

Beta Fixes

All changes


This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2019/02/06/release-87/

#2

So the smart things component allows you to expose your home assistant entities to smart things ? Abit like homekit ? Or?


#3

It is the other way, you can get things from smartthings in Home Assistant.


#4

Great work on this release. I’m keen to see how the new Area’s part works out.

The docs for the update to Transmission are missing, wrong etc. I found a link to the docs preview for 0.87. Not sure what went wrong here, but hopefully this will save some others the hassle of trying to work out what to actually change.

https://deploy-preview-7816–home-assistant-docs.netlify.com/components/transmission/


#5

Fixed the transmission docs, should be live soon.


#6

Actually, gettting this error with Transmission now when HA is starting up.

Error during setup of component transmission
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/setup.py", line 148, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/lib/python3.5/asyncio/futures.py", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 304, in _wakeup
    future.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/transmission.py", line 64, in setup
    username = config[DOMAIN][CONF_USERNAME]
KeyError: 'username'

My config is valid (posted below), I don’t use a username and password. The old way worked fine. Is this something simple to fix or a bug? Happy to open an issue on GitHub if need be.

transmission:
  host: 192.168.1.7
  turtle_mode: true
  monitored_conditions:
    - current_status
    - download_speed
    - upload_speed
    - active_torrents

#7

Already fixed in dev, will be part of 87.1 https://github.com/home-assistant/home-assistant/pull/20575


#8

For anyone using the OpenMQTTGateway on 0.87.0, you will need to remove optimistic and retain flags from your binary_sensor.yaml file for all RF 433Mhz entities.

None of my 433 Mhz components would load with these in place.


#9

HomeKit Controller errors out on startup; Leviton Smart Decora Switches do not load. Gaaah.


#10

I think we still need a confirmation that asuswrt via ssh is working again this release.

anyone?

It’s a big thing that is preventing me from moving past v85.


#11

Regarding asuswrt, the device tracking appears to be working over SSH, but the sensors do not.


#12

Looking forward to testing out the Yeelight Flow functions… but the docs are lacking. What do the values in the dictionary relate to?
ie: TemperatureTransition: [1900, 1000, 80] what are the functions of those values??

Also, there is no indication of how to correctly code for the other transition functions we have available…

The linked Yeelight doc has different syntax so is not really any help.


#13

:fire: Pumped to see the entity registry UI! Areas is going to be awesome. Thanks for all the hard work everyone!


#14

Welcome back Ben!


#15

Looking forward to playing with this release.
I’ve been loving lovelace since receiving the solid nudge in the last release.


#17

solved the issue indeed - using a sonoff rf bridge - no mention on the breaking changes
quickly resolved

thanks.


#18

asuswrt sensors still not working - using SSH configuration to connect


#19

Super frustrating hey.

I even double checked the breaking changes, perhaps I can not read or do not understand the wording of the breaking change (if listed).

On a side note, after sorting all of my RF433Mhz sensors, I noticed no automation’s were working (I have in excess of 100), at all. I had to completely delete my config folder, and files, delete the docker image and roll back to 0.86.4.

Everything working again, so must be something to do with 0.87.0 and the entity registry changes. Need to investigate further before updating again.


#20

Cool - will one be able to specify area in configuration.yaml ?

That’s what I’ve been waiting on as all other platforms like Alexa, homekit and more it’s so tedious using UI only to define it. With hope.


#21

I can’t seem to be able to add entities to an area I’ve created. That should work in the integrations page according to the blog.