0.87: SmartThings, Areas and Entity Registry UI.


#145

There is an add-on that checks your code before updating, for breaking changes … maybe you can try it


#146

After updating it seems the reboot function in HASS (not .io) work not completely on my RP.
When I reboot, states is not completely updated.
When I do A hard reboot (un-power en re-power again) it does !


#147

The last time I tried using that checker it crashed the RPi as well… but as I said, none of the breaking changes apply to my code because I don’t use the relevant components that they affect. As far as I can tell there is no reason for the update to crash the RPi.

EDIT: I just tried running the update for the third time… this time it didn’t crash the RPi and I’m finally updated to 0.87.1 :grinning:


#148

it takes a while for the addon to run… it’s easy to just bail on it without waiting. been there done that.


#149

I’ve had success with that add-on a few times but for whatever the reason, the last time I tried it the RPi completely crashed and had to be power cycled. Very much like the first 2 times I tried to update to 0.87.1 I’m glad it finally updated though… just in time for the next release! (the NUC is still out of action as I haven’t had time to work on it)


#150

When I add my smartthings api token and hit submit, the button just turns to a spinning circle and stays like that forever. Is this normal and I am not waiting long enough or should this complete fairly quickly. Any suggestions on what this might mean?

Thanks