0.88: Persons, Command line auth and event subscriptions


#102

It’s a warning for now but expect it to break the component in the future so I suggest you work out how to fix it… ie fix your script to work with it.

See for example here Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: "all"


#103

I did try what is said in the warning and it broke that script so if it is not the proper way to update the script why post the incorrect info

I even use the script builder in configuration section put in exactly the only way it will take it “entitiy_id”:“all” and this is what I get for my troubles

Error executing service <ServiceCall script.1550718691920 (c:35ae31c2c9b445ed821e85afb55ac133)>

I take it out and leave it blank it works with warnings


#104

There is a hidden group you can turn on with homeassistant.turn_on service.

{
“entity_id”: “group.all_scripts”
}


#105

Open a new topic and post your script.


#106

Anybody else having problems with HassIO-deconz-0.88.1.
Had to fall back to 0.87.1


#107

My scipt is working as it should as long as I leave the entity out of it


#108

What issue?


#109

I get these warnings but really don’t know how to fix them:

20

Any hints? Are they related to what?


#110

Only because HA is currently ignoring the error in it. This may not continue to be the case.

Do you want help to fix this or not?


#111

The primary reason I posted was to point out that the info that the warning tells you to put in to fix the issue breaks the script as far as when my script breaks I can install the entity_id: and put all my devices in separated by comma it will make a little longer script but it works I like how it works now as leaving it blank is cleaner but oh well


#112

It breaks your script the way you have done it, but without you actually posting your script we can’t see what you have done wrong.


#113

I’m not sure if it’s already been mentioned but the extra keys error messages give the wrong line numbers if there are comments at the top of the YAML file


#114

I installed just yesterday for the first time Deconz addon for Hassio and a Conbee stick on 0.88.1 and I’m not getting any issue so far.


#115

I’m having issues with the image_processing tensorflow not working on 0.88, It worked fine until 0.87.1.

Any suggestions?

Because I had to compile my own tensorflow, I had to put it in a custom python folder outside Docker (accessible via \config\deps\lib\python3.6\site-packages), has that changed in any way? Everything else seems to be working fine.


#116

Since updating the notify service for Discord have stopped working for me. Anyone else experiencing this? Trying to gather more info before making an issue.


#117

Discord notify working fine for me.


#118

I am having the same issue with Discord. It broke going to 0.88 and is still broke on 0.88.1 here. I was going to post an issue but haven’t seen anyone else mention it so I assumed it was just me.

Error executing service <ServiceCall notify.discord (c:6cdb0a32c0534b8aacffa31fba6127b4): message=<homeassistant.helpers.template.Template object at 0x6cc1d890>, target=['537018440867774474']>
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/core.py", line 1142, in _safe_execute
    await self._execute_service(handler, service_call)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/core.py", line 1155, in _execute_service
    await handler.func(service_call)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/notify/__init__.py", line 117, in async_notify_message
    await notify_service.async_send_message(**kwargs)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/notify/discord.py", line 43, in async_send_message
    import discord
  File "/usr/local/lib/python3.7/site-packages/discord/__init__.py", line 20, in <module>
    from .client import Client, AppInfo, ChannelPermissions
  File "/usr/local/lib/python3.7/site-packages/discord/client.py", line 38, in <module>
    from .state import ConnectionState
  File "/usr/local/lib/python3.7/site-packages/discord/state.py", line 36, in <module>
    from . import utils, compat
  File "/usr/local/lib/python3.7/site-packages/discord/compat.py", line 32
    create_task = asyncio.async
                              ^
SyntaxError: invalid syntax

#119

Thanks, also damnit! I wonder what’s wrong on my end then…


#120

Yes! Exactly the same error for me. I will make an issue then, since it’s not only me.


#121

well here is my script and it is working with warnings

 alias: Secure Home
 sequence:
 - data: {}
   service: lock.lock
 - data: {}
   service: light.turn_off
 - data: {}
   service: switch.turn_off