0.89: Nissan Leaf, PlayStation 4, Point alarm control, Owlet baby monitor


#82

Are you running any services on your host system using that port, ie. ps4-waker? You’ll need to stop those services. Run in terminal: sudo lsof -i -P -n and see if that port is in the output.


#83

Waze is giving an error, since update:
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity.py”, line 220, in async_update_ha_state
await self.async_device_update()
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity.py”, line 348, in async_device_update
await self.hass.async_add_executor_job(self.update)
File “/usr/local/lib/python3.7/concurrent/futures/thread.py”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.7/site-packages/homeassistant/util/init.py”, line 224, in wrapper
result = method(*args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/homeassistant/components/sensor/waze_travel_time.py”, line 221, in update
route = bytes(route, ‘ISO-8859-1’).decode(‘UTF-8’)
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xdf in position 22: invalid continuation byte


#84

I couldn’t see any fix to the google location tracker issue, so I restarted with 0.88.2 and the issue went away immediately. As there is nothing I need in this release I’ll be waiting for the bugfix release before upgrading.


#85

@maunsen Here it seems your PS4 isn’t responding in time to a search request. Try when your PS4 is on. Does your PS4 also show up with the Home-Assistant device in the app?


#86

@ Ktnrg45 Yes, they are both visible and I can control the PS4 with the App.


#87

In terminal with your venv activated run these commands:
python3

import pyps4_homeassistant

pyps4_homeassistant.ddp.search()

Is there an output or is there an error still?


#88

Will be fixed in 89.1


#90

Yeah mine broke too


#91

By any chance, do you have multiple ps4’s ?
I have 2 but it keeps finding the wrong one.

Anyway to use both or pick one or the other?


#92

Not supported this release. Youll have to choose 1 to use.


#93

Thank You, for the reply!


#94

Yes, that does throw the same error:

  File "<stdin>", line 1, in <module>
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/pyps4_homeassistant/ddp.py", line 100, in search
    data, addr = _send_recv_msg(host, broadcast, msg)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/pyps4_homeassistant/ddp.py", line 89, in _send_recv_msg
    return sock.recvfrom(1024)
socket.timeout: timed out

EDIT:
The Pi and the PS4 are both connected via Ethernet.

EDIT2:
I found the problem. I’m running a VPN Client on my pi and when that is activated, the error is thrown.
When I turn it off, everything works fine.
I guess the problem is completely on my end and I have to figure out the right routing in my setup.


#95

OK. after 0.89.1 it started working again.


#96

This can be fixed with a quick workaround (just tried it, and it works)

You just need to rename the cookie file saved in your home directory - probably /home/homeassistant/.homeassistant - to a different format and restart HA.

Change the name of the file from:
.google_maps_location_sharing.cookies

to:
.google_maps_location_sharing.cookies.example_gmail_com

(replace the @ and . with _)


#97

I can confirm that it worked for me :slight_smile: thanks for the great tip.


#98

My Waze travel time, since 0.89, went banana: I use it to have the amount of minutes required from my home address to work address, in HASS is 300 minutes, but in reality (as is in Waze app) its 20 minutes

Any clue?


#99

Thanks for the heads up, cookie has been recreated, and now working again.

Interesting there is no mention of a fix in the release notes?


#100

Cannot make PS4 media player to work. Integration UI returns “bind to port 987 not possible”, with HA running inside a Docker container (not HASS.IO) and network_mode: host enabled in docker-compose file.

However, "exec"ing into that container and running the command mentioned above returns a (to my understanding) successful result:

[{'status_code': 200, 'status': 'Ok', 'host-id': '0CFE45XXXXXX', 'host-type': 'PS4', 'host-name': 'PS4', 'host-request-port': '997', 'device-discovery-protocol-version': '00020020', 'system-version': '06508011', 'host-ip': '192.168.1.26'}]

Can I use this output to “manually” configure the new component?


#101

Crazy enough, triggering the integration dialog from Microsoft Edge Browser completes succesfully …


#102

same for me