0.89: Nissan Leaf, PlayStation 4, Point alarm control, Owlet baby monitor


#61

Can not update 0.88 to 0.89:

(SyncWorker_11) [hassio.docker.interface] Can’t install homeassistant/raspberrypi3-64-homeassistant:0.89.0 -> 404 Client Error: Not Found (“manifest for homeassistant/raspberrypi3-64-homeassistant:0.89.0 not found”).


#62

Same error here. Hass.io on Raspberry Pi 3B+, currently on 0.88.2


#63

Are you having this issue even if in the Hass.io tab there is the New Update Notice of 0.89.0 or just issuing the hassio ha update --version=0.89.0?

I’ve tried the second one without having the New Update Notice and it didn’t work (I haven’t checked for an error, but it remained to 0.88.2).


#64

Same issue for me. This happened the reboot after running the homeassistant update to 0.89. Now neither the google_maps tracker, or google_hangouts messaging works. They both seem to have issue with authentication.

Google maps now fails with the following error:

2019-03-07 23:37:02 ERROR (SyncWorker_6) [locationsharinglib.Service] Could not open pickle file, either file does not exist or no read access.
2019-03-07 23:37:04 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform google_maps
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/device_tracker/__init__.py", line 184, in async_setup_platform
    disc_info)
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/device_tracker/google_maps.py", line 46, in setup_scanner
    scanner = GoogleMapsScanner(hass, config, see)
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/device_tracker/google_maps.py", line 66, in __init__
    self.service = Service(self.username, self.password, credfile)
  File "/srv/homeassistant/lib/python3.7/site-packages/locationsharinglib/locationsharinglib.py", line 366, in __init__
    cookies_file=cookies_file)
  File "/srv/homeassistant/lib/python3.7/site-packages/locationsharinglib/locationsharinglib.py", line 225, in __init__
    self._authenticate()
  File "/srv/homeassistant/lib/python3.7/site-packages/locationsharinglib/locationsharinglib.py", line 263, in _authenticate
    self._submit_password()
  File "/srv/homeassistant/lib/python3.7/site-packages/locationsharinglib/locationsharinglib.py", line 306, in _submit_password
    raise InvalidCredentials(body)
locationsharinglib.locationsharinglibexceptions.InvalidCredentials: 
[["gf.sicr",null,null,5,null,[null,null,"type: FIRST_AUTH_FACTOR\n",1,null,"INCORRECT_ANSWER_ENTERED",null,null,1,6,null,null,null,null,null,"xxx Homeassistant","[email protected]","https://lh3.googleusercontent.com/xxx/photo.jpg",null,null,1,1,{"1001":[1]
,"5001":[6,["gf.uicd","xxx"]
]
}]
]
]

Google Hangouts had some errors I dont remember, so I attempted to delete the integration, and readd it, now I can’t authenticate it just says ‘Invalid login, please try again later.’


#65

Looks like 0.89 introduced VACUUM.XIAOMI_CLEAN_ZONE as a new service. It was not listed as a breaking change, so hopefully using the COMMAND service with app_zoned_clean still works as well. Can anyone confirm?


#66

yes, still works :slight_smile:


#67

Did not work by pushing on 0.89 update in Hassio>Dashboard>update


#68

I’m confused by how the “Great Migration” is affecting custom components when overwriting an existing HASS integration. Specifically, I overwrite HASS’s unifi device tracker (/homeassistant/device_tracker/unifi.py) with custom_components/device_tracker/unifi.py.

Do I need to copy over /homeassistant/components/unifi/* to my custom_components directory to keep my change? If so, do I also need to do this?:
mv custom_components/device_tracker/unif.py custom_components/unifi/device_tracker.py


#69

This should be your customized unifi.py:

custom_components/device_tracker/unifi.py

This should be a copy taken from homeassistant/components/device_tracker/__init__.py:

custom_components/device_tracker/__init__.py

Be advised that if your customized version of unifi.py is based on source code from a previous release of Home Assistant, it may fail. 0.89’s version of unifi.py may contain modifications that make your customized, older version incompatible.

This is precisely what happened to me. I had customized versions of MQTT climate.py and alarm_control_panel.py based on code from 0.88.1. Climate worked but alarm_control_panel did not. It had undergone a small but important modification in 0.89 that prevented my, ever so slightly older code (0.88.1) from working.

My “Great Migration” adventure is documented in this post. :slight_smile:


#70

Great, thanks @123!


#71

tuya does not work after upgrade


#72

Great work! I really like the PS4 integration, eliminates a custom component. Is XBOX One also on the list?

Thanks for a great release again!


#73

@TravelinMax @Modul8 – I’m seeing this same error too. I’m on a Pi3 running Hassbian.

My Travis-CI build log (which fails due to colorlog can be seen here. Full configuration files can be found on my GitHub.

Any ideas? Currently running 0.88.2 on from the Hassbian installer.

Thanks!


#74

colorlog is not part the core dependency, so that check_config script should not depend on it, I will submit a PR to fix it.

For now, you can change your installation script to pip3 install homeassistant colorlog to fix it temperately. Or if you like colorized log in your travis, you can keep it there.


Problem with “Check Home Assistant configuration” add on
What is up with all these breaking changes?
What is up with all these breaking changes?
#75

Seems like all my webhooks have disappeared too.

The automations are there, but no webhooks. Just tried recreating a new test one and no webhooks are displayed - is this a bug or is there a breaking change i have missed?

I am logged into the cloud and the account is active.

TIA

mb


#76

@awarecan – Thanks. So if I actually tell Home Assistant to update on my Pi the colorlog error shouldn’t cause the update to fail, right?

I think my Google Maps Travel Time configuration is fine based on the breaking changes in 0.89.0. YAML can be found here https://github.com/brianjking/homeassistant-config/blob/master/sensor/google-maps-travel-time.yaml.

- platform: google_travel_time
  name: Home to Kinna Work
  api_key: !secret gmaps
  origin: !secret homelocation
  destination: !secret kwork
  options:
    mode: transit

- platform: google_travel_time
  name: Kinna Work to Home 
  api_key: !secret gmaps
  origin: !secret kwork
  destination: !secret homelocation 
  options:
    mode: transit

My TP-Link switches I commented out and just set to have discovery: true as seen here https://github.com/brianjking/homeassistant-config/blob/master/switch/tp-link.yaml.

 - platform: tplink
   discovery: true
   #host: 192.168.1.121
   #name: Tribot
 #- platform: tplink
   #discovery: false
   #host: 192.168.1.122
   #name: Christmas Tree  

#77

That import error terminated the configuration checking. You probably need pip install colorlog first to allow check config script work.


#78

Is it just me that the last 2 updates wont download?
My system log:

19-03-07 19:31:01 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.89.0 19-03-07 19:36:03 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.89.0 19-03-07 19:36:03 INFO (SyncWorker_7) [hassio.docker.interface] Update Docker homeassistant/qemux86-64-homeassistant:0.88.1 to homeassistant/qemux86-64-homeassistant:0.89.0 19-03-07 19:36:03 INFO (SyncWorker_7) [hassio.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.89.0. 19-03-07 19:36:34 ERROR (SyncWorker_7) [hassio.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.89.0 -> 404 Client Error: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:0.89.0: No such image: homeassistant/qemux86-64-homeassistant:0.89.0”). 19-03-07 19:36:34 WARNING (MainThread) [hassio.homeassistant] Home Assistant is already running!

In the Hassio>Dashboard Tab it says I’m currently running ver. 0.88.1
I click update and the little circle spins for a min or so then it turns to a red box around it and nothing updates.


#79

I’m getting same error but on Hassio.
Any workaround for this?


#81

I am having issues including my PS4.
I’m running Home Assistant in venv on a Pi 3 with raspbian stretch.
My PS4, the Pi and my phone are on the same network.
I followed the steps in step2 of the guide.
In the PS4 Second Screen App on Android I can see the Home Assistant Device, but when I click on it Home Assistant throws an “Unknown error occurred” in the frontend.
The log says this:

2019-03-07 20:46:18 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/aiohttp/web_protocol.py", line 418, in start
    resp = await task
  File "/usr/lib/python3.5/asyncio/futures.py", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 304, in _wakeup
    future.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/asyncio/tasks.py", line 241, in _step
    result = coro.throw(exc)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/aiohttp/web_app.py", line 458, in _handle
    resp = await handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/aiohttp/web_middlewares.py", line 119, in impl
    return await handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/http/real_ip.py", line 33, in real_ip_middleware
    return await handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/http/ban.py", line 68, in ban_middleware
    return await handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/http/auth.py", line 98, in auth_middleware
    return await handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/http/view.py", line 112, in handle
    result = await result
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/config/config_entries.py", line 144, in post
    return await super().post(request, flow_id)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/http/data_validator.py", line 46, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/helpers/data_entry_flow.py", line 86, in post
    result = await self._flow_mgr.async_configure(flow_id, data)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/data_entry_flow.py", line 80, in async_configure
    flow, step_id, user_input)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/data_entry_flow.py", line 98, in _async_handle_step
    result = await getattr(flow, method)(user_input)  # type: Dict
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/ps4/config_flow.py", line 60, in async_step_creds
    return await self.async_step_link()
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components/ps4/config_flow.py", line 72, in async_step_link
    self.helper.has_devices)
  File "/usr/lib/python3.5/asyncio/futures.py", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 304, in _wakeup
    future.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/pyps4_homeassistant/helpers.py", line 21, in has_devices
    devices = ddp.search()
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/pyps4_homeassistant/ddp.py", line 100, in search
    data, addr = _send_recv_msg(host, broadcast, msg)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/pyps4_homeassistant/ddp.py", line 89, in _send_recv_msg
    return sock.recvfrom(1024)
socket.timeout: timed out

Any Ideas what is going wrong?
Thanks in advance!