0.91: More streaming, better Zigbee, cameras with ESPHome

But does it normally take this long? It was released the 10th. Is there a place I can see the latest Hass.io version?

Try this
From ssh

hassio ha update --version=0.91.3

I updated to 0.91.3 a few days ago so it should be available.

No, I had it since some days, updated yesterday

Yes, I guess I could do that. Just curious what would cause it not to show up.

Unfortunately I’ll have to go back to v89. This version broke my Xiaomi_aqara component. I tried regenerating the key a few times, nothing seems to work, it just says (MainThread) [homeassistant.config] Invalid config for [xiaomi_aqara]: required key not provided @ data[‘xiaomi_aqara’][‘gateways’][1][‘mac’]. Got None. (See /config/configuration.yaml, line 21). Please check the docs at https://home-assistant.io/components/xiaomi_aqara/
As far as I’m concerned, it is configured correctly and it worked perfectly before updating to this version. Anybody else with a Xiaomi Mi Gateway experiencing the same issue?

2 Xiaomi gateways working perfectly fine on 91.3 and also tested with latest beta without issue

Thanks for confirming, I will try to play about with it, hopefully get it to work. Reverting back to v89.1 it works perfectly, when I update Home Assistant, it stops working. I have default config:
discovery_retry: 5
- mac: 7C:49:EB:xx:xx:xx
- key: **************
Not really sure what makes it break.

Xiaomi gateway works fine here on 0.91.x

Try removing the colons from the MAC address, the description of the mac option says:

The MAC address of your gateway. Needs to be formatted without “:”.

I don’t know if this changed in this version.

You don’t even need the MAC address unless you have more than one gateway.

Is anyone else having persistent issues with Yeelight?

Have tried restarting multiple times, using discovery and not, config is all up to scratch.

0.91.0 works perfectly fine and have rolled back and forth - with 0.91.4 entities appear as unavailable and I see the following error consistently:

2019-04-24 20:32:58 ERROR (MainThread) [homeassistant.components.light] yeelight: Error on device update!
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 261, in _async_add_entity
    await entity.async_device_update(warning=False)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity.py", line 379, in async_device_update
    await self.hass.async_add_executor_job(self.update)
  File "/usr/local/lib/python3.6/asyncio/futures.py", line 331, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/local/lib/python3.6/asyncio/tasks.py", line 244, in _wakeup
  File "/usr/local/lib/python3.6/asyncio/futures.py", line 244, in result
    raise self._exception
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/yeelight/light.py", line 356, in update
    elif self.light_type == yeelight.enums.LightType.Ambient:
AttributeError: module 'yeelight' has no attribute 'enums'

As far as I can tell I dont get any errors, but my mi desk lamp is not being found at all.

# Yeelight
  - platform: yeelight
        name: Office Desk

In your case I suspect it’s down to config. As outlined above there was a breaking change to Yeelight - it is no longer nestled within the light component and is its own component. See here

Therefore your config should show:

      name: Office Desk

And not

- platform: yeelight
      name: Office Desk

In my case my config has been updated per the docs, so if anyone else can help please let me know!

1 Like

D’oh. I missed that note!

I have the same black screen with “Smart Home Camera” when asking Google Home to stream Camera xxx to Living Room TV. I’ve tried ticking “preload stream” in the lovelace UI as dshokouhi suggested. Still no camera feed on my Sony Bravia Android TV

Same error for me

Same problem here - “Smart Home Camera” all around. Whether on Chromecast or a Google Home Hub. This is confirmed behavior without “Preload Stream” enabled, and also looks to be the same even when preload is turned on. Sad panda. I suspect that I can do a manual service call, but I actually haven’t been able to find the time between kids, etc.

I also openly wonder if this is a case of the NabuCasa (which I am subscribed to for sanity) not issuing the right calls to connect the two. Who knows.

Ever get this working?

I get the same thing with my Amcrest cameras.

I did in fact get it working - The problem was a malformed URL for the camera. So, operator error.