Home Assistant Community

0.93 Upgrade and Zwave

#1

Just started with Hassio last week (so a bit of a noob) and I see the new 0.93 upgrade is available. The check config addon throws up a problem with the z-wave. I see in the release notes it mentions there is a problem with copying over zwave config files, I assume this is the problem I see in the checker? If so it is ok to upgrade, if not should I be leaving the upgrade.

The only reason for moving to the new release is adding in the Sonos is next on my list which I see has a significant change which would be easier to do on the new release rather than go back through and change things.

Thanks
Chris

#2

Welcome!
My current strategy is to wait for 0.93.2 or one week after release, whichever happens first.
In my experience, there are usually many bugs when a major version is first released. By the second patch, most major ones have been resolved.

1 Like
#3

can you post a link to that or at least copy the pertinent bit? i scanned the release notes and didn’t see anything zwave related.

#4

Sure it was in the blog on the release: https://www.home-assistant.io/blog/2019/05/16/release-93/

Last part before the Beta fixes

#5

Normally my view as well but wanted to get the Sonos working it was the last piece other than Alexa integration to complete from moving my small Vera setup across to HA. As you say, probably best to do without the pain of a new release when still getting to grips with HA.

1 Like
#6

Maybe you should post the errors that you see. I believe the release notes are referring to manually copying over config files. It should not have anything to do with the config checker.

#7

The Sonos configuration changes needed for a 0.92 -> 0.93 migration are small, don’t worry.

It is highlighted in the release note because it affects a lot of setups, not because it is a big change.

1 Like
#8

Here is the error I get

Blockquote
[Info] Start install HomeAssistant latest
You are using pip version 19.0.3, however version 19.1.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
[Info] Installed homeassistant==0.93.0, check config now
[Error] Wrong config found!
Testing configuration at /tmp/config
INFO:homeassistant.util.package:Attempting install of influxdb==5.2.0
INFO:homeassistant.util.package:Attempting install of hbmqtt==0.9.4
INFO:homeassistant.util.package:Attempting install of paho-mqtt==1.4.0
INFO:homeassistant.util.package:Attempting install of mutagen==1.42.0
INFO:homeassistant.util.package:Attempting install of netdisco==2.6.0
INFO:homeassistant.util.package:Attempting install of homeassistant-pyozw==0.1.4
ERROR:homeassistant.util.package:Unable to install package homeassistant-pyozw==0.1.4: Failed building wheel for homeassistant-pyozw
Failed cleaning build dir for homeassistant-pyozw
Command “/usr/local/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-install-46_8ducz/homeassistant-pyozw/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-7zx02tta/install-record.txt --single-version-externally-managed --prefix --compile --user --prefix=” failed with error code 1 in /tmp/pip-install-46_8ducz/homeassistant-pyozw/
You are using pip version 19.0.3, however version 19.1.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
ERROR:homeassistant.requirements:Not initializing zwave because could not install requirement homeassistant-pyozw==0.1.4
INFO:homeassistant.util.package:Attempting install of libpurecool==0.5.0
INFO:homeassistant.util.package:Attempting install of aiohttp_cors==0.7.0
Failed config
General Errors:
- Unable to install all requirements: homeassistant-pyozw==0.1.4, pydispatcher==2.0.5

#9

I noticed in the release thread that same error was posted and the response was that the config checker is broken. I don’t know the details of Hass.io upgrades, but doesn’t it just install a new docker image? If that’s the case, the docker image would already have the correct pyozw package installed. It looks like the config checker is actively attempting to install the pyozw package in a temporary environment, which usually requires compiling the zwave library. The compiler dependencies are likely not included in the docker image, causing the build it to fail. So it could be that Hass.io upgrades will succeed, but the checker does not. Just a guess, as I don’t use Hass.io.

#10

Checker worked fine for me. Just pip complaint.

#11

You’re also using Hass.io?

#12

Hassio on Raspbian Lite

#13

Hass.io on Raspbian Lite != Hass.io from image, which could explain the different behavior. :man_shrugging:

#14

Home assistant and the configuration checker add on are both running in the same Docker container environments. I ran it on 0.92.2.

#15

So if it works fine for you it may be a problem for me. I’ll hang on for some updates as I don’t want to lose z-wave. I only have a few devices on z-wave but they are important.

#16

Do you have a zwave entry in your configuration.yaml, or are you relying on the Integration?

#17

Yes I have a zwave entry in the configuration.yaml. If I recall it didn’t automatically get picked up so need to include it I’ve also added some changes as my power switches weren’t updating if they were on or off they always appeared as on without changing the polling.

#18

I moved from configuration.yaml to integration as recommended by the Release Notes at that time.

#19

I would assume the config checker is only examining the contents of configuration.yaml. So if it sees zwave: it will install the dependencies of the zwave component. If you’re using the Integration it won’t do that, hence no failure. Anyways, that’s the last explanation I can come up with. :slight_smile:

#20

It is all very confusing as someone starting out as there are years of suggestions for working around issues on older versions and you never know what you should do! Without the zwave in the yaml I wasn’t even seeing the Aeon stick.