0.95: AdGuard, Life360, Plaato Airlock

It is time for release 0.95, and guess what? It’s good! First things first, did you see the new Raspberry Pi 4? 3x as fast as the model 3, gigabit ethernet port actually supports gigabit speeds now, faster memory read/write, oh well, faster everything! The benchmarks are impressive. Best of all? The base price stayed the same. However, you can now also pay more for upgraded models with more memory, which is great if you like to install all the hass.io add-ons.

Talking about Hass.io support, we’ve received ours and work to add support will start shortly 🚀. Since we’re discussing Raspberry Pi’s, can we talk SD cards really quick? Quality matters. When you buy SD Cards get the pro variants, preferably the ones that are class A1 or, even better, class A2. The A stands for application and they are optimized for running apps, like Home Assistant.

LOOK WHAT WE HAVE HERE 😍 pic.twitter.com/HrEu1a272Y

— Pascal Vizeli (@pvizeli) June 26, 2019

RV Assistant

Home Assistant is not just limited to homes. Recently we had a boat owner on Home Assistant podcast episode 48, and Home Assistant also powers recreational vehicles (RV) (like this schoolbus).

With this release, we’re making integrating Home Assistant into moving vehicles so much easier. In the last release, we introduced support for the core config to be updated without restarting Home Assistant. This release brings it a step further and introduces a new service homeassistant.set_location. With this service, you can automatically change the location that Home Assistant is located. Once updated, it automatically updates all the things that rely on the location, like your sunset triggers and your current weather (only Met supported now).

AdGuard Home - local ad-and-tracker blocking

Here at Home Assistant, we’re big fans of privacy and we’re always working on improving it. So this brings us to AdGuard. AdGuard Home is a local DNS server that automatically blocks any device looking up a domain that is used to serve ads, spreads malware, or isn’t appropriate for your kids. Thanks to @frenck, starting release 0.95, it has a top-notch integration with Home Assistant:

One cool new feature: because parental control is now available as a switch, you can control AdGuard via Alexa and Google: “Hey Google, turn on parental control” 😲.

Frenck shows a demo of the AdGuard integration during his stream. See the full stream.

Life360

More goodies. Keep paying attention as we’re not done yet. Also new in 0.95 is the Life360 integration thanks to the hard work by @pnbruckner. This integration started its life a little over 360 days ago on the forums as a custom integration and has now become part of Home Assistant. Life360 is an app to allow friends or family members to share location with each other.

If you are migrating from the custom integration, please read the instructions.

Improved Alexa integration

One more thing… This release improves the Home Assistant Cloud Alexa integration. Just like Google Assistant, it is now possible to manage which entities are exposed to Amazon via the user interface. Alexa actually offers some cool features around this. Any change you make is reflected instantly inside Alexa. Add an entity? Control it instantly via Alexa.

However, we didn’t stop there. The manual installations of Alexa has had optional proactive state reporting since earlier this year, and this is now available for Home Assistant Cloud users too. If you choose to opt-in to this, every state change of your exposed entities is sent to Amazon as soon as they happen. It allows Amazon Echos with displays, to instantly reflect the state and allows you to create routines inside Amazon powered by your Home Assistant entities.

More icons available

Austin Andrews, the lead designer of Material Design Icons, informed us that Material Design Icons 3.7.95 has been released. It includes a handful of the top requested Home Assistant icons (and a total of 100 new icons!).

Released v3.7.95 to NPM/CDN. 100 new icons! 🧙‍♂️ Preview: https://t.co/N02X3rnQ8N Read more: https://t.co/CHQ3TEdVM2 #MaterialDesign #OpenSource pic.twitter.com/LlWy8RfFVu

— Material Icons (@MaterialIcons) June 22, 2019

Noteworthy breaking changes

For the last couple of releases, we’ve been printing warnings if your configuration contained invalid slugs or extra keys. Starting with this release, these warnings are now errors. No procrastination anymore, you’ll need to fix it now.

We have also realized that the default database clean up task never automatically ran as intended. Instead of running every night, cleaning up your history so that it only contains the last 10 days, it never ran. Oopsie. We’ve fixed it in this release, so now the defaults kick in. Want to adjust how much history you want to retain? Check the docs.

New Integrations

New Platforms

If you need help…

…don’t hesitate to use our very active forums or join us for a little chat.

Reporting Issues

Experiencing issues introduced by this release? Please report them in our issue tracker. Make sure to fill in all fields of the issue template.

Breaking Changes

Beta Fixes

All changes


This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2019/06/26/release-95/
3 Likes

Smooth Upgrade, Thanks all involved.

Yay! I’ve just set up AdGuard Home in prep for this after seeing some of Frenck’s tweets.

1 Like

I’m getting a:

Successfully installed homeassistant-0.95.0 pyyaml-5.1 ruamel.yaml-0.15.97

And then it just hangs indefinitely.
Tried to downgrade and also hangs, still banging my head to check how to recover.

Great release - smooth upgrade and cool new features to enjoy. The Alexa UI is a lot more convenient and user-friendly. Life360 is absolutely amazing for presence detection (been using the custom component for a long time and it’s always been rock solid. The best device tracker imo - glad to see it “graduate” to a standard integration).

And I just installed the AdGuard integration the other day after watching Frenck’s livestream. Really impressed with how easy it was to get up and running and the various services and switches that make it easy to automate.

1 Like

I’ll have to try the Alexa features, it looks cool.

Just a quick note, the link to the docs for the vlc_telnet component seems to be broken:

https://www.home-assistant.io/components/vlc_telnet/

Fantastic job as always !
I was waiting for google_cloud text-to-speech ( tired of standard google assistant voices).
I’ve setup it but cannot make it work.
My log always says

WARNING (SyncWorker_13) [homeassistant.components.google] Please re-authenticate with Google.

And no tts service is available.

Do you have any idea ?

Thanks :slight_smile:

I have been facing bluetooth problems since 0.94 and was hoping it would be resolved in 0.95 but no joy. I even opened an issue but had no response from the devs.

Guys please look into bluepy. I am running HA in docker compose mode with network set as host. Things were working fine before 0.94 update and all of a sudden bluetooth has stopped working.

I cannot use switchbot nor xiaomi bt temp and humidity sensor.

Please look into it. @Danielhiversen

Thanks.

:face_with_raised_eyebrow: it seems that the “re-authenticate” message is not related to google_cloud. I have deactivate it and I still see it in logs… [EDIT] it seems to have something related to google calendar platform. I will have a look at this[/edit]
[EDIT2] ok my bad, the re-authenticate message is definitely for google calendar. There is even an home assistant persistent notification to solve the connection to google calendar[/edit]

That means google_cloud config does not provide tts service ?

2 Likes

Upgrade seemed fine at first, but I’m now seeing this error in my logs.

Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py”, line 275, in data_received
messages, upgraded, tail = self._request_parser.feed_data(data)
File “aiohttp/_http_parser.pyx”, line 523, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method

Looks like this is an open issue in this github issue.

Couldn’t find anything else in the forums on this, so any pointers/ideas?

I had no idea about the A1 and A2 ratings for SD cards. I checked the card I just bought for my Pi 4 and it’s A1 so I’m good. Still going to move the db off the SD card to extend its life though

Looks like the “breaking changes” section has reverted to the old fairly vague descriptions.

What exactly does “Restore automation last_triggered with initial_state override” mean?

What does it break?

the link to the docs included in the breaking change entry doesn’t really give any info on this either.

I had the same issue that bt stopped working.
Backed up config and reinstalled, suddenly came back.

This usually means that if you’re using SSL, someone is connecting to Home Assistant using http://, or the other way around.

The person who usually contributes these is on holiday. Extended breaking changes are available in the PRs linked from the vague descriptions. Source of the blog post is here. Contributions to bring them to the blog post are welcome.

1 Like

If you would be interested in bringing USB boot (so we could use an external SSD, say to run Hass.os from), please consider supporting this feature request:

If you too would like to see SSD bootable Hass.os drives, please support the Feature Requesrt by voting for it.
I’m hoping it might be possible, @balloob ?

2 Likes

already done :slight_smile:

Kinda two fold though, I am also hanging out for the Pi 4 image too.

1 Like

Yeah, there’s something wrong with it. All of a sudden BT devices stopped working for me as well. However in my case disconnecting BT dongle and reconnecting it + HA restart helped

THANK franks

for adGuard

Been watching you channel

JOB WELL DONE :beers:


Testing configuration at /home/homeassistant/.homeassistant/.
Failed config
  General Errors: 
    - Platform not found: tts.google_cloud

Successful config (partial)

won’t work for me :frowning: