1.5.0 Feedback

as per @mynameisdaniel, leave legacy and basic authentication unchecked, then press save

1 Like

I have the same, and even with the username and password

What does “Use internal URL” do?

Thanks to all who have worked on this great new version of the app!

I have used it for a couple of hours now and noticed one small issue:

  • When entering a zone the displayed text is not correct. It used to show the zone name which you were entering.


Just tried, using internal URL. Get:
Error: invalid client id or redirect uri

When I click Cancel I then get: There was an error connecting … The operation couldn’t be completed. (HomeAssistant.AuthenticationController.AuthenticationControllerError error 1.)

Tried it both with Basis authentication on or off.

In the log file I get:
2018-09-27 15:09:38 ERROR (MainThread) [homeassistant.core] Error doing job: SSL error in data received
Traceback (most recent call last):
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/asyncio/sslproto.py”, line 526, in data_received
ssldata, appdata = self._sslpipe.feed_ssldata(data)
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/asyncio/sslproto.py”, line 189, in feed_ssldata
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/ssl.py”, line 763, in do_handshake
ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1045)

I do not have SSL setup but then it is not exposed to the outside either and just trying to use it with internal URL.

I have been testing this for a while now.

As per other posts, leave legacy and basic auth off.

I have found the best way to get this working is to reset the app at the bottom, enter the URL under connection and tap save. It should then take you to the normal home assistant logon screen. I enter user and password and then it prompts for 2FA.

You will probably then find that all the status’s have X’s instead of ticks. Tap on Done and you might get an unable to connect error. If you then force close the app and re-open it, you should see ticks in the status area and HA should work normally.

FWIW, I am using Google Assistant as well and it is working fine without legacy_api being enabled on my system. @awarecan has I believe made a change to the component for the next release that will integrate it into the new auth correctly but for now it is working fine without legacy_api. I did setup my GA component before it required an API password to be entered in it.

Fix is inbound on that

I use CloudFlare for my site and I have one-time pin selected. It allows me to get a one-time pin and then redirects to HASS Login page.

When I give the login details, it then goes back to the config setting screen and says ObjectMapper failed to serialize response. Basic, Legacy and Internal all set to Off.

Please go ahead and open a issue on GitHub with those details + anything else relevant + screenshot of the error. Thanks!

I still see the settings icons on my iphone X but how did you minimize the top menu? Or did you simply cut the screenshot? I´m frustrated that the menus takes up almost 1/3rd of the screen.

I’m in pretty much the same situation, have setup GA a long time ago. When I switched to MFA I decided to stop support for legacy auth to further protect my setup, I also decided to upgrade GA to use a long like token. the long life token doesn’t work when legacy auth is enabled, and I re-enabled legacy auth to stop getting ip_banned on my mobile devices…

I’m not using long-life tokens OR legacy_auth. It just works without either.

I am getting it…

HI @robbiet480

is there any way to install this beta next to the current app? I don’t want to change setup just yet and lose my 075.3 functionality.

It should be possible, I have the Plex app and the Plex beta app running just fine together.

It seems to me that the app i backwards compatible so you don´t need to update to hass 0.77+ for using the app. I´m running it fine with v0.76.2.

With legacy and basic auth off I am still being locked out of accessing HA because I get ip banned when moving from wifi to 4G cellular networks.

I also had my iphone 6 lock up requiring a force restart (hold home + power) for the first time in years today. That’s the fun of beta testing I guess.

Can confirm it’s working allright with the latest beta :+1:

sure, but it’s not a matter of updating the HA instance, but of testing the beta (with all its yet to be cleared flukes, inherent to being a beta) and being able to use a stable setup of the current App.

If not, no beta testing I am afraid.

The new app feels way faster.

Is it possible to add horizontal swiping to switch views?


Any chance of getting shortcuts integration?