1.5.0 Feedback

beta-testing
Tags: #<Tag:0x00007f4801179f08>

#1

Use this thread to provide feedback on 1.5.0.

Changelog:

New Features:

  • Migrate all API and associated functions to a new Shared framework which will allow us to more easily build integrations to other parts of iOS as well as significantly reduce bugs
  • New Auth API support
  • Event logging

Improvements:

  • Major internal overhaul of API, classes, division of duties and more
  • Refactored Location
    • Removed SwiftLocation in favor of a custom implementation
    • Now using Core Motion to determine motion type during location updates. This might be removed later
    • Start using the Visits Location Service as another trigger for location updates
    • Store zones in Realm for easier access
    • iBeacon support improved

Bug fixes:

  • Modified device_tracker.see to be compliant with schema
  • Webview fixes
    • General UI fixes like making sure buttons at bottom are always there and ordered properly
    • Support basic authentication on the UI only
    • Catch more errors
  • The app should be disconnecting less, if at all

Misc:

  • Updated translation strings

Public Beta Testing is now open!
False Failed Login Notifications
iOS Notifications disappearing - ios.conf missing
#2

Hi Robbie. Great job :blush:

Just installed the beta. I am having trouble connecting. I activate base authentication and type in my credentials. After pressing save and done, I get a screen saying “unable to connect to home assistant” I can then retry, or press an invisible settings button in the lower right corner. The credentials are definitely correct. Any ideas of what could be wrong?


#3

Hey @robbiet480,
I was playing around with the beta today. The scrolling system feels rather clunky compared to the current app.

Other than that, I signed in with the new auth system without issues. :+1:


#4

Basic authentication is something different again (thanks for including it Robbie) - if you’re just using the new Home Assistant user system to authenticate, leave legacy and basic authentication unchecked, then press save. That’ll then prompt you to log in.


#5

Having problems connecting with legacy mode:


#6

Aaaah I see. Works now. Thanks for helping me out =)


#7

Thanks, just installed. Is there any specific you want us to test?
I noticed with the official app/version I have loads of authentication issues when moving out of trusted networks and my cell IP address eventually gets banned.
I therefore still have legacy enabled for that purpose.
Can you therefore confirm that the app will work with legacy disabled and MFA enabled?


Login attempt failed warnings periodically showing up
#8

I can not see settings on my iphone X


#9

I’m glad this is not just me. Seems to happen when moving from wifi to 4G networks. Doesn’t matter if it’s a trusted network or not. Happens at home (trusted) or at work (not a trusted network). I haven’t worked out if it is because I have the app open when actually moving between networks or not.


#10

he he same here. Had to bring back the legacy auth support and do the same on Google Home as the long life token would not work with legacy either. Will try and test this later with the beta app


#11

Getting this too.


#12

as per @mynameisdaniel, leave legacy and basic authentication unchecked, then press save


#14

I have the same, and even with the username and password


#15

What does “Use internal URL” do?


#16

Thanks to all who have worked on this great new version of the app!

I have used it for a couple of hours now and noticed one small issue:

  • When entering a zone the displayed text is not correct. It used to show the zone name which you were entering.

screenshot_location


#17

Just tried, using internal URL. Get:
Error: invalid client id or redirect uri

When I click Cancel I then get: There was an error connecting … The operation couldn’t be completed. (HomeAssistant.AuthenticationController.AuthenticationControllerError error 1.)

Tried it both with Basis authentication on or off.

In the log file I get:
2018-09-27 15:09:38 ERROR (MainThread) [homeassistant.core] Error doing job: SSL error in data received
Traceback (most recent call last):
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/asyncio/sslproto.py”, line 526, in data_received
ssldata, appdata = self._sslpipe.feed_ssldata(data)
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/asyncio/sslproto.py”, line 189, in feed_ssldata
self._sslobj.do_handshake()
File “/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/ssl.py”, line 763, in do_handshake
self._sslobj.do_handshake()
ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1045)

I do not have SSL setup but then it is not exposed to the outside either and just trying to use it with internal URL.


#18

I have been testing this for a while now.

As per other posts, leave legacy and basic auth off.

I have found the best way to get this working is to reset the app at the bottom, enter the URL under connection and tap save. It should then take you to the normal home assistant logon screen. I enter user and password and then it prompts for 2FA.

You will probably then find that all the status’s have X’s instead of ticks. Tap on Done and you might get an unable to connect error. If you then force close the app and re-open it, you should see ticks in the status area and HA should work normally.

FWIW, I am using Google Assistant as well and it is working fine without legacy_api being enabled on my system. @awarecan has I believe made a change to the component for the next release that will integrate it into the new auth correctly but for now it is working fine without legacy_api. I did setup my GA component before it required an API password to be entered in it.


Installed Duckdns add-on and now cannot connect to my hassio using the app
#19

Fix is inbound on that


#20

I use CloudFlare for my site and I have one-time pin selected. It allows me to get a one-time pin and then redirects to HASS Login page.

When I give the login details, it then goes back to the config setting screen and says ObjectMapper failed to serialize response. Basic, Legacy and Internal all set to Off.


#21

Please go ahead and open a issue on GitHub with those details + anything else relevant + screenshot of the error. Thanks!