.103 update not installing

Saw there was an update to .103. Tried it twice. First time waited 30 minutes and Lovelace didn’t load. Reset the pie and after 5 minutes .102.3 loaded. Tried again withe db renamed. No difference. Nothing obvious showing in log. Any idea on what to try next?

Having the exact same issue. Tried updating and didn’t respond to anything so i restarted HA. Nothing happend and now i’m stuck and can’t connect to the front-end.

I did a reset of my pi and it came up after 5 minutes with the old version. Do you have many custom components installed? Maybe we have something in common causing the issue. I have badnest and wyzesense that I believe are not supported.

Did you just unplugged the pie and put it bag on? don’t have many custom components.

I have a switch. Turned it off waited 30 seconds and turned it back on. Unplugging works also.

going to try it out when i get back home… frustrating…

I had the same issue (but with Hass.io). What I’ve done

Waited for CPU finishes all operations (I checked it using htop)
Then I connected to Hassio via ssh and run hassio info There was 103 version
Rebooted my Pi using sudo reboot

After that lovelace is up and I have 103 version

Before you try to upgrade again, install the Hass.io Core Add-on: Check Home Assistant configuration and run that. Be patient, as it takes a while to run.

1 Like

Waited 15 minutes. No errors other than pip version. How long does this take? Just got this
General Errors:
- Component error: wemo - No module named ‘netdisco’
Removed wemo, rebooted and no errors found.
Will try the update again. Failed again. No errors in config.

What is htop?

My pie is up and running again. Not looking forward to update it again

Are you on .103?

it’a a tool for CPU / memory monitoring

Did you run this on your pi?

No… I’m going on holiday tommorow so will wait with the update

So yours did like mine, reverted to .102.3. ?

Yes. With the log file completely empty. Can’t read what went wrong.

Do you have the wyzesense component installed?

No i haven’t
But did try to update again and getting this error now:

19-12-12 18:52:40 ERROR (SyncWorker_5) [hassio.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:0.103.0 -> 500 Server Error: Internal Server Error ("readlink /mnt/data/docker/overlay2/l: invalid argument").
19-12-12 18:52:40 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

Yes, or just use ‘top’ command
It’s useful when you want to check what’s happening in your rpi at the moment
Like task manager in Windows