2021.1: Happy New Year!

Guys i really love you, this project is born in the right way and evolving in a semi perfect solution, 30 years using internet, unix system, networking and server appliance i never see nothing growing fast and stable like hass :partying_face:

1 Like

This thread might help to achieve your goal :grinning:

thanks. however, that’s for Deconz, and I should maybe have added Id like to use the Hue bridge.
btw, I did give your suggestion a go, but couldn’t get a single Philips Hue White and Color Ambiance E27 light to be found by the photon integration…

Is there a reason 2021.1 is not showing up correctly on my HassOS? I did the update and this is what I have in the supervisor now. Also I heard OS 5.10 is out but have not been notified of upgrade.

Try a Ctrl + F5 browser refresh. If that does not change things…

You started the update, but it looks like it did not complete and was rolled back to 2020.12.7

Reload the supervisor (bottom left of the supervisor card) and see if the newest version updates.</>

EdIt: Actually looking at my supervisor card I see 2020.12.7 as the newest version too, despite having an alert for 2021.1 on my supervisor dashboard.

What does your config / info menu show?

Your update probably did work and there is something amiss in the supervisor display.

The latest version of supervisor is 2020.12.7. The latest version of core is 2021.1.0.



Any chance we could get the conference videos viewable on PeerTube?

Specifically, conf.tube seems like it would be an instance that would be perfect for this, with unlimited quota for videos of conferences from open source projects. You can even set it up to automatically mirror from your YouTube account, so just 15 minutes of setup takes care of the whole thing.

Heck, I’d be happy to set it up myself with permission from the HA team to republish the videos on your behalf.

Doh! :man_facepalming:

1 Like

What’s in the log?

Did you reset the bulbs before trying to pair them? I have no problems with the E27 Color and White feom Philips.

I have added

    pyatv: debug
    apple_tv: debug

to the conf but no details regarding apple tv :-/

Right, the error means that Home Assistant failed to connect to the device. First, did you try to reboot the Apple TV? Helps sometimes. Also, do you have any kind of special set up with VLANs and MDNS repeaters?

Just tried a reboot, but no luck.
No special setup, no vlan, same subnet.

Condolences to @Villhellm … Thank you for the GoFundMe link as well.

An alternative would be to setup Hyperion (either running as a Rpi image with Hyperbian or in Docker). It can control Hue lights and can add a hell of a lot of effects (effect_list: Atomic swirl, Blue mood blobs, Breath, Candle, Christmas, Cinema brighten lights, Cinema dim lights, Cold mood blobs, Collision, Color traces, Double swirl, Fire, Flags Germany/Sweden, Full color mood blobs, Green mood blobs, Knight rider, Led Test, Light clock, Lights, Notify blue, Pac-Man, Plasma, Police Lights Single, Police Lights Solid, Rainbow mood, Rainbow swirl, Rainbow swirl fast, Random, Red mood blobs, Sea waves, Snake, Sparks, Strobe red, Strobe white, System Shutdown, Trails, Trails color, Warm mood blobs, Waves with Color, X-Mas)

You can also define your effects, based on the templates above and they’re loaded into HA.

I have one instance running on Rpi2 connected to a digital led strip (for a Hue Sync Box clone) and another on Docker controlling a set of Hues that can either function independently or act as a receiver for the Rpi2 instance.

For those missing the AVRI integration go to the Afvalbeheer integration in HACS as that one has support for the new platform AVRI is using.

@Petrica, @M1ke and others:

Suddenly managed to do it, HUE lights flashing in color! One needs to first turn_on the light, and then this can be entered in the service_call

flash: long
entity_id: light.kayon
color_name: red

explained a bit more here, so won’t cross poster any further:

some scripts:

    alias: Flash lights in color
    mode: restart
    icon: mdi:alarm-light
      - service: light.turn_on
          entity_id: light.flash_lights
          color_name: >
      - repeat:
            service: script.lights_flash_on_color
            condition: state
            entity_id: input_boolean.flash_color
            state: 'off'

    mode: restart
      - service: light.turn_on
          entity_id: light.flash_lights
          color_name: >
          flash: long
      - delay:
          seconds: 15 # is the time a regular flash cycle takes, 1 flash per second

    alias: Stop Flash lights in color
    mode: restart
    icon: mdi:alarm-light-outline
      - service: script.turn_off
        entity_id: script.lights_flash_color, script.lights_flash_on_color
      - service: light.turn_on
          entity_id: light.flash_lights
          profile: relax # reset lights to a non alarmed color, for next turn_on ;-)
      - service: light.turn_off
        entity_id: light.flash_lights

and a few inputs:

    name: Flash color

    icon: mdi:palette
    name: Select flash color
      - Red
      - Green
      - Blue
      - Yellow
      - Purple
      - Orange
      - White

light.flash_lights is a light group of selected lights being able to be set in colors.
make into this Lovelace bare setup:

  - type: entities
    title: Flash color
      - entity: input_boolean.flash_color
        secondary_info: last-changed
      - input_select.select_color
      - entity: script.lights_flash_color
        name: Flash lights in color
        action_name: Flash
      - entity: script.lights_flash_off_color
        name: Stop Flash lights in color
        action_name: Stop

and some fiddling in the customizations:

        icon_color: >
          return state.toLowerCase();

      templates: &flash
        icon: >
          if (state == 'on') return 'mdi:alarm-light';
          return 'mdi:alarm-light-outline';
        icon_color: >
          if (state == 'on') return entities['input_select.select_flash_color'].state.toLowerCase();
          return 'steelblue';

      templates: *flash

simply keeps flashing away :slight_smile: yeah.

1 Like

Hi all ! Happy new year !

First time I cannot update Home assistant on RPI3b+

21-01-08 08:49:04 ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:2021.1.0 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2021.1.0&fromImage=homeassistant%2Fraspberrypi3-homeassistant: Internal Server Error (“Get “https://registry-1.docker.io/v2/”: dial tcp: lookup registry-1.docker.io: no such host”).

I tried to reload then restart supervisor. I also tried to reboot HA OS 5.9 but no luck.

Any idea to fix this?

I’m not sure. But there were known bugs of OS 5.8 and may be 5.9.
Maybe these bugs are related to your problem.

As am I. This might might shine some light on it? Is it nothing? Has anyone tried it?