2021.10.0: Z-Wave S2 support, Tuya, secure ESPHome and 400 new icons

Thanks. The update only changed the entity id of my HS220. Changing them back works!

Try this:

1 Like

The HACS custom Tesla integration works like a charm for me.

Well… for me, my Tuya zigbee radiator thermostats are detected as a single device and entity. Which results in the current temperature giving me one single reading, and then it… dies. It’s been stuck at the same exact temp since switching to the new Tuya. Before, they had several entities each.
The weirdest part is that even on the smartlife phone app, the thermostats are now locked to that temperature.
I can still adjust the temperature, the thermostat actually gets my setting, it’s just worthless since it assumes it’s exactly the same ambient temp all the time.

I know the feeling mines almost looking like duddly do right evil villian.

2 Likes

Tell her it’s a new “pirate” addon :rofl:

1 Like

I started the Z-Wave migration tool with no problem. However, when the Z-Wave JS add-on install started it asked for three S2 keys. I can’t find any documentation on how each is used and more importantly how to generate them. Can someone point me in the right direction.

The ZWave-JS migration doesn’t work for me. I have two Remotec ZRC-90s and three NEO Coolcam PIR sensors, both devices are listed in the compatibility page but the migration basically lists all entities from all devices and says it can’t do them. Not sure where to go from here, the migration tells me that manual adjustments will be needed but doesn’t say what needs to be done.

2 Likes

After updating to 2021.10.0 (core-2021.10.2) lost connection to my 3 Remote Home-Assistant installations. Restarted servers, rebooted, etc, yet no connection from my “master” installation to the remotes. Restored to core-2021.9.7 and all is good again. Any ideas?

Well, I tried to follow the assistant but got stuck at the first step, install zwave-js. I’m running core and I found no specific procedure to install it. I spent a few hours trying with no luck. So I’ll stay with my old zwave setup for now.

goodluck! my wifi/router had a Dns error on their end and homeassistant locked me out for days upon days without easily being able to be back in the webgui.

took my unit home and plugged into home wifi router , worked instantly.

took it back to work, still nothing for days, none of my local devices (60+) that rely on homeassistant worked even though i have a local router setup for all the devices, my rpi4s dependency on a broken dns via att, broke my whole damn thing.

kicking this entire thing closer to the curb everyday the past 3 years… long ass walk.

was there a conclusion on how to fix tuya? 4/5 different intergrations, 45+ tuya reliant things and no longer homeassistant capable? thats the jist of it? uninstalled tuya v2, tuya local, any HACS version of tuya, and after like 3 reboots…

restoring a backup was the only solution. F this!
haha no wonder people hate this thing.

That is not an official integration.

Subscribe to the open gitHub Issue?

I really don’t understand why people run core… so limited. Anyway, you would need to install the ZWave JS server in a Docker container (I think), since that would normally be installed as a HA add-on, which is essentially a Docker container along side HA anyway.

Perfect! :laughing:

Although I doubt that she will ever notice her new outfit on her HA Companion page :upside_down_face:

Nobody’s forcing you.

I run just core because I don’t want a locked down managed system where I can’t install other software outside the addons.

You need to install zwavejs2mqtt for zwavejs to work in core/container. It can be installed in a docker container, and Instructions are here

https://zwave-js.github.io/zwavejs2mqtt/#/getting-started/quick-start

1 Like

That’s where a Supervised install on top of Debian is even better. You can run other software in the background plus have add-on’s.

1 Like

Anyone having issues with Climate entities in Tuya v2? I am getting the following:

The device appears but not the corresponding entity.

Yup, another one here:

I can’t remember exactly what it looked like before, but I’m pretty sure it wasn’t an empty circle! Works ok otherwise though, so just a UI bug I think.