2021.10.0: Z-Wave S2 support, Tuya, secure ESPHome and 400 new icons

Have you cleared your browser cache?

That is already fixed in 2021.10.3: https://github.com/home-assistant/frontend/issues/10202

1 Like

Thanks, fix confirmed :+1:

Just say you decided to run some pirated software. Not sure HOW you pirate free software though… :thinking:

That is a matter of opinion. I have chosen to run HA in Docker with s separate Docker container for official zwavejs2mqtt. That avoids the complexity if an HA addon based off of the official released code from the developer. With MQTT turned off, the xwavejs integration workd fine with zwaveje2mqtt WS server.

1 Like

@sparkydave @mwav3 You don’t even need supervised or core anymore to get around a ‘locked down’ system. The community terminal and SSH addon give you full control over HassOS. I still run supervised but everything that I need to do in supervised can now be done using that community addon. I’ve just been too lazy to switch to HassOS.

1 Like

I think the fact there are so many install options that can be debated is one of the biggest advantages Home Assistant has. This gives the user lots of choice and flexibility. There are ups and downs to any of them though, which already have many threads in the forum. I wrote about the reason I went with the container install here The benefits of docker / core / rasp - #4 by mwav3

Sometimes though we get in our “camp” about which install option is better and I see a post saying “why would anyone do it this way?”. I’m sure the original poster has their reasons for a core install, and I wanted to give them the instructions to get zwave working with it.


I have exactly the same issue. Did you find a workaround? I can only assume that it’s something to do with my IP being in Australia and the data center in China. Unfortunately there is no Australian data center and the app defaulted to china when setting up.

I’m running on a Pi 3B, so I try to limit any overhead. Also I always was able to install any extra software (node-red, bluetooth monitor, esp home, idrive backup, etc.) by myself. I see ZWavejs2Mqtt has a full documentation where zwave-js-server has a very partial one. So I’ll probably try the first option.


Hi guys.

(Now hopefully in the right thread :roll_eyes:)

With this update the systemmonitor sensors (homeassistant/components/systemmonitor/sensor.py) where updated and with that change at least the load monitors (load_1m, load_5m and load_15m) stopped getting sent over to InfluxDB.
Additionally the long term statistics for these sensors also stopped working (ex: "[homeassistant.components.sensor.recorder] The unit of sensor.load_1m (None) does not match the unit of already compiled statistics ( ). Generation of long term statistics will be suppressed unless the unit changes back to " ).
Other sensors from the same module such as the memory_use_percent appear to be fine though.
My best guess is that changing the units from " " to “None” breaks the InfluxDB integration.

This behaviour was triggered right with the first update (2021.10.0) and persists through at least 2021.10.3.

So I’m not really sure where I should report this exactly, can someone give me a pointer, please?


1 Like

I had to “Delete” my app account (which was setup in China) and create a new app account in the correct region. It took a while, but it now kinda works (the new integration doesn’t inspire confidence).

1 Like

Thanks for that. Doesn’t really give us much of an option in Australia. Think I might just look at at dumping the tuya products. Everything else (shelly, hue, lifx) has been seamless.

The former tuya integration worked good… It might be rash to dump it until we give them a chance to fix stuff…

Getting the following error trying to connected the integration.
Have rebooted multiple times.
Tried new clean install of HA with no other integrations and same result.
I did also set my region in the Tuya IOT platform account settings (Account Information > Basic Information > Country/Region > “United States of America”)

Tuya login error response: {‘code’: 2007, ‘msg’: ‘your ip(###.###.###.###) cross-region access is not allowed’, ‘success’: False, ‘t’: 1633965641198}

Also, on the website, under linked tuya app account, it shows 31 devices, but on the all devices tab, it doesnt list anything.

Edit: I created a completely new account on the tuya app and added a device to it. This time it sees the device on the all devices tab in the cloud project, but still gives me the exact same error:
Tuya login error response: {‘code’: 2007, ‘msg’: ‘your ip(###.###.###.###) cross-region access is not allowed’, ‘success’: False, ‘t’: 1633965641198}

I’m getting a login error with the new integration. Has anyone else encountered error 1109? I’ve confirmed there are no strange characters in the keys or passwords.

Any direction would be appreciated.

I fixed this for myself.
I had to create an entirely new app account and IOT account using new email address’s.
I now have to set everything up again 100%.
Home assistant of course see’s everything as new devices. Automations dont work and will need set up again. My dashboards are f**ked.

And it seems the free IOT account is a 1 year trial.
And is limited to 50 devices.
After that its $3300 a year. WTF

This is a miserable experience. Yet again.
Never will i ever buy Tuya again. $3300 a year? wha???

So I bit the bullet and upgraded to 2021.10.3 from 2021.9.7
I had the old HA official tuya integration installed and working in addition to the HACS Tuya v2 integration. They worked together albeit with different Entity names.
So prior to upgrading I deleted the old HA integration as per instructions but left the HACS Tuya v2 integration in place and then upgraded.

Upgrade went fine apart from a complaint in the log about removing tplink from configuration yaml. ( I have Tplink devices as well)

The HACS version of Tuya v2 is working great without me doing anything - all scripts and automations are working fine as are all my dashboards.
I think I will stick with this until i hear that the new Official HA integration is working properly.
So to summarise al lot of heartache and deliberation for nothing. Frenck was correct, they do live together as long as you only configure one.
Thanks to the users on Reddit and some contributors here for stating this amongst all the noise around the poorly implemented HA Tuya integration.

Mustered the courage to upgrade in order to answer my own question - not really liking the answer :frowning:

I have two ‘old’ dimmer switches on the old firmware version and two new ones - see the four SW2 items:

The two old dimmers show up in home assistant but I cannot change the brightness from there any more; I need to go into the Smart Life app do do that. Not good!
The two new dimmers show up in the device list at https://iot.tuya.com/ but NOT in home assistant, so I cannot even switch them on and off from home assistant any more. Even worse!

Guess I’ll add myself to the group that is disappointed that an integration with inferior functionality has been pushed to replace the old version - would be great to at least be given a choice.

dimmers hsould be fixed in next release

Sounds good, thanks!