2021.10.0: Z-Wave S2 support, Tuya, secure ESPHome and 400 new icons

I read somewhere that you can renew it in the zero cost tier.

I have a Tuya webcam. Before the new updates, the old integration, discovered two scenes (one to activate the cam and one for turning it off) but now I can’t find them… any help? This new Tuya integration is full of headhace…

Thanks for the great work, lads! After upgrading, my ID-Locks stopped responding and is close to impossible to pair again. I sort of get them, but the 2 entities (of many) that I get up does not work. Are there any changes with S0 in version .10?

if that can help someone, I went with Zwavejs2mqtt (disabling the mqtt gateway and activating the ws server).
For now I’m using the snap package (it was easier to quickly deploy and test). I may use the packaged version later.
There is a small issue with the snap package on Pi (sudo does not work, but there is an easy fix https://github.com/zwave-js/zwavejs2mqtt/discussions/1216#discussioncomment-759534)

The old Tuya plugin stopped working for many people all of a sudden. The reason is, that Tuya is switching off their servers that provided the old API. Tuya wants everyone to move to Tuya 2.0. However, that API is not fully compatible with the old one, meaning you lose functionality when doing that. On top of that, i discovered that the new Tuya plugin is not quite finished yet. I went through the trouble of setting it up and getting my keys from the Tuya dev-suite (the fact that i have to use their dev-suite already shows how unfinished this is), only to find out that many of my lightbulbs reported wrong colors and could not be controlled any more. I have 20. The old plugin was already useless, so i had to find another solution. I found it in the form of Tuya_custom. You can install it through HACS, a portal to Github that you can install in Home Assistent. Once installed, you can use thousands of Github-projects in Home Assistant. In there you can also find Tuya_local, but this is still in a very early Alpha-stage and not yet usable. Tuya Custom works fine though, although my RGBCW-lights lost their RGB-function and are now only able to do white to warm white. This is because Tuya custom uses the new Tuya 2.0 API, which is not fully compatible. Sadly, there is no other choice available. Hope you are now somewhat more informed.

I have a Tuya dimmer. Works fine in Tuya Custom, that also uses the new Tuya 2.0 API. I can recommend it. At this moment, it’s way better that the official new Tuya plugin. You can find Tuya Custom in HACS.

Correct, this is exactly my experience. The new Tuya plugin, the official one, is far from finished. I also stick to the Tuya Custom plugin for now.

I don’t see a tuya_custom only a ha_tuya_custom on GitHub:
https://github.com/ollo69/ha_tuya_custom: Tuya Custom Component for testing (github.com)

But it does not support setup thtough HACS any more.
When trying to add the URL as a custom repository the error message says “Repository is archived.”

This is not fixed, It started with empty icon and fixed wrongly with mdi: shield-off
It needed to be mdi:shield-check
roll it back a few versions and you’ll see.

This is not fixed, the actual icon has a tick not a line across. mdi:shield-check is what is needed.
Roll it back a few versions and you’ll see

There is no evidence of this.

Plenty of us have have the old Tuya 2021.9.7 working correctly using the custom HACS install on HA 2021.10 By all accounts Tuya advised that this legacy API would be unsupported at the end of the year, not this month.

It seems the Home Assistant team has made the decision to remove the original Tuya integration prematurely as they don’t want a last minute rush at the end of the year. This has had the effect of breaking many users existing setups with no official support for Tuya Covers in 2021.10

I think this was a bad call.

As are you too, after reading my reply.

If you just want to get Tuya working again right now and are happy to upgrade to the new Tuya when its more functional you can simply load the Tuya 2021.9.7 integration using HACS and everything will function as it used to before the Tuya V2 release.

The repository is here: https://github.com/andrey-yantsen/home-assistant-tuya-old

Just keep in mind that eventually when the old API is turned off (rumored to be the end of this year) this will stop working. But by then hopefully the Home Assistant version is fully featured and supports all the devices that are currently broken in the 2021.10 release.

1 Like

Anyone get encryption between ESPHome and HomeAssistant working? The ‘documentation’ leaves a lot to be desired for this. (as in, there is none)

Add the encryption key option to your device config and upload it:

You should then receive a notification in Home Assistant to add the key.

I haven’t actually tried this yet. I’d suggest you try one that you have easy access to first. Just in case it goes wrong and you have to serially flash the device to remove the key.

1 Like

This works for me with my MQTT sensors…

  - platform: mqtt
    name: "Grid - Total Energy"
    value_template: "{{ value|float / 1000 }}"
    unit_of_measurement: 'kWh'
    expire_after: 86400
    device_class: energy
    state_class: "total_increasing"
    qos: 1
    state_topic: "shellies/shellyem-C45BBE6B51F3/emeter/0/total"

I did try that, didn’t know about that part where HomeAssistant will prompt for the key though. I’ve been looking through the interface trying to find where I should go ahead and tell it in advance.

Cant get that far though,- when trying to flash ESPHome:

  password: !secret apipass
  encryption: NpQb/dsRHrgt8ZcarUl1jkSF2E4UP0alwiq6v8YtF7M=

**Failed config**

**api:** [source includes/standardConf.yaml:21]
  password: !secret apipass

  **expected a dictionary.**

  encryption: **NpQb/dsRHrgt8ZcarUl1jkSF2E4UP0alwiq6v8YtF7M=** [source includes/standardConf.yaml:22]

enc key is randomly generated so I see no issue just leaving it in the paste above, obviously I won’t use the same key!

I think this is actually by design and they’ve changed the icon used for “alarm disabled” across the board. The recent fix has aligned this with the other icons used in the UI:

FWIW, I think the new icon is better. The old one was ambiguous - does green with a tick mean “safely armed” or “safely disarmed”? The new one clearly shows “safely disarmed” so, for me at least, this is a positive change.

1 Like

I am trying to remove the existing Tuya integration to install the new one, but nothing happens adter I press the delete button and I am getting the following error in the log:

ImportError: cannot import name 'AuthType' from 'tuya_iot' (/usr/local/lib/python3.9/site-packages/tuya_iot/__init__.py)

The problem is I can’t install the new Tuya integration without removing the old integration. Is there any workaround for deleting it?

Not like this:

Like this:

  password: !secret apipass
    key: NpQb/dsRHrgt8ZcarUl1jkSF2E4UP0alwiq6v8YtF7M=

Or better still:

  password: !secret apipass
    key: !secret api_encryption_key

I have now tried it. Worked flawlessly. I got a reconfigure persistent notification right away.

Same here, began the migration and it tells me none of my devices will be migrated (listing all of them in the ones that won’t be migrated…)

The screenshot shows only a subset of the entities, if I have to set it all up from scratch I don’t see the point of migrating to nothing…