2021.12: New configuration menu, the button entity, and gorgeous area cards!

yes the same problem. i hope in next release this problem will be solved

Fix for hue (and more stuff) is available. Solved my issues with Philips Hue.

2021.12.3

2 Likes

since this integration (button) has to generate events, then yes, you can intercept any message in NodeRed. But you don’t need button integration for that.
If there will be dedicated node for that - this is the question to an node-red-contrib-home-assistant-websocket package author

I personally would not bother as from what I gather the .3 update fixes all the Hue issues and should be released today some time.

EDIT: It has just been released in fact.

Do you know if also the miio integration issues are solved?

Please read the changes listed in the release notes

1 Like

Not isolated to 2021.12 releases. I experience similar issues on 2021.10.7. The problems started a couple days ago. Try reloading the integration and that may bring them in sync for a while.

I don’t see any reference to hue in 2021.12.3 change log may you confirm that they really fixed something ?

read it again Release 2021.12.3 · home-assistant/core · GitHub and dont forget about dependencies :wink:

1 Like

It’s in there, aiohue was updated. It’s the dependency that home assistant uses to control hue.

1 Like

in 2021.12.3 there is a solution for miio?

For future reference, you can check what is included in the 2021.12.3 patch release by looking at it in GitHub. I don’t see anything related to the xiaomi_miio integration.

You can also see all the open Issues related to xiaomi_miio here

1 Like

You came here to complain, not to get help or to debug. You offer no logs, you refer to no issue you have placed on github.

Reverting will help only you, it won’t help fix anything.

As for tuya, getting their devs involved in ha development seems to have been a disaster. Their promised local control was, frankly, bullshit. Frenk seems to have spent a lot of time fixing their efforts, but you still have to live by their cloud, and of course die by the cloud.

4 Likes

Yep. You’re quite right. Well done. Have a lollipop.

I want to say thank you Marcel van der Veldt for all efforts done to solve hue integration with 2021.12.3
Impressive how fast this was available.
Also thank you to move to the next gen api of Hue already.
This is more faster, more accurate and now we can also play with motion sensor On/Off.
We loose (thanks to philips) some features like flash,colorloop,dark, daylight but that’s life :slight_smile:

My action during 2021.12.2 was to rollback to 2021.12.1.
Today, I’m on 2021.12.3 and everything is working well. With 30 devices on hue, it’s control nearly all the lights, so it’s more impacting in winter.

One point was my experience with backup, I loose all the statistic past data related to energy + all entities with statistic. I don’t find till now any explanation or tools to look into DB.
I was thinking only loosing one day. That somethings that I need to understand because it’s starting to be crucial in case of disk outage to retrieve stats data in case of partial backup.

3 Likes

Hello everyone, I upgraded the 2021.12.3 release and I no longer see the positioning and tracking of the car on the MAP CARD until yesterday it worked perfectly. Could you tell me what has been changed?

I would like to 2nd that, absolutely superb work, thank you so much @marcelveldt your a gent :+1:t2:

1 Like

You’re absolutely right, shame on me for not reading through. Thank you for the shove I needed… :+1:t2:

I just updated both Core and OS (which forced an update to the Zwave JS to MQTT Add-on also), and things went smoothly. I have two minor issues that I found if anyone has seen before or has any insight into. The first is a few new warnings in the log for several luminance sensors like the following:

2021-12-17 13:20:10 WARNING (Recorder) [homeassistant.components.sensor.recorder] 
The unit of sensor.fibaro_eye_office_luminance (lx) does not match the unit of 
already compiled statistics (Lux). Generation of long term statistics will be 
suppressed unless the unit changes back to Lux

The second issue is that one of my entities is now showing up as Restored and unavailable on a powered Ecolink Chime device. It is used in my UI and worked previously. I’ve re-interviewed, healed, refreshed values, on the Device in zwavejs2mqtt CP multiple times and it never becomes available.

If anybody has any insight on either of these, I would appreciate the help. Cheers!

1 Like