2021.7: A new entity, trigger IDs and script debugging

Looks like TRIGGER_BASE_SCHEMA might have been renamed to DEVICE_TRIGGER_BASE_SCHEMA. I have a similar issue with my Vivint integration.


1 Like

I am having major issues with my Zigby controller after upgrading. Have tried several times, reverting to my snapshot each time with the same errors.

Couldn't start deCONZ = dresden elektronik deCONZ protocol: ConBee I/II, RaspBee I/II coordinator
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/asyncio/tasks.py", line 492, in wait_for

The full error looks like this:

Logger: homeassistant.components.zha.core.gateway
Source: components/zha/core/gateway.py:152
Integration: Zigbee Home Automation (documentation, issues)
First occurred: 5:34:21 PM (1 occurrences)
Last logged: 5:34:21 PM

Couldn't start deCONZ = dresden elektronik deCONZ protocol: ConBee I/II, RaspBee I/II coordinator
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/asyncio/tasks.py", line 492, in wait_for

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py", line 152, in async_initialize
    self.application_controller = await app_controller_cls.new(
  File "/usr/local/lib/python3.9/site-packages/zigpy/application.py", line 74, in new
    await app.startup(auto_form)
  File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/zigbee/application.py", line 93, in startup
    coordinator = await DeconzDevice.new(
  File "/usr/local/lib/python3.9/site-packages/zigpy_deconz/zigbee/application.py", line 435, in new
    await dev._initialize()
  File "/usr/local/lib/python3.9/site-packages/zigpy/util.py", line 110, in retry
    r = await func()
  File "/usr/local/lib/python3.9/site-packages/zigpy/device.py", line 178, in _initialize
    await self.get_node_descriptor()
  File "/usr/local/lib/python3.9/site-packages/zigpy/device.py", line 137, in get_node_descriptor
    status, _, node_desc = await self.zdo.Node_Desc_req(
  File "/usr/local/lib/python3.9/site-packages/zigpy/util.py", line 110, in retry
    r = await func()
  File "/usr/local/lib/python3.9/site-packages/zigpy/device.py", line 300, in request
    result = await asyncio.wait_for(req.result, timeout)
  File "/usr/local/lib/python3.9/asyncio/tasks.py", line 494, in wait_for
    raise exceptions.TimeoutError() from exc

Looks like the controller will not load at all. Anyone else seeing this?

Hi @frenck, I upgraded from 2021.06.6 to 2021.07.01 this morning and since then InfluxDB standard configuration causes the “Configuration validation” button to fail (the spinner goes on forever). If I comment out my influxdb config, the config validation completes successfully.

If I try the “Restart Core” button in the System Tab, I get this error;

numpy.ndarray size changed, may indicate binary incompatibility. Expected 88 from C header, got 80 from PyObject

Suffice to say, the InfluxDB integration has stopped working. This is my config;

  host: a0d7b954-influxdb
  port: 8086
  database: homeassistant
  username: homeassistant
  password: !secret influxdb_password
  max_retries: 3
  default_measurement: state

If I comment out my influxdb: section in my configuration.yaml, restarts work fine, and the configuration validator works fine.

This is very weird - any ideas?


Please dont tag people (unless you were having a discussion way back in the history of the topic). See point 16 here.

Hi tom, sorry - I assumed that since Frenck posted the topic, and wrote the influxDB add-on it was within the guidelines.

I’m also having this issue.

Same issue here. My password has a ‘@’ and after replacing this was solved. Of course this is not the ‘@’ before the servername.

I think it’s in their best interest to do what the community would want, otherwise the project would die. I’m also pretty sure the number of votes isn’t the_only_ criterion they consider. Complexity, time to develop, etc. could mean that some other popular but not necessarily top idea gets developed first. Then there’s the question of bias: On the Internet, it’s easy to make a big noise if you try hard enough — doesn’t necessarily make it important. Add to this the fact that the project also has a general direction it’s taking and that people tend to overestimate their own ideas. There’s a saying that goes: “Users don’t know what they want, but they know what their problems are.” Among all of this it’s not trivial to decide which features to develop.

I see there seem to be a lot of automation developments over the past months and I imagine more are to come in the future. I’ve used node red for my automations (only because I wanted to teach myself node red) but I’m wondering whether I should continue with it or move over to HA’s native automation mechanism. Would any of the key developers offer any advice on this? Thanks

Thanks for the update.
I’m not sure if it’s a wrong configuration from or a bug.
I have multiple modbus configurations in different files / packages. Everything configured as mentioned in the docs. Before the update it worked afterwards it seems like they overwrite each other. The one that was included last counts the other ones are not recognized.
Same situation for knx works like expected.

1 Like

So these errors does have an impact none of my Smart Plugs reports current Power back.

Conbee II

No changes has been made on Device or Gateway.

Any help would be appreciated.

I am seeing the same issue with my ZHA integration. My post with screen shot is above… if anyone has any ideas that would be great.

also having problems with ZHA after upgrade to 2021.7.1. I hope that this PR will be included in next release and fixes the issue.

For the moment I downgraded to 2021.6.6 again

should be fixed in 2021.7.2 when released. Bump deCONZ dependency to properly handle current and voltage not being reported on some zhapower endpoints by Kane610 · Pull Request #52764 · home-assistant/core (github.com)

1 Like

Suggestion on best route to do that with a Pi set up?

Doing what? downgrading?

Correct. I’ve never had to do that before didn’t know if you had a good resource off the top of your head since you just did it. If not I’ll explore.


It’s really easy. Go to your supervisor then snapshots. Select a snapshot from previous 2021.6.x version and click on restore