2021.7: A new entity, trigger IDs and script debugging

When you set up Spotify through the UI, it takes you to the Spotify login page so that you can authorize HA to use your account like a media player.

So once it’s set up, anytime you’re playing a song through Spotify, you’ll be able to see that info in HA.


Me too ;/ sms is down

Logger: homeassistant.components.sms.gateway
Source: components/sms/gateway.py:167
Integration: SMS notifications via GSM-modem (documentation, issues)
First occurred: 8:21:23 (1 occurrences)
Last logged: 8:21:23

Failed to initialize, error ERR_NOTSUPPORTED
Logger: homeassistant.components.sms.notify
Source: components/sms/notify.py:24
Integration: SMS notifications via GSM-modem (documentation, issues)
First occurred: 8:21:23 (4 occurrences)
Last logged: 8:21:23

SMS gateway not found, cannot initialize service
Logger: homeassistant.components.notify
Source: components/notify/__init__.py:311
Integration: Powiadomienia (documentation, issues)
First occurred: 8:21:24 (4 occurrences)
Last logged: 8:21:24

Failed to initialize notification service sms
1 Like

It is covered in the documentation. This blurb pulled from the Spotify integration page covers the functionality:

Not at all. This is the correct terminology, the context is different. It even eludes to that in the PR. Companies provide services, this is a service that is provided by spotify. This was opened up recently that allows for automatic discovery.

For future reference, if a PR is referencing a home assistant service, the yaml will be present in the PR along with a description of the service and a link to the documentation changes. This PR had no documentation changes because discovery was already possible, the bar for discovery was just lowered.


Ah! Thanks, that finally clears things up.
I still don’t agree with the use of “service” as it generates confusion between spotify service as a company and HA service and HA Service call, and the confusion created proves quite well my point I guess

OK, but again this takes previous experience with this documentation method and practices, which in my view makes it a bad approach for newcomers like me.

That’s actually very kind of you, as I’m sure others will do too, and even I can someday do the same.
That said, it does NOT relieve the developers from their duty to properly document things so that users can start using it correctly right away, instead of having to spend countless hours trying to figure out what the code does and how to use it.

Thank you for the clarification, and I don’t take offence at all, no worries.
If that’s the rule here, then fine, I’ll have to obey it, but this is the first forum where I see that rule, and honestly I don’t get it.

I run a forum myself as both admin and mod, and if someone reading a thread knows that someone else not involved has a solution or can contribute to it in a positive way we see no harm in referencing him so that he knows he can contribute if he wants to. Just a different way of seeing things I guess.

I do appreciate that being the HA original author/creator he does get hundreds of notifications and If I knew that he had that role I would not have mentioned him for sure, he sure has a lot on his plate already, but as I’ve mentioned earlier, I was unware of that.

Now, enough side talk if you don’t mind, getting back to what matters:

Did you have 2021.7.2 installed before upgrading to 2021.7.3?
I’m asking because I had it installed just one or two days before, and the discovery of Spotify was one of the things I noticed after 2021.7.2 so this is definitely not new to 2021.7.3.

Either someone did a commit/merge into the main branch sooner than intended, or forgot to mention the feature on 2021.7.2, but it was already there, it is NOT new to 2021.7.3.

Yup, but that was introduced in 2021.7.2.
So when I saw the 2021.7.3 release note I would never guessed it was describing something already applied in 2021.7.2.

OK, all is clear now, one way or the other, case closed for me.
Thank you all for your answers that clarified things for me.

Have a nice weekend all.

You’ll be happy to know that part of the pull request approval process is documentation. This one required no update to the documents.

It is mentioned in this thread point #16 in the first post.

1 Like

Yeah, thanks, I really don’t get all the negativity and assumptions on the bad side in there.

“bad manners, you’re demanding somebody answers you”
“nobody has to help you”

I truly can’t understand how asking for help can be taken as something disrespectful or demanding for an answer, but I digress. Rules are rules, and if we want to be in, we have to obey them, even if we don’t agree or like them.


As someone who gets DMs and @ pings all the time I can tell you it is very annoying.

There’s no need for it.

1 Like

We are dealing here with a wide variety of cultural differences & cultural norms. We all try to get along together in the most respectful way possible.

1 Like

And there i was thinking i was just being friendly

1 Like

The tagging rule is in place because a few bad seeds decided to harass volunteer developers to the point that the developers quit or reached out to moderators.

1 Like

I keep telling you, the pictures were very tasteful but I’m just not interested.


I recently installed 2021.7.3 and noticed that the ZHA Visualization view no longer shows a device map, it’s blank for me. I downgraded to 2021.7.2 and the Visualization view works properly, displaying the device mapping. I upgraded/downgraded between the two versions a few more times, and it showed the same behavior, no map on 7.3, and working map on 7.2. I see there was an upgrade to the ZHA integration in 7.3, and I’m wondering if anyone else is seeing this issue.


In the frontend the climate unit displays the double message when off.
Schermata 2021-07-18 alle 13.52.54

It’s showing the preset mode. This is normal behavior.

I have the same error too.

Same here. Can’t get my TV to switch sources anymore as it cant see the devices. Have you found a workaround yet?

Hi. Should I be seeing any new features on the Sony Bravia Integration, Ive removed and re-added ?

If I am watching something on Youtube or BBC1 it just says playing. I was expecting it to say BBC1 or Youtube rather than just playing.

Also, does anyone have any example commands to use the remote feature please ?

Thanks in advance

Hello, Did You found a solution for “[homeassistant.components.sms.gateway] Failed to initialize, error ERR_NOTSUPPORTED” ? For now, I just roll back snapshot. Do You use home assistant os or Raspberry PI OS ? After 2021.7 I had Try to Switch to Home Assistant OS but on I’t i even have issue with switching modem AT so for me only working solution is Raspberry Pi OS and I’m installing docker on IT. Hope I’t will be fixed soon.

You don’t have to remove and add. You’ll have a new remote entity.

Yes, this is how all media_players behave. There may be an attribute that says what it’s playing, however it will not be in the main state.

There’s plenty of examples on the forums. Just search remote.send_command.

Here’s an example.

service: remote.send_command
  entity_id: remote.tv_room
    - VolumeUp
    - VolumeDown
  delay_secs: 0.6
1 Like