2021.8.0: Feel the energy ⚡️

No I am not using the default theme, I am using a modified theme based on “darkmix”. Do you know if there is a way of specifying the colour of the grid lines for all of the pop up history graphs? darkmix|690x391

Check the custom integration, that one works for me: GitHub - alandtse/tesla: Tesla custom integration for Home Assistant. This uses an oauth login proxy which was rejected from core.

1 Like

Perhaps best to find a thread for that theme or log an issue for that maintainer.

I’ve done some theme tweaking but I don’t know which variable that would be. You can dig for it using the developer tools in your browser.

1 Like

I figured out how to include the sensors in the energy dashboard entities list: they have to have 4 attributes which you can customize in your configuration.yaml file in the homeasistant: section for any sensor by using customize_glob.

      last_reset: '1970-01-01T00:00:00+00:00'
      device_class: energy
      unit_of_measurement: kWh
      state_class: measurement
      last_reset: '1970-01-01T00:00:00+00:00'
      device_class: energy
      unit_of_measurement: kWh
      state_class: measurement  

These 4 attributes are then added to all sensors named sensor.vebrauch_* and sensor.*_sim and they are then listed in the entities_list. You should also use the integration and utility_meter components to calculate hourly energy consumption.


Thanks to the HA Team for Energy feature! :+1: :muscle:
It would be great to be able to display the percentage of consumption per device of total consumption! And a perecentage stack of consumption on the Energy usage graph. :bar_chart: :slightly_smiling_face:

1 Like

Update went smooth, again! :clap:

Thanks A LOT to all contributing!

Awesome, thanks!

Any idea why I’m seeing this (bar going allt he way down) every day at midnight. I dont have any solar panels or whatever. I’m not returning anything



Hi has anyone managed to get calculated costs or Tarif working.
All looks good for graphs etc and I have set the costs but Tarif is always zero ?

OK, to follow up. I was previously on 2021.8.1, have since upgraded to 2021.8.3 and the phantom solar/export seem to have disappeared.

Just a note, on Raspberry pi 4 running Raspbian, I had to manually download, build, and install Python 3.9 in order for the Home Assistance Configuration check to not give an error when testing the upgrade from 2021.7 to 2021.8.x.

Just in case anyone else runs into it, the error I was getting was :

Fatal error while loading config: [Errno 2] No such file or directory: '/usr/local/lib/python3.9/site-packages/idna-3.2.dist-info/METADATA'

I had tried simply installing idna3.2, not realizing that Rasp Pi is only capable of installing Python3.7 via apt. This site had the steps to install 3.9x onto the pi. https://raspberrytips.com/install-latest-python-raspberry-pi/

After doing that, the Configuration check came back good, then I installed the update, everything looks solid. :+1:

1 Like

Cost Calculations are only performed every hour after the Grid Consumption and Grid Return values are updated.
Also, if you enter the incorrect tariff (as I did) the corrected tariff only applies from that time on. Its a bit frustrating setting this Energy Integration up first time … but when you get it going its pretty neat.

I think your Power Usage Total is set up as a ‘Daily’ … So it resets to zero at midnight. I use a Total kWh ‘All Time’ entity. The way the Energy Integration works is every hour it subtracts from the new value the previous value (an hour ago). In your case 0.1 - 5 is -4.9. (approx reading from your graph)
That ~5kWh value is your entire recorded previous day value.
Hope this makes sense … took me a while to figure it out for myself.

1 Like

Tariff working fine (after a bit of learning)

Sunday is Off-peak for me so Peak costs are $0

1 Like

Same here. Glad to hear it’s not my system. Spent the whole morning installing/reinstalling, and i get a “Aborted, integration is already configured error”. Also on bootup I get a “timeout” error when running Ambiclimate in debug mode.

Ive gort a Rainforest Eagle 200 which ive added as a grid source which is fine but i also want to use the PowerDemand sensor (whole house current) with the statistical card but it wont show that entity
ive tried customising the entity to make it a measurement state entity and changed the class to energy (the same as the other two eagle entitys that do show when selecting an entity witht the statistical card)
ive also included the customisation entity file in configuration.yaml

any ideas ?

Power demand sounds like a measurement of power not energy.

And confirmed by the unit of measurement in that screenshot. :slight_smile:

@ben1410 kW is power (an instantaneous measure of work rate, in Joules per sec). You need something giving you kWh (energy, in Joules, hence the h for hours). One possible solution is here on the thread and lots of other places (if you don’t already have an appropriate sensor): The clue is to integrate.

@ben1410 the energy dashboard will only list items that are in kwh. I just added the cards to my own dashboard, you can only add the yaml for them at the moment though.