2021.8.0: Feel the energy ⚡️

ok ive changed the measurement to Power and it will atleast let me select it now but says no statistics found…
ill keep playing and searching .
my tp link kasa plugs show up as an available option but are in W not kW
thanks for the assit , ill keep searching

yep , adding the statistic card on a seperate dashboard :slight_smile:

The grid lines in the graphs look terrible… ugh.

It is a good thing everything is themeable as well a open source then isn’t it.


I like the needle mode in the guage card, unfortunately it doesn’t show the blue before the green like non-needle mode shows.

1 Like

No changelog for 2021.8.4?


Same happened to me. Tried to create a new password but that didn’t help. Not using 2FA.

Hi there,

Excellent release, really like ne energy stuff!

I wanted to share that there might be a bug in the history graphs in the lovelace ui. Or perhaps it is my installation but I see the issue across all my history graphs.

What I noticie is that, if I click on a label in one of the history graphs, this particular line is removed and the label gets stripe-throughed.
After some seconds however, the line is added to the graph again. This was not the case before. See below the lines that I disabled but re-appear after 2 - 3 seconds…

NO Release Notes about it??

if you need to know whilst waiting for the docs to be updated
. Release 2021.8.4 · home-assistant/core (github.com)

1 Like

Same experience here. This has broken a lot of my automations. No errors are being logged that I can find, but something has for sure changed in 2021.08 that has completely broken this integration. No mention of it in the Breaking Changes section.

Why did I just have to look for this for 30 minutes?! #documentation #sucks

At the bottom of every page:


Has anyone in Australia managed to get Forecast Solar to work?

I get connection errors.

Logger: homeassistant.config_entries
Source: config_entries.py:324
First occurred: 01:00:26 (2 occurrences)
Last logged: 01:05:04

Config entry 'MyNameHere' for forecast_solar integration not ready yet: Error occurred while communicating with Forecast.Solar API; Retrying in background

about device template functions, can’t find documentation but id and attributes can be grabbed from .storage/core.device_registry

{% set dsm = 'afcc53fc26255335f14292f1606d63e6' %}
{{ device_attr(dsm, 'manufacturer') }}
{{ device_attr(dsm, 'model') }}
{{ device_attr(dsm, 'sw_version') }}

{% set hacs = '7e487e8368a90a4161fa4536d3c21374' %}
{{ device_attr(hacs, 'name') }}
{{ device_attr(hacs, 'sw_version') }}

DSM 7.0-41890


without id

{{ device_attr(device_id('sensor.hacs'), 'sw_version') }}


I don’t know if I am experiencing an particular issue or it is some bug related to the 2021.8 upgrades but.

My wifi switches (4 sonoff working only on LAN) stop to work after any reboot.
To get them working again, I have to reset the network device (wifi router) then all appears on dashboard again.
(before the update, no network reset was necessary, they appear online as expected)

as well, my broadlink IR remote (RM4 mini) is conected, is recognized on interations, but none of the commands I programmed seems to work. (no configuration files was modified after the updates)

Can anyone help me how is the best way to solve this issues?

Thanks in advance,


Love the new energy feature :slight_smile:

Had a spare Wemos D1 mini laying around, so ordered a photodiode and got my Home Assistant Glow energy monitor up and running this afternoon. Now fully integrated and counting those 1W pulses from my electricity supply meter.
I used an old Sonoff DW2-WiFi window sensor that was laying around because I have never used it, so it’s case got re-purposed for my Glow monitor.

ESPHome ESP266 configuration file can be found here


I use the zwavejs2mqtt (installed on different machine than Home Assistant). I use the zwave2js integration. I have two Aeotec sirens. They always worked as a switch and presented as a switch.

I do not see anything new. What is this new siren feature? Or is it not yet fully implemented? Or is it only the gen 6 sirens that use the new feature? Mine are gen 5

Not that I miss anything. They work. I am just puzzled.

Much neater than my (work in progress) solution.

1 Like

Strange this is what i see am i missing something

Screen Shot 2021-08-09 at 7.22.08 AM Screen Shot 2021-08-09 at 7.22.23 AM