2021.8.0: Feel the energy ⚡️

Other than the Aeotec siren gen6, are there any zwavejs Sirens already known to work?

I’m liking the new Sidebar view feature.

What´s missing for this energy sensor to be selected in Energy dashboard “Add Grid Consumption”?


This sensor is a template sensor which adds all single devices energy consumption.
I already added state_class and device_class.

Not sure what is still missing according to Sensor Entity | Home Assistant Developer Docs.

You need to include this.

Metered entities#
Metered entities have a value that keeps increasing until reset, like energy consumption or production. To have Home Assistant track this entity, you need to include a last_reset property.


last_reset: ‘1970-01-01T00:00:00+00:00’

to your customize.yaml or to your configuration.yaml template

What sort of template sensor is it? It needs to be the new style, not the old style.

Looks like it does not work for most of Australia. Checked the solar forecast website and saw this.

Then went to the link and found this.

So you are good if you are in Perth or up some of the west coast

Here is the full map so not just Australia missing out possibly.

Does anyone know of any other forecaster that works with the new energy dashboard or is this it for now?

1 Like

Thanks! That worked. Took some time after making these changes to customize.yaml after entity showed up in Energy dashboard.

BUT: now the next issue is with total cost tracking entity. I got one looking like this:

…and this doesn´t show up :frowning: What´s missing here?
Strange: only same entities like for the kWh tracking are listed (all of them are of type kWh).

Maaaaan I´d really love to have a more detailled documentation on this Energy dashboard wizard - what kind of entities are expected at which step? Usually doc is just great for HA… but this time I´m pretty stuck (like others too) :frowning:

A known gap is Australia,

And NZ by the look of it.

I have one from ‘Vision’ (VISION Z-Wave Siren, Smart Home Automation Security System) which has worked for a while now with ZwaveJS (even before the new ‘siren’ component. Previously it simply showed up as a switch.

I’ve noticed with this update that the HomeKit representation of LIFX bulbs has changed. Rather than having a single brightness slider, a slider exists for both RGB and colour temperature.

Was this a planned change? It does make brightness changes by Siri a bit weird compared to through the app. (Lights can go bright on different colours or temperatures to the existing state.)

what do you do specifically with ESP and ESPHome to get around the broken DTE integraiton?

copying in @Danielhiversen for any insights. Much appreciated, and thank you!

that’s a very cool setup. Can you share your settings (hardware/software)

For solar forecasts, it appears Solcast has data that covers Australia (didn’t check NZ…). There is no built in integration for them yet, but you could roll your own if you’re feeling adventurous. It looks like they have a free tier that can do ~10 queries per day, which could be enough to be helpful

1 Like

Hi Markus, I am facing the same issue. Unfortunately the custom integration isn’t supported anymore. Anyways I wanted to switch to modbus integration of the Kostal Plenticore inverter. For now I started testing how the setup would look like, so I still need this custom integration.
Meanwhile there is official support for kostal build into HA Kostal Plenticore Solar Inverter - Home Assistant. But my guess it will have other entity names and this would require to rework my Grafana dashboard based on the entities.
I had a quick check and already saw that in HAs const.py e.g. ELECTRICAL_CURRENT_AMPERE has been changed to ELECTRIC_CURRENT_AMPERE. Maybe it’s possible to fiy it in the custom integration.


Why did you reply on my message? I was stating that the release notes had a wrong link :stuck_out_tongue:

Either since updating to 2021.8.2 (and adding the template: to my packages) or since adding the cost and compensation entities to recorder I see the processor ram go above 85. I’ve never seen alerts for this in the 4 years using Ha… and the instance locks and needs rebooting daily.

Anyone else seeing this?

Markus, please have a look at Integration not working anymore after HA update to 2021.8.4 · Issue #26 · ITTV-tools/homeassistant-kostalplenticore · GitHub where I described the required changes in the const.py file of the homeassistant-kostalplenticore integration. It worked fine for me, the entities are available again.

My Shelly’s are timing out i add unicast to see if solved but they keep lossing connection

Logger: homeassistant.components.shelly.entity
Source: components/shelly/entity.py:255
Integration: Shelly
First occurred: 4:07:25 AM (19 occurrences)
Last logged: 4:19:48 AM

Setting state for entity Casa - Luz Cocina failed, state: {'turn': 'off'}, error: TimeoutError()
Setting state for entity Casa - Luz Cocina 2 failed, state: {'turn': 'off'}, error: TimeoutError()

Also TP-Link
i do had my HS300 as strips with IP address on config

Logger: homeassistant.components.tplink
Source: helpers/update_coordinator.py:219
Integration: TP-Link Kasa Smart (documentation, issues)
First occurred: 4:07:21 AM (9 occurrences)
Last logged: 4:19:32 AM

Error fetching Alita 2 Finnex data: Communication error
Error fetching Alita Nano Led data: Communication error
Error fetching Alita Air Pump data: Communication error
Error fetching Alita 2 Plug 2 data: Communication error
Error fetching Alita 2 Heater data: Communication error

Also Supervisor is suddenly looks like it lose the network

Source: components/hassio/websocket_api.py:109
Integration: Home Assistant Supervisor (documentation, issues)
First occurred: 4:10:48 AM (9 occurrences)
Last logged: 4:10:48 AM

Failed to to call /network/info -
Failed to to call /resolution/info -
Failed to to call /os/info -
Failed to to call /addons -
Failed to to call /store -`

Something seems broken on logbook card. Custom entries created with logbook.log service no longer appear in this card.