2022.11: A heck of a release!

Problem solved with release 2022.11.2.

Every works fine again!

I didn’t like that backwards compatibility was broken for the statistics module for no good reason, but at least there was a warning message.

Otherwise, I had actually been waiting for this release, because it fixes the EnergyFlip integration.

On top of that it seems there have been some UI improvements. The most important feature is that it still works.

1 Like

Home Assistant OS Not Supported By Home Assistant 2022.11

Upgrade to 2022.11 caused Home Assistant to identify my Home Assistant OS (VM) install in as an unsupported OS. - under three different categories:

  • Unsupported system - Operating System

  • Unsupported system - Systemd issues

  • Unsupported system - CGroup version

Does anyone know what might cause HA to not feel at home in Home Assistant OS? I have been unable to find any related posts specific to HASSOS and can’t think of anything about my configuration that might be different from others.

Chances are, your issues were there before 2022.11, but it just wasn’t notifying you like it does now.

Since it looks like you’ve rolled back to 2022.10.4, if you go into Settings → Repairs → 3 dots at the top right, then ‘System Information’, do you see Unsupported system? If so, then it wasn’t 2022.11 that caused it.

Go to the thread that is dedicated to this subject.

1 Like

A Cure for Graphs

If you don’t like the way HA now displays your graphs in the Info tab when clicking on an entity (and plenty don’t), help is at hand. The Interactive History Explorer card can now replace the normal (and now massively disliked) HA default. Here is the announcement post New interactive history explorer custom card - #378 by HeyImAlex and here is the repo. GitHub - alexarch21/history-explorer-card: A card for Home Assistant Lovelace for exploring the history of your entities interactively and in real time. and a screenie


The system is reported in Settings → Repairs → System Information as “Supported” and “Healthy.” I will post on the correct thread so that others are aware. Thanks to all for your help.

could it at all be possible, that updating to 2022.11.2 causes an error on the Rest platform?

I didnt edit any of that in my config, and yet:

Package package_energy_dayprices setup failed. Component rest cannot be merged. Expected a dict. Package package_iungo setup failed. Component rest cannot be merged. Expected a dict. Package package_weather setup failed. Component rest cannot be merged. Expected a dict.

taking out the 3


configs validates the checker…

yep, serious bug introduced…Rest in package · Issue #81812 · home-assistant/core · GitHub

because of Adjust REST schema validation by epenet · Pull Request #81723 · home-assistant/core · GitHub
quality assurance testing must have slipped…


Hi, updating to 2022.11.2 broke my google calendar - gcal sync. revert to 2022.11.1 solved the issue. I guess there might be something wrong with gcal bump

2022.11.0 screwed up lifx somehow. Seems ok in 2022.11.2

The automation “Light on when dark” has an action that calls an unknown service: lifx.set_state .

This error prevents the automation from running correctly. Maybe this service is no longer available, or perhaps a typo caused it.

Calling it manually resulted in set state ignoring the ‘brightness’ parameter.

Serious lack of QA on that one.

Thanks for the info, card-mod seems the tool to use, with the examples I could make the margins/corners go away.

Now I just need to brush up on my CSS knowledge to do more advanced stuff as I don’t really mind the round corners, it is more the (IMHO) inconsistent margins/paddings.

Thanks for checking CChris . I think it is indeed the round corners that made it more visible.

I was expecting margins/padding like on the energy dashboard. I think I can use the cardmod custom card as mentioned earlier in the thread to get those added.


So I ended up with this cardmod CSS code

  style: |
    ha-card {
      border-radius: 0;
      padding: 8px;

Which gives me a similar looking padding as on the energy dashboard and I like how this looks

Full view

1 Like

I recently updated but now I get a dict error on my restful configuration which worked perfectly fine before. I didn’t find anything related at first glance to the restful configuration in the breaking section.


  packages: !include_dir_named packages


  - resource: https://www.meteo.be/services/wow/ajax/getLatestObservation.php?id=eb83b402-87d8-e911-b3b9-0003ff59a783
    scan_interval: 60
      - name: "vlinder_data_temperature"
        value_template: '{{ value_json["primary"]["dt"] }}'
        unit_of_measurement: '°C'
      - name: "vlinder_data_wind_speed"
        value_template: '{{ value_json["primary"]["dws"] }}'
        unit_of_measurement: 'km/h'
      - name: "vlinder_data_wind_direction"
        value_template: '{{ value_json["primary"]["dwd"] }}'
      - name: "vlinder_data_humidity"
        value_template: '{{ value_json["primary"]["dh"] }}'
        unit_of_measurement: '%'
      - name: "vlinder_data_pressure"
        value_template: '{{ value_json["primary"]["dm"] }}'
        unit_of_measurement: 'hPa'
      - name: "vlinder_data_rainfall"
        value_template: '{{ value_json["primary"]["drr"] }}'
        unit_of_measurement: 'mm/h'


homeassistant.exceptions.HomeAssistantError: The system cannot restart because the configuration is not valid: Package rest setup failed. Component rest cannot be merged. Expected a dict.

As stated, worked on 2022.10.5 as expected. Stopped working after upgrading to 2022.11.2 upgrade this morning. Not sure (never encountered an issue) if I can safely put the 2022.10.5 release back? Or would like to know what’s suddenly wrong with the setup restful integration?

Search a few posts up…

Also, always check the integrations listed issues. It’s raised


No one take the bait please. Thanks.


@frenck wrote in the release note that we now can use config_entry_id() in templates.
That of course only works for UI configured integrations, not for the yaml ones.

Is there a workaround / other way to achieve the reloading of a yaml configured integration?

1 Like


Logger: homeassistant.components.history
Source: components/history/__init__.py:85 
Integration: History (documentation, issues) 
First occurred: 11:35:57 (5 occurrences) 
Last logged: 12:15:08

WS API 'history/statistics_during_period' is deprecated and will be removed in Home Assistant Core 2022.12. Use 'recorder/statistics_during_period' instead

why would core integration History throw a warning of deprecation…?

They are refactoring the statistics getter endpoint in the websockets API. It’s a renaming of the endpoint. To make things ‘look more logical’ on their side. It will completely break all components using LTS, including core and custom cards. They will all have to be changed and updated to the new endpoint, otherwise they will break in 2022.12. For a completely unnecessary rename that gives zero functionality or stability advantages. And supporting the old endpoint for backwards compatibility would have taken less than 10 lines of code.


The cavalier attitude towards breaking changes in this project really blows my mind. A breaking change should be an absolute last resort thing, not something you do casually just because you feel like it.


Its an internal api that isn’t meant for outside use. It just so happens that custom “items”, have access to this api. This is what you signed up for when you make custom things for HA. Add your stuff to core and it’ll get fixed for you without it being a breaking change.

HA has stated many many times that they will do whatever they want with their api. At least they notify custom “items” now, they never did in the past.

Every project I’ve ever worked on in 20 years of development does this with their internal api’s. This shouldn’t be anything new for you.

Now breaking changes for the users… yes, it’s a bit overboard at times.


Why don’t you gauge interest for a fork? The current developers have no interest in creating production value.

1 Like