2022.2: Let's start streamlining!

Where is this error seen and is it actually preventing you upgrading to 2022.2.2?

What is your install type (see in the info page).

It is shown by the check_config add on. I don’t know if it is preventing the upgrade, but the upgrade isn’t happening. I tried to upgrade, and it seemed to start the process but after a while just reverted to the config screen again, showing the upgrade available. I checked the backups and no new backup. Supervisor log seems to indicate a backup starting, but it doesn’t seem to finish.

I am running HAOS 7.2 on Raspberry Pi 4.
Supervisor is at 2022.1.1
Core is at 2021.12.10 showing 2022.2.1 available.

I tried a manual backup but is says backups are not available, system is in a freeze state. I restarted core, no change. I restarted Host, no change.

Not sure what to try next?

Just noted that Supervisor Log now includes:

22-02-05 13:30:49 INFO (MainThread) [supervisor.homeassistant.module] Backing up Home Assistant Core config folder
22-02-05 13:56:32 INFO (MainThread) [supervisor.backups.manager] Found 4 backup files
22-02-05 13:56:32 INFO (MainThread) [supervisor.backups.manager] Found 4 backup files
22-02-05 13:59:22 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
22-02-05 13:59:22 INFO (MainThread) [supervisor.resolution.evaluate] Starting system evaluation with state CoreState.FREEZE
22-02-05 13:59:22 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete
22-02-05 13:59:22 INFO (MainThread) [supervisor.homeassistant.api] Updated Home Assistant API token
22-02-05 13:59:33 WARNING (MainThread) [supervisor.jobs] ‘Supervisor.restart’ blocked from execution, system is not running - CoreState.FREEZE
22-02-05 13:59:50 ERROR (MainThread) [supervisor.utils] Can’t execute restart while a task is in progress

And now it seems to have completed a backup and is moving on to the upgrade…. Will go mow the lawn and come back and see how its going…

No automation for that?


Legacy Nest - #7 by allenporter has the rationale

No reason to switch from homebridge but the setup was cut by 50% (no more url setup or pubsub config). Check out the integration video which takes about 15 minutes to get it set up.

Just notice that a button entity has been created for all my aqara devices: contact sensors, motion sensors, buttons, weather senor. These showed up as a result of updating to latest version. I was a couple versions back so the creation of the devices might be related to the release that had the button update. They popped out because they all have a state of unknown associated with the latest release. They all have the long device name like:


The names I assigned to all of these devices are more readable. These just seem like needless entities with useless unknown state. They can’t be deleted via the GUI. Anyway to remove them? Is there any good reason they were created?

Nope, and it seems patience was the key. After mowing the lawn, the update was completed successfully it seems. Haven’t tested everything yet, but the basics seem OK.


It was mentioned in the release notes. Some devices had an identify button added to assist with distinguishing them. This is most helpful with lights.

The file name you posted starts with the device make/name, and ends with identify.

I don’t think there is a way to remove it, but you can disable it.

It can quickly get heated, especially in such release note threads. As long as we all can calm down eventually and refrain from attacking each other personally no harm is done.

That aside, feel free to join the beta and help out by providing feedback early on. The more the merrier.


Agreed. I’ve joined the beta, reloaded Supervisor and look forward to what’s coming down the pike.

Are the beta versions noted as such when an update appears in Configuration? I assume I can choose to skip versions as in the stable channel? Right now Configuration says OS 7.3 is available, but when I click on it, it says No update available for Home Assistant Operating System. Actually, I think I’ve experienced that before with the last OS update. Cheers.

1 Like

When you want edit Lovelace and press on the EDIT Button of a card, the popup to change things is not working in Safari. (Cleared my cache, reboot HA didn’t work). It work in Firefox
Before this update it worked correctly

1 Like

I do like the new release a lot. So many improvements. I’d like to encourage people to join the beta next time: it helps you, it helps the developpers, it helps the community. And you can watch the funny cat gifs in the discord beta channel :joy::wink: Just don’t forget to make a proper backup of your system upfront.

1 Like

Currently there is no beta running. According to schedule it starts a week before the release.

There are a number of buttons now for stuff like rebooting a device.

What state do you think such a button should have?

Absolutely understandable and absolutely correctly recognized!

And as you can see well, you are already “admonished” the usual suspect here. I bet two, three more comments and you will be banned here.

1 Like

Seems t me if it’s a button associated with an operational device then it should be in the on (operational) state

Really, you’re going to start this conversation up after everyone was asked to stop? Please step away. These arguments are useless.


then it should be in the on (operational) state

Then it would be a switch, not a button.

Think about a doorbell. What state should the button have? It’s not on or off. It’s just a button. How about a reboot button? What state should that have?