2022.3 - how to use text to speech on media device?

Prior to the latest 2022.3 update I could go to my HA Overview where I had a media card for my HomePods/speakers and tap it and there was a place to input text I wanted to play to the speaker. It was very helpful when trying to communicate with kids in basement.

The latest update removed this ability and now prompts me to use the media player. I go to the media player and select TTS and can input text but it only plays back on the computer/phone. How do I output to the device? Feels like a step backwards :frowning:

2 Likes

Bottom right hand corner of the media dashboard. Select the player you want to TTS with.

Untitled

But yeah, I would prefer if this was still in the pop-up for media players too.

2 Likes

Thanks

I only see the web browser option

Do I have to do anything to configure what speakers show up?

(And do you know if there is an official way to make a request for feature change? Unclear why the prior approach was removed. It was so convenient.)

What sort of media players?

They probably need to be added to media sources.

I’m my Configuration->Devices I have HomePods and Denon AVR setup. I had media player cards on my lovelace overview page.

I never had problems.

With this new UX I’m trying to see how to access these devices to play text to speech.

I googled “media sources” and found this resource:

Sounds like I need to add my HomePod and Denon entities to my configuration yaml file?

No, the developers need to add homepod media players to the media sources.

Post in the release notes topic, that homekit media players do not show up as a source, and open an issue.

Bummer :frowning:

Thanks for confirming

See what to do about it in my edited post above.

Thank you!!

Thanks again for the coaching on filing the issue

I also added a feature request to bring the prior TTS capability back:

Not sure if it’ll get any votes, but figured worth a shot :slight_smile:

5 Likes

Might join you in rolling back as when I select a sonos speaker it switch’s view and only shows local media, no option to do TTS.

1 Like

I too am missing any device selection from the Media browser. The only option I have is Web Browser. I do have 3 Echo Dots and 2 Echo Shows that I have built into automations for sound effects and notifications and still work normally. Not sure what is needed to have these devices show up in the device selection.

Any suggestions?

1 Like

I have the same issue. No chance to get TTS working on my players via the media section. This “update” is one of the worst “improvment” I’ve ever seen in home assistant. It’s simply a very huge step back. Please, bring back the functionality as before, thank you.

1 Like

Has anyone found a way to use homepod mini as sound output for /tts from home assistant ?

Bump, let’s bring this topic back up.
I place a same question than previous, have anyone got HomePod to play tts/media after 2022.3?

I was able to figure it out, but not trivial

High level steps:
Add HomePods to integration and make sure to check the box during setup to turn on at startup (can’t remember exact copy but it’s the only checkbox)

After integrated then you can test TTS by using the “call service” in developer tools, choosing the TTS service to play to your HomePods and confirm it is working

Assuming you can play then you can create a script to play whatever text you enter and launch from dashboard card (took me a while to figure this out but I can provide coaching if you need it)

I guess you was pointing NOT to tick that checkbox

sorry - yea, my memory was bad (if that “was” checked, it wouldn’t work)

let me know if you need further assistance - took me quite a while to get it figured out (wish it hadn’t been broken a few releases ago - everything was so good then, and easy for us newbies)