2022.8: You can fix it!

Any Luck with Eve? I haven’t been able to see my devices through Home Kit Controller yet, not sure if I am missing something

Broadlink is also not working for me.

older Eve devices may not work… but you’ll still see them. we are waiting for the 2022.8.1 update to hopefully fix this part.
that, to get them detected, you might have to reset them after removing from HomeKit. I had to hold the reset button for a few seconds to get them detected by Home Assistant.

hmm, so that means another option to get data updates working is to remove BLE monitor? I have only left it installed to compare against the new native BT integration, but if it interferes with data updates, then I’ll reconsider!

Nevermind, I understand now that “active scan” needs to remain enabled in the old Passive BLE Monitor. I had disabled that option right after updating in the theory it wasn’t needed anymore.

Im getting this error when i try to update.

1 Like

I use the custom firmware with the new Xiaomi BLE, you just have to change to ‘Mi Like’ in the settings

1 Like

Big thanks you to @DCSBL for creating the Homewizard water integration before it even officially is delivered! Looking forward to playing with it as soon as it arrives!

1 Like

If possible mods could move this and the former two posts to a new dedicated topic.

I could imagine a (temporary?) internal mapping table so legacy naming and automated/default naming work in coexistence.

What I don’t want to loose is the history - stats in the recorder db and in InfluxDB etc. They all are based on entity_id‘s so to maintain history there seems to be a bit of effort and good ideas needed.

But I don’t expect to get all answers today, as stated it will take a lot of time (don’t know what that is in calendar time, I guess at least months if not 2 to 3 years maybe).

1 Like

Look up home relay assistant

2022.8.1 update didn’t work for me, but I’ll try again Saturday when I get my new bluetooth adapter.

2022.8.1 didn’t solve the problem I’m having with my old Eve Room.
Still same error mentioned in 1st gen Eve Room, Bluetooth and 2022.8 - #4 by zadigre

Exact same error in the log…

Hopefully the ones I ordered have the same issue

I’ve tried to install both 2022.8.0 and 2022.8.1 several times but nothing happens after Core backup is done. Any help? This is what I’ve got:

22-08-05 08:26:10 ERROR (SyncWorker_4) [supervisor.docker.interface] Can’t install ghcr.io/home-assistant/qemux86-64-homeassistant:2022.8.1: 404 Client Error for http+docker://localhost/v1.41/images/ghcr.io/home-assistant/qemux86-64-homeassistant:2022.8.1/json: Not Found (“no such image: ghcr.io/home-assistant/qemux86-64-homeassistant:2022.8.1: No such image: ghcr.io/home-assistant/qemux86-64-homeassistant:2022.8.1”)
22-08-05 08:26:10 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

1 Like

If you need me to do some other test, please do not hesitate to contact me.


Is this what you are referring to: https://assistantrelay.com/

I think I may have found the problem. I have the RM4 Pro and some RM3 devices. After upgrading to 8.1, I noticed some of the lights and switches were working and some aren’t. Further investigating that the one that did not work was that the command was setup using the older method. Which looks like this.

  - platform: broadlink
    mac: !secret RM4_mac
     # Ceiling Fan
    - name: Ceiling Fan Light
      command_on: JgAwABYcNBw1Nhs2HDUcNRscNRw0HDQcNQABohsbNRw0Nhs3HDUbNhscNBw0HDUcNAANBQAAAAAAAA==
      command_off: JgAwABcbNRo3NRw1HBo2GzYbNRw0GzYaNgABoRwaNxo2NRw2HBo2GzUaNhs2GjYbNgANBQAAAAAAAA==
    - name: Ceiling Fan Summer
      command_on: JgAwABcbNhs1NR00HRk2HDUbNTYbGzY1HAABoR0ZNho3NR00HRo1GjcaNjUdGTc1HAANBQAAAAAAAA==
      command_off: JgAwABkZNhs1NR40HRk2GzUbNho2GzUbNgABoR0aNRs2NR00HRk2GzYaNxo2GzUbNQANBQAAAAAAAA==
    - name: Ceiling Fan Winter
      command_on: JgA0ABkZNxo3NB00HRo3GTcaNzQdNB0aNwABoB0aNxk3NB00Hhk3GTcaNjUcNRwbNAAJLAoADQUAAA==
      command_off: JgAwABkZNhs1NR40HRk2GzUbNho2GzUbNgABoR0aNRs2NR00HRk2GzYaNxo2GzUbNQANBQAAAAAAAA==
    - name: Ceiling Fanlight
      command_off: JgAwABkZNhs1NR40HRk2GzUbNho2GzUbNgABoR0aNRs2NR00HRk2GzYaNxo2GzUbNQANBQAAAAAAAA==
    - name: Ceiling Fan Lights Only
      command_on: JgAwABoYOBk2NB40HRk3GjYaNzQeGTY0HgABnx4ZNxk3NB4zHhk2GTgZNzQeGTc0HgANBQAAAAAAAA==
      command_off: JgAwABkZNhs1NR40HRk2GzUbNho2GzUbNgABoR0aNRs2NR00HRk2GzYaNxo2GzUbNQANBQAAAAAAAA==
    - name: Ceiling Fan Only
      command_on: JgAwABkYOBk3NRw0HjQdNB0ZNxk3GTgZNwABoB0ZNxk4NB00HTQdNB0ZNxk4GTcZNwANBQAAAAAAAA==
      command_off: JgAwABkZNhs1NR40HRk2GzUbNho2GzUbNgABoR0aNRs2NR00HRk2GzYaNxo2GzUbNQANBQAAAAAAAA==

The ones that were working was setup using the latest method. Which looks like this. The file is hidden btw.

    "version": 1,
    "key": "broadlink_remote_24dfa7f1167e_codes",
    "data": {
        "Ceiling Fan": {
            "turn off fan": "JgAwABkbNho2Nhs2Gxs2GjYbNRs2GjYbNgABoRwaNhs1Nhw1HBo2GzUbNho2GzYaNgANBQAAAAAAAA==",
            "turn off lights": "JgAwABoaNho2Nhs3Gxs1GjYbNho3GjUbNgABohsaNxo1Nxs1HBo2GzUbNho3GjYaNgANBQAAAAAAAA==",
            "toggle lights": [
            "toggle summer fan": [
            "toggle winter fan": [
            "summer fan lights": "JgAwABkbNho2Nhs2GzYcNhsbNTYcGjY2HAABoRwbNRs2Nhs2GzYbNhwaNjYbGzY2GwANBQAAAAAAAA==",
            "winter fan lights": "JgAwABkbNho2Nhs2GzYcNhsbNTYcNRwaNgABohwaNhs2NRw2GzYbNhwaNjYbNhsbNgANBQAAAAAAAA==",
            "lights": [

So in short, you will need to use the latest method of programing the code. Luckily, I programmed all the codes in the past, but was still using the older method. I just need to adjust some of the template switches. If my observation is correct, I didn’t see anything about breaking changes for Broadlink.

Cannot change the “unit of measurement” anymore :frowning: I’m trying to change C to F, and does not want to record the changes

1 Like

I’m getting problems with Broadlink after the most recent update as well. Both of my _codes files look something like this;

    "version": 1,
    "key": "broadlink_remote_a043b0702327_codes",
    "data": {
        "kitchen_ac": {
            "turn_on": "JgBQAgwODw4ODQ8ODg8OAANBcToOKw4PDg4PDQ4rDRAODg8ODA8PKg8ODisOKw8ODisOKw4rDyoOKw8NDg8OKw4ODw4NDw4ODg8MDw8ODg8ODQ8ODisODg8rDg4NDw4ODysOKw4ODw0ODg8ODisODwwPDw4ODg0PDg8ODg8NDg8ODg4PDC0NLA0sDQ8ODg8qDyoOLA4ABHpxOg8qDw4ODg4ODyoODw4ODg4PDg4rDQ8NLQ0sDQ4PKg8rDisTRUNCATED",

I have 2 Broadlink devices; an RM4 pro and a RM4 mini. The integration itself seems to load, and both of the devices (and their entities) load, but none of the switches I have defined based on their commands are showing up.

My configuration.yaml looks like this (hasn’t changed before/after update);

  - platform: broadlink
    mac: MAC_ADDR
      - name: Kitchen Air Conditioner
        command_on: JgBQAgwODw4ODQ8ODg8OAANBcToOKw4PDg4PDQ4rDRAODg8ODA8PKg8ODisOKw8ODisOKw4rDyoOKw8NDg8OKw4ODw4NDw4ODg8MDw8ODg8TRUNCATED
  - platform: broadlink
    mac: DIFF_MAC_ADDR
      - name: Bedroom Air Conditioner