2022.8: You can fix it!

I got my LYWSD03MMCs working today with the Xiaomi BLE integration with custom firmware. Just had to set to ‘Mi Like’

Really need to add MAC to the name as all 6 of mine were named LYWSD03MMC and no way to find out which was which. That’s why I tried the custom firmware as the name then was ATC_00_00_00, last 3 MAC pairs.

Yes, there is: Xiaomi BLE - Home Assistant

It’s also a part of 2022.8.
It might be an early version - hopefully further development will address case with multiple sensors better.

Inkbird 308 wifi is tuya-based. If you set it up in the tuya app, you can integrate it with the various tuya integration options

I’m not sure if my Bluetooth range is sufficient enough to reach my front door. I was using thread and homekit up until this past week.

I’m working on flashing an older pi3 I had laying around to act as a Bluetooth range extender.

If i can get it up and running tonight, I’ll update with results.

After the update the UI told me that it detected bluetooth, but once enabling it it is throwing this error: Retrying setup: Failed to start Bluetooth: [org.bluez.Error.NotReady] Resource Not Ready

and this in the logs:
Config entry ‘Bluetooth’ for bluetooth integration not ready yet: Failed to start Bluetooth: [org.bluez.Error.NotReady] Resource Not Ready; Retrying in background

Is there something else that I should be enabling?

I am running HASSIOS on a pi 4b

1 Like

Very cool release! But i’m still waiting for water meters on energy pannel. Water is not energy but resource and it will be greate to see all (gas, electricity and water) resource usages for current month and compare usage by kind and timeline. For example I’d like to see water usage and gas usage for heating of water or compare water usage week to week.
Could you please add water meters like gas meters. Sometimes i’m thinking about making PR with this functionality but, it will be difficult.


Usually that means bluetooth is turned off

You can try turning it on with bluetoothctl power on in the container

Also check

# rfkill list
0: hci0: bluetooth
	Soft blocked: no
	Hard blocked: no

If its blocked you may need to run
rfkill unblock all

I’m running HA-OS on my raspberry pi and I’m not versed in containers (even thou I wish I really knew more about it).
I mostly followed a youtube tutorial named: How-To: Home Assistant TALK TO Google Assistant / Google Home
Best luck man!

the terminal add in gave me an error on turn on and permission error trying the rfkill, not quite sure how else to run privileged commands using the hassio image on a raspberri pi, is there a way to do this that I am unfamiliar with?


bluetooth added my govee devices just fine. for eve devices (i’ve tried eve weather and eve energy), i’m getting 2 errors

Logger: homeassistant.components.homekit_controller.config_flow
Source: components/homekit_controller/config_flow.py:446
Integration: HomeKit Controller (documentation, issues)
First occurred: 2:08:38 PM (6 occurrences)
Last logged: 2:37:12 PM

Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/homekit_controller/config_flow.py”, line 446, in async_step_pair
pairing = await self.finish_pairing(code)
File “/usr/local/lib/python3.10/site-packages/aiohomekit/controller/ble/discovery.py”, line 132, in finish_pairing
pairing = await drive_pairing_state_machine(
File “/usr/local/lib/python3.10/site-packages/aiohomekit/controller/ble/client.py”, line 213, in drive_pairing_state_machine
request, expected = state_machine.send(TLV.decode_bytes(response))
File “/usr/local/lib/python3.10/site-packages/aiohomekit/protocol/init.py”, line 225, in perform_pair_setup_part2
raise InvalidError(“M5: not an error or a proof”)
aiohomekit.exceptions.InvalidError: M5: not an error or a proof


Logger: homeassistant.components.homekit_controller.config_flow
Source: components/homekit_controller/config_flow.py:484
Integration: HomeKit Controller (documentation, issues)
First occurred: 2:08:39 PM (6 occurrences)
Last logged: 2:37:13 PM

Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/homekit_controller/config_flow.py”, line 484, in async_step_pair
self.finish_pairing = await discovery.async_start_pairing(self.hkid)
File “/usr/local/lib/python3.10/site-packages/aiohomekit/controller/ble/client.py”, line 63, in _async_wrap
return await func(*args, **kwargs)
File “/usr/local/lib/python3.10/site-packages/aiohomekit/controller/ble/discovery.py”, line 121, in async_start_pairing
salt, pub_key = await drive_pairing_state_machine(
File “/usr/local/lib/python3.10/site-packages/aiohomekit/controller/ble/client.py”, line 213, in drive_pairing_state_machine
request, expected = state_machine.send(TLV.decode_bytes(response))
File “/usr/local/lib/python3.10/site-packages/aiohomekit/protocol/init.py”, line 129, in perform_pair_setup_part1
handle_state_step(response_tlv, TLV.M2)
File “/usr/local/lib/python3.10/site-packages/aiohomekit/protocol/init.py”, line 87, in handle_state_step
error_handler(tlv_dict[TLV.kTLVType_Error], f"step {expected_state}")
File “/usr/local/lib/python3.10/site-packages/aiohomekit/protocol/init.py”, line 61, in error_handler
raise AuthenticationError(stage)
aiohomekit.exceptions.AuthenticationError: step bytearray(b’\x02’)

any ideas?

org.bluez.Error.Failed was the error that was returned when I tried to turn it on with bluetoothctl

1 Like

Well, it solved itself over time. So all is fine :+1:

1 Like

INKBIRD 308 wifi its Tuya based !! I have to give this a try. Very Cool. Thanks.

First of all, congrats! You make my first days of the month an amazing time! Every release makes this beautiful home assistant better and better…all my love!

I tried the new bt integration, but it gives me this:
DBus service not found; docker config may be missing -v /run/dbus:/run/dbus:ro: [Errno 2] No such file or directory

I’ll obey and modify my dockerfile (should I??)
with this requirement but I don’t know why I have to do it, as long as ble integration runs smoothly for some time ago…

Thanks in advance!

You can rename the device, they also update the entity ID that way.

Ofc we need to be able to identify it with the MAC, I already raised that issue on github :slight_smile:


Big update, great work as usual

The dbus service has access to the bluetooth hardware, the only way for HA to interact with this hardware as the host is for you to pass this service in so docker can access it.

In my case (Unraid) it is /var/run/dbus and it worked great. If you don’t have bluez installed on your host you will need to do that as well

1 Like

No. Still works here.

Try moving the device closer. If you have a bluetooth adapter plugged into a usb3 port, be sure to use an extension cable https://www.usb.org/sites/default/files/327216.pdf. If that doesn’t work, open an issue with logs for aiohomekit and we will see if we have some better suggestions based on the logs

Did you try rebooting the host yet?