2022.8: You can fix it!

Same here. Even broken when using scenes. Also the e14 and the outdoor light. But for some strange reason it’s still controllable when using mushroom cards.

Yeah, I’ve rebooted it a few times, disabled bluetooth in the devices UI, rebooted, re-enabled it, rebooted and it is still throwing the same error. I also removed any other bluetooth related integrations I had been previously using (Bluetooth LE monitor)

The new map colors are MUCH improved.

1 Like

I have trouble with my RM 4 Pro. I configured some remote codes as switches and this function stopped working.

Calling the Service works fine for me. Can someone verify my issue

1 Like

Nice,I’ll do it!:heart:

1 Like

Tried with mushroom cards also.
I’m not able to control the temperature color at all…
Only the color control functions.

OK I tried running bluetoothctl from VSCode since I remembered it runs a root terminal and was sent this error:

root@a0d7b954-vscode:/# bluetoothctl power on
dbus[7361]: arguments to dbus_connection_get_object_path_data() were incorrect, assertion "connection != NULL" failed in file ../../../dbus/dbus-connection.c line 5905.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

Wow. I upgraded and the first thing I saw was:
New Integration Discovered

I didn’t even know my NUC had Bluetooth in it.

Configured and it found this:

What is “hci0”? Is this how HAOS sees my bluetooth in the NUC?

Anyway, this is what the configured integration looks like:

Now what? How do I get it to “discover” any BT devices I have?

hci is an acronym for host controller interface, basically a way for the software to inferface with the hosts bluetooth hardware

Now that you have the bluetooth integration setup if there are any that are currently supported it will auto discover them in time. If they don’t then you may not have any currently.

1 Like

Mine did the same, but I think it is the loss of being able to adjust the temperature rather than the color of the bulb. When I came home, all my bulbs were a bit red-ish. I’m reverting to my backup now to see.

Confirmed, previous version has a temperature and color option.

1 Like

Upgraded during the live stream and was able to migrate my 8 Goove H5075 Bluetooth Hygrometer Thermometer from Passive BLE to the native Bluetooth integration, and I can say I am experiencing a more stable connection on the most distant devices.

Amazing work HA and Passive BLE team!


You need to run it on the host

You can also install the community ssh/term addon and disable protected mode to get into the host

1 Like

Same. I have several broadlink switches in configuration.yaml and all are no longer available.

Thanks, chaps!
Can’t wait for my Airthings sensors to finally get a stable, local bluetooth integration. I’m also hoping for a magician to find a way to integrate Mill sensors through the new bluetooth integration. I love everything local!

I’d love to see battery life alerts in the Repairs section / it be expanded to more than just “this integration will break in the next version”

I’ve got a hallway motion sensor, which has 5% battery left. Definitely need to replace the battery, but it doesn’t show up in the Repairs section. device_class is battery, so I’d imagine it’d be easy enough to iterate through all the batteries in HA, check if they’re under a certain percentage, then report it as an issue that needs to be repaired.

Yeah I could create a dashboard tab that shows all the batteries, or a sensor to list the batteries that need to be replaced, but at the same time, there’s a section for repairing stuff, and “your device doesn’t work because it’s flat” is something that can easily be repaired.


A very easy upgrade for me, thanks team!

Only issue I had was 5 Lifx lights not being migrated (out of ~30), I removed them along with the conifig in configuration.yaml and then re-added them in the front end, all working and only a couple of mins work.

So, hci0 is the BT chip on my host processor? Cool.
Even if I did have any compatible BT devices I doubt that my NUC would be in range. It is in the basement, though Zigbee and Z-wave do find all my devices.

What would be an inexpensive BT device I could buy to test if the integration I have would even work?

Maybe the BT2MQTT mentioned in post 85 by @ mrdj863 might be worth look at…

Good job, devs.
118 posts and only one saying he had to revert to 2022.7

You should take a well deserved bow.


Is 1st gen Eve Room supposed to be supported?
I’m having an error when trying to pair it.

Synology DSM 6 runs bluetoothd version 4.101. So seems incompatible :frowning: Anyone Synology users out there have a way to get it working?