2023.1: Happy New Year of the voice!

Read the full release announcement here
7 Likes

Works fine for me! Nice start of the new year!

2 Likes

Looked like pi-hole didn’t make it to 2022.12.9 - but it works now in this release.
Great work!!

1 Like

Would be possible one day via the new google home SDK to collect some sensor value only defined into GH ?

I’m getting “redirect_uri_mismatch” When trying to set the AUTH for the Google SDK integration.

“Access blocked: This app’s request is invalid”

3 Likes

Props to @bdraco for his amazing work on bluetooth and Yale integrations! It is much appreciated!!

3 Likes

Seems to run well, Thx.
Just 2 custom cards that didn’t want to work anymore. Digital clock and weather card. After downloading them again the issue was solved.

2 Likes

Google Assistant SDK: Fire event with request/response for automations by tronikos · Pull Request #84856 · home-assistant/core · GitHub would have allowed this using events, but we need to wait for a supported way to have return values for service calls, which is discussed in Service calls with return values · Discussion #777 · home-assistant/architecture · GitHub

2 Likes

Thank you for another cool update. Loving the Google Assistant SDK, I used to use Relay Assistant but it wasn’t maintained and became pretty unstable. Resurrecting some old scripts now!

Thank you for the updates to the Local Calender integration; those are the things I really wanted to see in it.

1 Like

A post was split to a new topic: Export Alexa devices

Always excited to see a new release. Happy New Year and a big thank you to all involved.

Interesting, my Pi-Hole integration was working until 2023.1.0. I even removed it and now cannot re-add. Did I miss something in the prior release notes?

You probably need to update Pi-Hole (latest is 2022.12.1, which wasn’t working with Home Assistant until 2023.1).

Already have Pi-Hole 2022.12.1, so sadly that can’t be it.

Discovered that the Harmony Hub Integration is no longer working for me, the harmony conf file no longer has any devices or activities in it.

Great work! I can’t wait to have voice assistant working locally!
Regarding the new Reolink integration, I’ve tried it with my Wi-Fi doorbell and I can only see the camera entities but nothing else… I was expecting for a sensor when the button is pressed, is that in the works?
Thanks!

I’ll also report that the Pi-Hole integration seems to have broken with the upgrade to 2023.1.

Latest Pi-Hole is installed.

Pi-Hole Integration not working - Configuration - Home Assistant Community (home-assistant.io) looks like the issue to follow.

I’ve tested the official Reolink integration with RLC-520 and RLC-820A cameras, and the resulting camera entities appear to work fine (other than the main streams on the RLC-820As, although I suspect that’s due to issues with H.265).

1 Like

This update seems to have wrecked my system. Only been using Home Assistant for a couple of weeks, so maybe I did something stupid, but I can’t work out how to go back.

After installing the update, restart took a long time, then I got a notification “Setup failed for custom integration ltss: Requirements for ltss not found: [‘geoalchemy2>=0.8,<0.9’]”

Not knowing what I else to do, I found the backup made before updating and clicked restore. When HA restarted, it had the same error about ltss.

So I went to look at configuration.yaml, but could not start studio code server. I tried installing the basic file editor add-on; it appeared to install, but cannot start.

So I went and restored last night’s backup. Same issues. (What are the backups for if they don’t work to restore the system?)

I guess when I get home I’ll wipe the system and start again, unless anyone can suggest a simple fix. I’ve only been running this instance since new year, so not a great loss (and I have the data up until I ran the update, assuming I can get a new install to connect to it).

But very keen to understand just what I did wrong.