2023.2: How can I Assist?

It’s conversation:

1 Like

Thanks saw a other post so was little to fast.
Then only my migration database question is still there :slight_smile:

I’m using the custom integration “Daily Sensor” for this purpose, doesn’t help for your query of course but it’s an alternative without dependencies to SQL-Queries.


Yep, this appears to work! Many thanks!!!

Solution from m0wlheld gives me empty result. But, i guess i forgot to mention that i use mariadb on synology, not built-in database from HA…sorry for that… some commands are a bit different…
Although i don’t know what i’m gonna do, since synology hasn’t updated mariadb yet, so i’m stuck with critical warning in HA…

Assist will always use the system language that has been set in the user settings (at least for now… The devs are still continuing the development - so more features and options are likely)
So if you do have a user with language setting “english” - Assist will work in english.
If you do have another user witch Czech language setting, assist will use czech for this user.

For your entities - you should use Aliases - if you want to translate the entity name into different languages for assist.

Exactly that. If you have Bluetooth support in HA (stick, PoE or Bluetooth Proxy) - it will just pop up after you provide power.
Just a warning/heads up - connectors, if you buy with them (and make sure you get B model) they are TINY, not standard dupont cables.

1 Like

I have lots of issues from this release, but Sonos isn’t one. I’m running HA in host mode in Docker but the host is on the same network as the Sonos system.

That’s awesome! If it works as well as my DFRobot one at a fraction of the cost and size I’ll be pretty impressed!

I was going to buy the no-pin B version and solder on some pins myself as have loads lying around. Would that be a bad idea… After typing that I just realised it’s exactly the same price for one with pins.

Bah… now i have database address problems… above select works in “phpmyadmin”, but i can’t insert it into HA, because sql integration says database url invalid…? it was valid until now…?

mysql://root:[email protected]:3306/homeassistant?charset=utf8

(IP address is IP of my synology)

I tried with built-in database, but in sqlite above select is not correct…

My dB is much (much) smaller than that. So I’ll give it a go later and see what happens

Sorry, it’s a no-go. While sql works in phpmyadmin it doesn’t in HA. Above mentioned “invalid url” is a consequence of bad SQL, as it seems.

does the ESPHome upadte mean you can’t share ESPHome devices between instances?

That’s strange… For me the query works in HA. I’m using MariaDB 10.5.18.

How did you create sql sensor? With integration -->add --enter data, or did you write it in configuration.yaml?

I have Home Assistant in my own language (dutch) but it doesn’t seem to understand anything. Not in dutch, not in English… Useless in this way

For anyone running Debian Bullseye (current stable), you may want to upgrade python from 3.9 and mariadb from 2.5 to 2.6 (see Breaking Changes above).

Disclaimer: YMMV, but I found these two guides helpful and they Work For Me ™, so far…

For mariadb you can use packages from the official repository rather than Debian.

Unfortunately I couldn’t find packages for Python, so that involves building your own, installing alongside the default 3.9 and then making 3.11.1 the default. It should therefore be possible to return to using official packages when Debian provide them.

How To Install MariaDB 10.6 on Debian 11 “bullseye” | Open UNIX Kernel

How to install Python 3.11.1 on Debian 11 bullseye (aruljohn.com)

All that said, I’m not yet seeing 2023.2 as an available upgrade using pip with HA Core :frowning:

I have it in my configuration.yaml, because I hate having SQL code in a config dialog. I use the SQL component from HA 2022.4 (last good version) as a custom component to achieve that.
But just for you I’ve created a sensor with that query with the GUI and it works exactly as my configuration.yaml sensor.
Did you fill the “Column” field correctly? Should be “min_temp” if you copied my query.

Ok, now i see that your solution is for HA’s internal sqlite database. Now i switched to HA’s internal db for testing and your sql works. I guess that “DESC” will give me max temperature, while “ASC” will give me min temperature today, correct?

So, i guess one of solutionsis to switch to internal db, especially since synology is know to give out updates pretty late, so i coudl be stuck with critical warning for weeks, months…

There are two things I noticed in this release that I had to back out the changes. The first is with “Safari”. In the past, this has worked fine allowing the browser to display and administer Home Assistant. However, with the latest release and opening the Home Assistant URL, the screen is blank with the Home Assistant Icon. If I run the same workflow on a different browser such as “Fire Fox”, it works as I would have expected. Did the requirements change and “Safari” is no longer supported? The other issue I found was with MQTT. This integration communicates with “Solar Assistant” to render information regarding solar production, inverter and battery status. After the update, the MQTT entities for Solar Assistant could not be found even though both were carrying on a conversation. Looking at the logs I can see MQTT message received but it looks partially processed. With that said, I had to back out of this release to the previous one. Sadly.

After the update, my Fire Tablet 7 with Fully Kiosk shows only a white screen, sometimes with the blue HA icon. Then nothing happens, looks like it hangs. It looks like a similar problem as in the past in older versions: Problem with 0.99 and Fully Kiosk + Fire Tablets?
Fully Kiosk works allright with a different url/webserver.
Cleared the cache etc. in Fully Kiosk. Nothing changed. As I said, the same behaviour as in version 0.99.
EDIT: I tried WallPanel app on my tablet, exactly the same behaviour. With other url, WP works fine.

EDIT: Updating to 2023.2.1 solved the problem. (Update frontend to 20230202.0)